Question about 2004 Volkswagen Jetta

2 Answers

1.8t engine stumbles when under load.

I changed my oil, oil filter, plugs and Air filter yesterday. took it on a test drive and it drove just fine for four miles. then the engine started stumbling when i try to accelerate or go up hill. can't fnd a vaccuum leak and there is a check engine light that flashes from time to time?

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 322 Answers

Have it scanned with a scan tool, check the gap on the plug or see if the righr plugs where used.

Posted on Jul 19, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 179 Answers

I would unhook your mass airflow sensor and drive the car if it runs better unhooked then it is confirmed that you have a bad mass airflow sensor. then you can replace it. also make sure you hooked up your plug wires correctly. hope this helps!!!

Posted on Jul 19, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

ENGINE IDLE / ENGINE CUTS OFF


Its a sensor that increases the idle under load so it could be a sensor on the power steering rack or a sensor on the autobox when in drive with foot on brake ,its a sensor for sure but what and where i have no idea

Jan 29, 2014 | 2008 Chevrolet Trailblazer

1 Answer

2010 HHR runs rough after oil change, no power will not shift into next gearr and dies


Take your car to a real shop, not one with pretend mechanics, and have it evaluated by a qualified mechanic for engine damage. It sounds like they either forgot to put oil in, or didn't tighten the drain plug or filter and you lost most of your oil. If damage is found, and the qualified mechanic states that the damage could be due to oil starvation, file a claim with Meineke. Be prepared for a runaround (hundreds of YouTube videos on these ripoff shops - Meineke, Jiffy Lube, etc).

Apr 09, 2017 | 2010 Chevrolet HHR

1 Answer

I HAVE A 2004 ACURA MDX, PUT SCAN TOOLS TO READ CODES. THE CODES ARE ALL CYLINDER MISFIRING DETECTED RANDOM/MULTIPLE CYLINDER MISFIRE...NOW I CHANGED THE SPARK PLUGS, NGK PLATNUM FROM AUTOZONE, CHANGE THE...


Sounds like a bad PCV valve or bad EGR valve. replace the PCV valve ( about $10) locate and watch the EGR valve .. it should move up and down when you rev the engine.. spray the shaft with WD40 if its sluggish or stuck.. it may help.

Jan 06, 2011 | 2004 Acura MDX

1 Answer

Cruise control not available,gearbox default, codes will appear and then i disconnect battery and codes go away for about one day and then reappear when codes are on car does not drive. when codes are not...


i pulled the battery and had it tested, they said it was fine so i changed the air filter. under the battery i pulled the rubber plug and the allen plug and filled the transmission with 6 quarts of transmission fluid while the car was running like you guys said. gearbox ,cruise not avilable, and engine light went away drove for ten miles and everything seemed great

Dec 27, 2009 | 2002 Jaguar X-Type

2 Answers

Sudden poor fuel economy on a 2001 Grand Caravan 3.8l


a partial plugged cataylic convertor would case this. and under a load like towing a boat should have thrown a code. a exhaust back pressure test would show this. but normal driving would not throw a code.

god bless you for serving our country!!!

Aug 04, 2009 | 2001 Dodge Grand Caravan

1 Answer

94 Buick Century 2.2 L4


Seems as though you've got it covered...Try adding "SeaFoam" ($9) from Advance Auto Parts and add it to your gas...drive for at least 100mi. Good Luck

Jun 27, 2009 | 1994 Buick Century

2 Answers

1999 Dodge Ram 5.9L 4X4 not enough fuel


check the fuel filter and the EGR valve

May 07, 2009 | 1999 Dodge Ram

1 Answer

89 Wagoneer drives rough


The thing to do now is a fuel pressure test pump could be weak just a few pounds under the recamended pressure will do that weather its mechanical or electrical . Is there a filter in the carb. wear fuel fine hooks? If none of this is an issue at least you can eliminate fuel deliverly as the problem.

Apr 19, 2009 | 1989 Jeep Grand Wagoneer

Not finding what you are looking for?
2004 Volkswagen Jetta Logo

404 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volkswagen Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8270 Answers

Are you a Volkswagen Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...