Question about 1989 Honda Accord 4 Door

1 Answer

Turn signal, tachometer, fuel and temp guage stopped working

'89 accord. Turn signal, tachometer, fuel and temp guage stopped. Fuses ok, replaced turn signal and hazard relay. Should I replace the turn signal switch next?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 25 Answers

You should pull out the gauge cluster and check the connector on the back side of the cluster.. i bet that is the issue

Posted on Jul 31, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My turnsignals dont work on my 1987 honda accord flashers do work


flashers and turn signals have separate flasher and separate fuse.

Mar 14, 2016 | Honda Cars & Trucks

1 Answer

2000 mpv . my dash and turn signals stopped working. i have no fuel guage, odometer, rpm, temp guage or turn signal. the turn signals do work if the hazard lights are turned on. the battery also goes dead...


drivers side kick pannel remove it and you will see lots of conectors make sure that they are pluged in i have see this problem befor. or boky controll mod is shot

Nov 28, 2010 | 2000 Mazda MPV

1 Answer

My Aveo starts up normally and slowly heats up to normal operating temp. But the cooling fan never turns on and eventually the temp guage climbs from the halfway mark to the top mark. I checked the fuses...


Most systems work this way: temp sensor on engine sends a signal to the computer which in turn sends signal to blower relay that then sends signal to the fan.
Any problem along the way, and the fan won't come on.

May 14, 2010 | Cars & Trucks

2 Answers

Signal lights, fuel gage, temp gage not working. Could it be the signal light relay? Where is it located?


This sounds like you have blown a fusible link! Check your main fuses first.

Sep 15, 2009 | 1989 Honda Civic

3 Answers

Fuel Guage & Temp. guage intermittant


there is a voltage regulator that controls both the temp guage and the fuel guage. cost is aprox. 40.00

Dec 22, 2008 | 1990 Nissan Pathfinder

2 Answers

Radiator cooling fan


Just fixed this problem. Replace the sensor or switch on the thermostat housing and viola!

Sep 19, 2008 | 1994 Honda Civic

Not finding what you are looking for?
Cars & Trucks Logo

322 people viewed this question

Ask a Question

Usually answered in minutes!

Top Honda Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you a Honda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...