Question about 2003 Ford Mustang

1 Answer

My 2003 Mustang Mach 1 has a skip in the engine when I first start it up. After I drive it for a short distance ( about 6-7 miles ) the skip goes away. I thought it might be a bad spark plug, so I replaced the plugs. Still skips. I'm wondering if it might be a weak coil pack. Anyone got any ideas.

Posted by on

  • franknyflh1 Jul 18, 2009

    The check engine light didn't come on, so no codes. The suggested solution sounded reasonable. I am on second bottle of STP injector cleaner, and second tank of gas. Skip is gone. It was too simple and obvious. Thanks drallim for the help. I really appreciate it.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,088 Answers

I'd suspect a sticking injector--car should have set the check engine light. Read the code(s) to progress further. If the coil pack were a problem, it would not be likely to fix itself. If the codes indicate an injector problem, try an injector cleaner in the fuel--worst case, replace the bad injector. The codes should indicate which cylinder to change the injector.

Posted on Jul 16, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2007 Suzuki xl7. When I first start down the road it seems to drive fine but within 1/2 to 1 mile it starts running very rough, leaping along. This goes for about another 1 to 3 miles. It runs...


ok and XL 7 but what engine options. gas, diesel, 2L , 2.5L?
what?
and most important , and never ever 1 time stated on this forum
what country.
leaping?

im not sure what you are saying.
it runs ok cold, and as it warms , the engine. it stalls.?
and what does same thing mean.?
my guess, it starts fine then stalls; hot.
but can you save the stall?

stalling is complex. can be many systems in the car.
but can be broken down to :
Ever did the 60k mile tune up,ever? if not why not.
never skip 60k\'s or the motor will run like garbage.


1: lost electrical power. to EFI .
2: bad engine, in that when it gets hot , it loses compression.
3: lost park. 1 or more cylinders, 4 or 6 you never said.
4: bad injection. 1 or 6 of them, flooding or starving.
5: bad fuel.
6:EGR sticking , usually this happens just before a stop sign.
7: if the stall was a bog and the fast right foot saved the stall, easy
the ISC is sticking closed.

Sep 30, 2013 | Suzuki XL7 Cars & Trucks

1 Answer

Mustang 2003 check engine light on. Had diagnostic run at AutoZone and they gave me the following codes: p0316 and p0301. car skips like it wants to cut off. Can I still drive until I get it looked at with...


If the light is flashing - NO. It means you are dumping raw fuel intot eh catalytic converter (very expensive).

If steady, drive sparingly.

01 is cylinder #1 misfiring. Could be spark plug or coil.

16 is misfire detected during start up.

Nov 01, 2011 | 2003 Ford Mustang

1 Answer

My reduced engine power light comes on after a short distance of driving


trailblazer start up cold and drive a short distance and it will not crank just turns over

May 08, 2010 | 2003 Chevrolet TrailBlazer

2 Answers

Transmission not shifting properly, 2003 automatic, 3.8 liter v-6, fluid and filter new and clean. Sometimes if I rev the engine it will catch and drive fine, but it doesn't take off properly, it hesitates...


hate to be the one to say this but possible trans slip how many miles before you changed the fluid most autos with automatic trans require a trans service every 24,000 miles and it is critical in most new cars today sorry......

Apr 15, 2010 | 2000 Ford Mustang

1 Answer

2003 Toyota Corolla oil pressure light flickers then goes to solid after a short period of time. Last time this happened, changed oil and filters and light went away. Now after maybe 1000 miles of driving,...


see if you have any oil level or pressure sensors. sometimes these can get gunked up. You may need a new oil pump. I suggest you start using a senthetic oil (valvoline,mobil 1 is reccomended) after u get the problem fixed.

Apr 14, 2010 | 2003 Toyota Corolla

2 Answers

03 mach 1 cranks no start


A 6 year old car with only 5,900 miles on it would indicate that it was sitting for long periods of time. I would check the fuel filter first if it does not seem to be getting fuel.

I would also check the fuel pump shut off switch, should be located in the trunk on the drivers side. (owners manual will tell you for sure)

Jul 27, 2009 | 2003 Ford Mustang

1 Answer

2003 Mustang engine skipping when accelerating


Does it idle fine? Sounds like a vacuum leak.

Apr 13, 2009 | 2003 Ford Mustang

Not finding what you are looking for?
2003 Ford Mustang Logo

Related Topics:

232 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5501 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...