Question about 2004 Chevrolet TrailBlazer

1 Answer

Had oil changed ,injectors cleaned and air filter replaced Now the speedometer reads 30 instead of 0 at idle

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 135 Answers

Remove the pos.battery cable for 10 seconds to reset the computer ,try that to see if it works ,most time the computer will give a code so ,go to autozone for a free computer check, hope to help you, robert b.

Posted on Jul 17, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 hyundai lantra sportswagon running rough, idling rough also, when accelerating splutters/spurges. Thinking maybe spark plugs or timing belt??


Needs a tune up. Adjust engine timing, replace plugs and plug wires, replace air filter, oil and oil filter, fuel filter and clean fuel injectors, adjust valves.

Jun 13, 2017 | Hyundai Cars & Trucks

1 Answer

1999 mercedes stalling out /code reads 173 basesp light is on reads oil hi stalls when idling did i put bad gas in


Clean throttle body add fuel injector cleaner good one.change a fuel filter and check an air filter.

Jan 22, 2017 | Mercedes-Benz Cars & Trucks

1 Answer

The engine misfires


Take it back to the mechanic.

Feb 16, 2015 | 2008 Citroen C5 2.0

1 Answer

What sensors and filters help save gas


it sound like your van is running rich.the use of those products are not going to improve your gas consumption.instead change air filter .clean or replace air mass sensor.check tire pressure .also a bad fuel injector will make the other ones spray more gas in order to keep engine at idle

Jul 09, 2014 | 2001 Nissan Quest

1 Answer

1999 audi a6 shakes, in ocations violently. Raw fuel smell. Loss of power. Burnt oil smell. idles poorly


If you had the ecu read it would probably say egr code. also a number of other codes to do with injectors and co2 sensor. you need to clean out the egr and clean out the air vent pipe from the sump to the top. also clean out the idle valve on the in take. also the breather pipes. you may even need to change the air filter. and when was the fuel filter changed. an oil change a filter change would not go a miss if it has not been done in awhile. routing maintenance will stop this happening again.

Feb 07, 2014 | Cars & Trucks

1 Answer

My 2003 mazda tribute fuel consumption is 17L/100kms. any help on how to reduce this?


Check your Tire Pressure, Change your Air Filter to a K&N, Change your O2 Sensors, Add SEA FOAM to your Fuel and have an INJECTOR CLEANING PROFESSIONALLY DONE

Apr 08, 2013 | Cars & Trucks

1 Answer

I have a Isuzu Bighorn 4jx1 but is hard starting. When it crank the engine on but bit not pick up speed or it it starts like it was out of fuel. Can you advice on what to do? Hear from you the...


try slightly over filling oil level if engine starts and runs for a minute or two then dies the oil pick up in sump has fallen out (cracked mounting bracket) or sucking air instead of oil. you can remove small tin engine sump after draining to check oil pick ups, after confirming it runs ok for a little while once over filling oil level in engine.
another thing that goes is the rail oil pressure sensor which reads incorrectly and a tell tale sign this is broken is the injector loom connector is full of engine oil when disconnected this is near engine oil level dip stick(wiring loom comming out of rocker cover), the sensors reading can be checked with scan tool before starting with ignition on, (0-0.2MPA) it must read if its reading higher with ignition on only (motor not running) the sensor needs replacing, the engine ECU needs to see approx 200MPA when cranking to get injectors to start to work properly and higher when running at idle and beond (up to about 5MPA at higher revs) if this is not getting to this or readings are fluctuating badly indicating air in oil the injectors wont supply the correct amount of diesel. in which the engine oil comming from low pressure (pickup pump) to then high pressure oil pump to rail and injectors.

Aug 29, 2011 | Isuzu Trooper Cars & Trucks

1 Answer

1999 Expedition - when in idle the speedometer and RPM needles occasionally go wild... any advise_


when was the car last serviced? if recently serviced what service did the garage do? servicing the car at 20,000 km involves changing spark plugs/ clean or change air filter, fuel filter/ engine oil filter in some case it alson involves cleaning the throttle body and cleaning injectors.depends on your climate and driving condition, your car might be having a faulty airflow meter or faulty idle speed control sensor, have those two checked or cleaned then if problem still the same have your car checked by a code reader to pinpoint the problem.

Apr 10, 2010 | 1999 Ford Expedition

1 Answer

Vibration problems in 1kz te


Check calibration. Muffler supports from the front till the back, there should be proper clearance. Is your diesel fuel of proper cetane rating for the engine? Check your belt drive system, is there any part that is excessively draining engine power, power steering pump, air con compressor, alternator or generator? Do these preliminary steps and isolate.

Nov 29, 2009 | Toyota Pickup Cars & Trucks

2 Answers

Hi, 2000 Landrover Freelander 1.8 petrol, failed MOT on CO emissi


check both lambda sensors for breaks in wires and for open circuit on heater side of lambda sensor on the one under the car on the second cat,failed heater element will not heat gas engough for sensor to read causing false readings , also check for slow i.a.c valve on inlet manifold.

Sep 26, 2009 | 2002 Land Rover Freelander

Not finding what you are looking for?
2004 Chevrolet TrailBlazer Logo

95 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...