Question about 2003 Ford F250 Super Duty Crew Cab

3 Answers

F250 a/c not working at 60 mph. works fine at low speeds.

Posted by on

Ad

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I changed the alternator and now the air conditioner isn't working. worked fine before

Posted on Jul 16, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 69 Answers

Check ypur vacum lines may be broked. there is a vacum reservoir device to be used when engin stops creating vacum. look at the vacum diagram sticker at the hood it tell you where are this hoses...

Posted on Jul 16, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 295 Answers

The belt could be loose.
The fan clutch could not be keeping up at high speeds to keep the system cool
I would have the cooling fan checked.

Posted on Jul 16, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is my 06 ford f250 6.0 overheating at low speeds?


at low speed, there is less airflow through the radiator. This could mean the fins are blocked or the radiator needs cleaning internally. It could also mean the fan is not working correctly

Jul 22, 2014 | 2003 Ford F250

1 Answer

2006 dodge ram 1500 low speed steering shudder


The 2006 Dodge Ram 1500 goes from 0-to-60-mph in just over 5 seconds with a top speed of 150 mph. Hope this helps!---------------------------------------------------------
Multi-Diag Access

Dec 04, 2012 | 2006 Dodge Ram 1500

1 Answer

My 1995 Toyota Corrolla spedomter only works at highway speeds (50 MPH). The needle stays at 0 MPH below 45 MPH. I had my mechanic check the speed sensor and that is fine. Any idea what is causing it to...


The speedo is of course electronic, it either has a defective circuit board or the tiny motor that moves the needle is defective. You will need to remove the cluster from the car and send it out to a factory repair center.

Sep 19, 2012 | 1995 Toyota Corolla

1 Answer

1997 ford f250 manual 4x4 diesel with a new speed sensor in the rear end.but speedo still jumps five mph 55-60-55


You might check to see if some reason the plug on the back of the speedo in the dash has come loose. It would take a torx bit to remove the bezzel (trim) There are two torx screws to remove the trim and the four on the speedo unit. I would say if the plug is tight you may have to replace the unit

Mar 25, 2010 | 1997 Ford F250 SuperCab

1 Answer

2003 gmc yukon vibration only at 50 to 60 MPH feels rough like transmition. other speeds are fine.


50-60 mph vibration may be as simple as tires being out of balance or an unevenly worn tire(s)

Oct 18, 2009 | 2003 GMC Yukon XL

1 Answer

My cruise control can be set only at a speed higher than 20 mph. I want to set it even at a speed of 10 mph. How to do this?


Your cruise is not desinged to work at those low speeds. The cruise module needs vacum that your engine cannot produce at those low rpm's. Most will not work under 35-45 mph.

Oct 18, 2009 | 1995 Toyota Camry

1 Answer

I have a 90 Pontiac 6000 that starts just fine everytime, but it misses and shutters when I accelerate. once it's up to speed it runs great and at low speeds ie. 30 - 40 mph it runs great. it just misses...


Check your transmission lock-up. It's programmed to come in at at 40mph. You can replace the lock-up to come in at 60mph or better.
Or you may have some ignition wires going bad or distributor cap has crack in it.

Aug 16, 2009 | 2006 Pontiac 6000

1 Answer

99 f250 SD 7.3


Your speed sensor in your trans. needs to be checked out sounds like its not working or not getting a good signal until its generating enough power and speed to start until it reaches 30 MPH. Check that out sometimes it could just be some dirt on it. It all makes sense the ABS light is on because its not reading the speed of the tires, and the AOD light is on because It has no idea when to shift into overdrive without knowing how fast its going. I sure Hope that Helps You Out, And Thanks, Bear001

Jun 17, 2008 | 2000 Ford F250 Super Duty Crew Cabs

Not finding what you are looking for?
2003 Ford F250 Super Duty Crew Cab Logo

194 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...