Question about 2003 Oldsmobile Alero

1 Answer

Battery is fine but car only clicks when trying to start what is wrong?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 215 Answers

That, sir, sounds like a bad ignition or corroded terminals on your battery or starter. Turn your key forward and cross the starter terminals with a screwdriver, If it starts you have a bad ignition. Hope this helps.

Posted on Jul 16, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car won't start, no sound at all when I try.


If you can get it to an auto parts store they can hook up a computer thing and tell you whats wrong. sounds alot like a bad starter.

May 01, 2014 | 2002 Honda Odyssey

1 Answer

Loud clicking sound when i try to tunr it over


boost, hummmmm ?????????????
a charger with a boost button? (big shops have this)
or you mean jumper cable , jump started from a running other car?


my wild guess. is you always start fine, when jumper cable jumped.
this proves, the
battery in your car is BAD or is only discharged.
for 100 years now, same deal.
try a fresh battery off a good car.
works now, so ??? yours is weak or bad!

but started car , is the voltage 13.3. to 15v? a walfart $10 meter.?
no , then the charge system is bad (charge lamp on?)
note, i said system. not a specific part.

if the charge system is failing.?
  1. bad battery. tha'ts right alts do shut down with battery bad. (open or shorted battery)
  2. loose alternator pulley belt.?
  3. bad alternator wires. connections.? or bad battery cables.?
  4. scan the PCM most 2007 will report what is wrong with voltages and charge. scan it.
engine rpm way below normal at idle 800 is typ. good. 400 dead wrong.
battery cables bad.
battey cables lugs green with corrosion
someone put the minus cable far end to the wrong part>?
this minus cable has correct spot near the starter.
some fit to block others to stater , bolt or bell blots.
to frame is wrong, seen that , with lazy work.



Feb 11, 2014 | 2007 Toyota Tacoma

3 Answers

Car working fine, suddenly wont start


Be sure it is in fact the right gas cap. Often when you purchase from someone like bumper to bumper etc the parts people get the wrong info. I suggest you go direct to the dealership pickup a cap and see if that solves the problem.

Jul 02, 2017 | 2000 Dodge Durango

2 Answers

Car won't start, Hear clicking


Sounds like your alternator isn't working

May 11, 2013 | Cars & Trucks

1 Answer

I had recently had my engin redone VW Jetta 3 CL 1993 model, and when i got it back it was working perfectly, starting fine. 2weeks about after one moring off to work the car started fine but on going home...


Hi Rozanne, It could be a bad connection on the main cable from the battery to the starter motor. I'll need some more details from you though. 1) When you crank the engine is there a clicking sound comming from under the hood? 2) What do you mean by 'short cutting' it. 3) Is the starter turning when you try it on the cars own battery? Can you let me know all the different symptoms the vehicle has from when it worked well and the difference between now and then. Regards Johngee

Oct 03, 2010 | 1993 Volkswagen Jetta

2 Answers

I have an 03 Toyota Corolla "S" and it was running fine then an hour later I go out to start it and it don't start. All you hear is the fuel pump and just one click. Whats wrong?


sounds like your starter is going bad. check the battery connections first. make sure they are tight with no corrosion. Maybe your battery is getting weak. try a jump start. You can have both tested at most auto parts stores.

Sep 19, 2010 | 2003 Toyota Corolla

1 Answer

My ldv clicks when i try to start it. doesn't start


to get the solution you need the the service and repair manual to fix the problem which you will get easily from the given link even they help after buying i had checked it http://toolsnyou.com/

Nov 07, 2017 | 2009 Audi R8

2 Answers

Toyota Corolla starting problem in winter (cold weather)


if the battery is good and there that sound you have problems with the starter motor

Feb 27, 2010 | 1998 Toyota Corolla

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

Related Topics:

103 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76682 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...