Question about 1986 Toyota Pickup 4WD

1 Answer

Idles rough plugs are white runs and drives good but idles rough everything has just been rebuilt and checked all vacuum lines are where they go i dont think it could be timing but

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Sounds like the same problem I had with my 1985. I have found that when the carborator goes bad. It gets an internal vacume leak that can,t be fixed. I wen,t through 9 rebuilt ones that all had the same problem. put on a aftermarket weber carb & has ran fine for the last 7 years.

Posted on Jul 26, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What are the causes of rough idle and stalling


First thing I would look for is a disturbed vacuum line which will cause rough idle. When replacing coil packs, you have to remove covers, etc. so when vacuum lines get old and dry, even moving one slightly can cause cracking, so look for loose or cracked vacuum lines around where you were working on engine. It may just be loose hose. Good luck

Oct 22, 2017 | Cars & Trucks

1 Answer

Idle good when cold, hotter it gets the worst it idles especially when sitting at stop lights


simple test for a vacuum brake booster
star and run the engine at idle without applying the foot brake
if it gets worse when the foot brake is applied , it is a vacuum leak in the booster ( replace the booster )
otherwise check for failed vacuum hoses including under dash control lines , vacuum leak at the manifold or EGR unit

Apr 16, 2017 | Chevrolet Astro Cars & Trucks

2 Answers

Runs rough at idle when i drive it runs fine until i come to red light then it wants to stall. if it is idling it will stall to just bought it havent did any maintenance yet


Those El Caminos are nice. If you haven't done any maintenance, I would make sure that the oil is full, check and replace any bad carb. vacuum lines, check for any fuel, intake, vacuum, etc. leaks. Maybe check and replace spark plugs, wires, dist. cap + rotor, also check timing, etc. Good luck.

Nov 20, 2010 | 1983 Chevrolet El Camino

1 Answer

Idles rough. when under load, it sputters like a cylinder is misfiring. no smoke or leaks. any idea?


well. if it idles rough without a load and then worse with a load i would try changing spark plugs and ign. wires. also try pulling out your idle air control valve and clean it out. if that doesnt work look up testing for your throttle position sensor. check for worn vacuum lines and check for vacuum leaks. if it runs rough throughout driving it will be ign. or fuel delivery. get some injector cleaner and throw it in your tank. if non of this works then your in the same spot as me bud. oh and check your camshaft position and crankshaft position sensor and also your speed sensor.
good luck to ya bra

Jul 06, 2010 | 2006 Volkswagen Jetta

1 Answer

My 1990 chevy pickup runs rough on idle if punch the gas it clears up but goes back to running rough it also does it when driving. i have changed the fuel filter/plugs/cap/router/modgual/o2 sensor/


Sounds like a vacuum line is off or cracked. As they age they become brittle an fall off or crack. Causes too much and the engine will run rough. as you increase the throttle the vacuum falls off and the air leak is meaning less. In other words vacuum is highest at idle and the leak will do it's worst.... Check any near hot areas or where there is movement....

Feb 13, 2010 | 2003 GMC Yukon Denali

1 Answer

1980 F100 with a straight 6 cyl. Won't idle.


The vacuum comes from the intake manifold and ported vacuum comes from the carb above the throttle plate. You might have a leak at the carb gasket or intake manifold gasket. Spray some car cleaner or WD40 around the gaskets and vacuum lines while the engine is running and when you hear the idle speed up, you've found the leak. You will need to install the rebuilt carb first, and you should tighten any loose intake manifold bolts. Don't overtighten them. Also check the EGR valve because it could cause the engine to stall at idle. A good tune up might be needed too. I've seen some of those engines run real rough when the ignition timing was off.

Sep 06, 2009 | 1981 Ford F 100

2 Answers

ENGINE IDLES ROUGH, BUT RUNS FINE WHILE DRIVING. My car is a 1995 Buick Regal Gran Sport with the 3800 series motor with 212000 miles. The rough idle tarted after driving through some muddy and wet roads


go the cheapest route. replace fuel filter and add SEAFOAM to tank of premiun fuel. replace filter before 500 miles. then add SEAFOAM to gas every 3000 miles to keep lines.engine,fuel pump, and emissions systems clean, ETHANOL problem number 3000

Aug 29, 2009 | 1995 Buick Regal

1 Answer

Check engine light comes on temporarily - engine chuggs at idle


Before changing you pcm try cleaning your egr valve. remove the valve and see if its stuck in the open position if so use a small pick to clean around the spring.

Mar 12, 2009 | 1999 Jeep Cherokee 4WD

1 Answer

95 GMC Jimmy 4.3l W vin rough idle


My problem was solved when I repaired my 4 wd activation dash switch. The switch was contacting on 2WD & 4HI at the same time. The front differential activation is vacuum activated possibly creating a tug of war that didn't actually engage it but drained off vacuum from the engine? A theory at best but stumbbled across it because I knew the switch wasn't working properly I repaired it and low and behold rough idle disappeared and all is good for 3 weeks running.

Nov 17, 2008 | 1995 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

188 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8514 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...