Question about 1998 Mitsubishi Eclipse

1 Answer

My Spyder runs hot when using the A/C, also spikes then drops quickly going from below 1500 rpm then above.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,129 Answers

After the car has ran for at least ten minutes run the A/C and observe that electric fans (there should be two fans) come on during the 10 minutes you will be observing,if one fan doesn't come on this is your problem trace the fan relay and replace if it is not an easy relay to locate you may want to purchase a cd repair manual with electrical locator inside software off of ebay motors they are fairly cheap and a good tool to have in your cd collection, good luck

Best Regards Mark

Posted on Jul 15, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1997 acura cl 2.2 revs up to 1500 rpm and down to 1000 rpm just several seconds after start


Cars are design to run at a higher idle at start up to warm them up quick. There is a sensor that reads water temperature and tells your car's computer how fast to idle. Your RPMs seem slightly high but not out of the norm. Does idle ever drop to around 600/800 after about a minute? If not, your engine temperature sensor maybe defective.

Mar 16, 2014 | Acura Cars & Trucks

1 Answer

Over Heating and Belt Problems-98 Spyder


Roger

I'm going to ran off a list here.

Change coolant and thermostat at the same time.

check for load on alternator,ac compressor and water pump.

My best guess is worm out (still not leaking) water pump.

I come across a low mileage water pump with total worn out turbine wheel.

AC electric fan should come come within 15 minutes in a hot day,

If it does not it will be the temp. sensor.


Pick on my list one at a time,she will be back on the road in no time.

Jul 15, 2009 | 1998 Mitsubishi Eclipse

1 Answer

Idle problem integra


check the MAP sensor (manifold absolute pressure). The ECM (car computer) uses that to keep idle at minimum 750 RPM. It's normal for it to run high when cold. These small 4 banger motors typically run hot, and they won't run right IF they're NOT running hot, ergo the idle is usually high when it is cold so as to cause it to warm up quicker. If the RPM's drop below 750, suspect the MAP sensor, &/or ECM.

Apr 18, 2013 | 1995 Acura Integra Coupe

2 Answers

My 2002 Dodge stratus is running cold when on the Highway, and hot at a stop light. Temp is going up and down too much. It is also randomly jumping at different times. High speed and low speed the jump...


I would suggest having the engine temperature sensor and circuit checked, as well as your engine temperature guage. The guage is best checked with the use of a scan tool used by the dealer or a repair facility. If no signs of actual malfunction of the vehicle are present, you may just be throwing money at the car because of a false reading on your temperature guage. Some cooling systems require a specific filling procedure. If not done properly, air will be trapped in the system, causing similar issues to what you are experiencing. That would also cause loss of heat in the cabin, as well as overheating of the engine.

Oct 07, 2012 | Dodge Cars & Trucks

2 Answers

Honda civic 2001, excessively high voltage 19 to 20 volts ... so something is wrong. Before replacing alt& regulator, what voltage and under what conditions should be on each of the 4 control wires...


never mind testing if when you start the car you are getting them voltages then fit a new alternator and quick before you burn out the ECU ,the regulator has packed up end of story ,change alternator now ,NEW not a scrappy one from scrapyard,and stop try to confuse the issue with something you do not know ,no voltage leaving the alternator should not exceed 14.7v

Nov 22, 2009 | 2001 Honda Civic

1 Answer

98 Lincoln Navigator Check Eng light on


fuel pump is going out causing the truck to run lean and miss

Aug 22, 2009 | 1999 Lincoln Navigator

2 Answers

90 inline 6 will start but not idle


check the connection on the battery but it dose sound like a alternator problem

Jul 23, 2009 | 1998 Jeep Cherokee

1 Answer

Engine misfires under load.


Replace the wires and coil boots.........

Jul 17, 2009 | 2001 Mitsubishi Eclipse Spyder

Not finding what you are looking for?
1998 Mitsubishi Eclipse Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8572 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...