Question about 2000 Ford Expedition

1 Answer

A/c doesn't get cold for atleast 10 mins after cars been running.Have to keep it on max a/c Had heater core replaced.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

  • Contributor
  • 40 Answers

After you have ran the car with the ac on where you have parked does water drip onto the floor if not check to see if the system is blocked check the drainage plug, i think on that it should be under the hood passenger side half way down use something like a long tie strap as it's flexible and strong enough

Posted on Jul 14, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why doesn't my car get up to operating temperature?


Well the first question would be what does the temp gauge on the dash show after you have run the engine for 5 or 10 min ?
If the gauge is in the middle of the temp range the engine is getting hot and either the heater core is stopped up or you have a problem with the blend door under the dash.
If the temp gauge is staying around the cold mark the thermostat is not closing to warm up the engine.
I am assuming the radiator is full of coolant.

Jan 28, 2013 | 1997 Ford Thunderbird LX

1 Answer

Rear heater core is hot in and out the condersor is cold


It is pluged. That is why you have cold air blowing. If it is possible take the heart core out and drain all the anti frezze out you can. Fluch it out with water as much as possible. Put some water into one side of it and see if it comes out the other. If not add about a half cup of draino in it and let it set for about 10 min. If water runs threw it ya got it if not add some more untill you get the water to flow through it freely. Reinstall and you should be fine.

Dec 01, 2012 | 2000 Ford Expedition

1 Answer

No heat in 2001 chevy nblazer


If the thermostat is not working the engine will not warm up. So the temp gauge should show cold after running the engine for 10 or 15 min.
If the engine is warming up but the heater hoses are not warm, you could have air in the cooling system.

Sep 11, 2012 | 2001 Chevrolet Blazer

2 Answers

New thermostat,water pump,alternator.battery,head gasket i can drive the car ror 15 miles i hear water sounds like in dash then sounds like it releases. it will run hot for a while . i cut it off for 10...


the car will run fine with a heater core bypassed..though if the h-core was leaking there should be water on the pass side floor...you may want to check out your fan switch

Mar 21, 2011 | 2000 Pontiac Sunfire

2 Answers

I have a 1995 jimmy and the heater dont work but it blows out cold air. what could be the problem


Start with the simple and replace the Thermostat, it take about 10 min to replace and make sure your coolant level is correct. Good luck and keep me posted, be glad to answer another questions you may have.

Dec 01, 2009 | 1995 GMC Jimmy

2 Answers

No heat


Sounds like the radiator line are plugged. What you can try is taking off one rad hose lin 1 Side at radiator and the other at the water pump to engine Run water through lines leaving both lines open should flush all debris away may have to do it a few times. Where this runs thorugh heater core and back out. But do not use alot of presure from the hose.

Jan 24, 2009 | 1985 Ford F150

2 Answers

2002 Lincoln Navigator. Heater is not working, it blows cold air. I had the thermostat changed and it stills blows cold air. There is no water leaks under the dashboard. It takes about 10-15 min for...


try changing the thermostat if thats not it check and see if you have water leaking in the passenger side floor board if so then you need a new heater core

Jan 05, 2009 | 1999 Lincoln Navigator

1 Answer

Heater in 200 gmc sierra is not workinmg


make sure antifreeze is full. run engine 10 min. verify engine is around 195 degrees. if not, try replacing thermostat. if it is running at 195, then maybe heater core problem or heater control not functioning properly

Nov 16, 2008 | 2000 GMC New Sierra 1500

1 Answer

Heating system


sonds like air in your pipes!!! run ya engine with the lid off your expansion tank and put your heater on low until water starts bubbling and may start going down in your expansion tank and if so keep topn up to max mark!!!

Oct 15, 2008 | 1994 Chevrolet Suburban

Not finding what you are looking for?
2000 Ford Expedition Logo

67 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5520 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...