Question about Lincoln Continental

1 Answer

A couple of months ago my air con ceased to work, I put the car in the repair shop and they added refrigerant. The air con worked fine but in the past week I have had some sort of dust/sponge like particles coming through the air vents and there is a rather offensive smell in the car which seems to get worse when it is running. I am wondering if this is linked to my air con system.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 36 Answers

You could have a unwanted guest in your vent dead mice or just a nest. it happens more than most people think i have cleaned out plenty at the last auto shop i worked out of. its just an idea with out smelling it my self.

Posted on Jul 14, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I would like a diagram of ho to put a serpentine belt on by passing the air con


cheaper to repair the pulley bearing
1/2 hour in an ac specialist shop with less hassle in trying to find the correct belt and then routing it to work

Jun 04, 2016 | Cars & Trucks

1 Answer

MY CAR'S AIR CONDITIONING ISN'T WORKING. MY SON


mcdevito75 here, either your son in law didn"t put in enough freon or the compressor is not working, Have your local shop check it out.

Jun 18, 2010 | 1998 Cadillac DeVille

1 Answer

Ac works fine except when i exclerate or go up a hill, it seems to cycle or stop blowing...then the continues to work fine but this is happening more often . I just got my ac repaired 3 months ago. it...


sounds like u still have a leak and need to have freon added or wasnt fully charged --when ur at idle or lower rpm the compressor will circulate the freon fine and will not cause a problem when u put a load uphill passing or increase the rpm a little more the compressor sucks more and circulates more freon which gives u a lower suction pressure if the suction pressure gets to low the the a/c protects itself and the engine by turning off [low pressure safety] cycling if had done 3 months ago bring back and have tested or u can buy some freon and add to ur system yourself

Jun 07, 2010 | 2004 Ford Expedition

1 Answer

1996 jimmy air conditioner blows hot air worked fine a couple weeks ago. I used the arctic freeze ultra synthetic refrigerant 134a+ but didnt seem to do any good. Still blows hot air.


Might be the condincer, does the comprsure kick when you turn the air on. if so you might want to take it to a shop and have them flush the lines out. old as it is it should be done, another thing to check would be the temp snsor for the a/c.

Aug 16, 2009 | GMC Jimmy Cars & Trucks

2 Answers

Nissan Almera Air Con Advice


It may be low on refrigerant if the pressures are to low, the compressor will not engage.

Jul 31, 2009 | 2000 Nissan Altima

1 Answer

My blower only works on setting 123 + air con not that cold


You have a resistor array assembly going out. What you described is typical of the first resistor going out and over loading the second, which goes out and overloads the third. Replace the HVAC resistor array. Don't buy a used one. Spend the extra money on the new OEM dealer item. Good luck to you.

Apr 20, 2009 | 2000 Jeep Cherokee

1 Answer

ODOMETER CEASED WORKING ABOUT A MONTH AGO (66,667) MILES SPEEDOMETER IS W0RKING FINE. WHAT REPAIR WORK DO I NEED.? DOUG 1992 CROWN VICTORIA


U will need to pull the speedo head out and send it in for repair, there are no parts availiable to the consumer, only authorized Ford repair stations, that is not the dealer, check the internet, I use DNA speedometers.com

Mar 25, 2009 | 1992 Ford Crown Victoria

1 Answer

The heater in my 95 ford V8 fairmont has stopped working!?!


You haven't totally filled the cooling system.  Heater on hot, raise the front of car adding coolant until all the bubbles are removed from the coolant system.  This bleeds the total cooling system

Mar 25, 2009 | Ford Fairmont Cars & Trucks

1 Answer

98 Ford Explorer wont move in reverse or overdrive


Probably low oil pressure in the transmission or worn clutches.

Mar 09, 2017 | 1998 Ford Explorer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

191 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lincoln Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

fordexpert

Level 3 Expert

5470 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Lincoln Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...