Question about 1986 GMC S-15

1 Answer

Will not run at idle speed. seems to shut fuel off. 2.5 liter. Have replaced the fuel filter. Problem started when I ran out of gas then it would not start without adding fuel to the carb. After starting if the rpm's are kept high it will continue to run.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,129 Answers

I would clean the carberator's float chamber out ther may be foreigng matter in the carb. If you have access to compressed air disassemble the carb and clean with solvent and blast it out with comp. air.

Posted on Jul 14, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hesitating when going a constant speed.. seems to be worse when fuel tank is below 1/2 and going up hill


may need to replace fuel filter.or could be an idle control sensor going bad. try running lucas fuel treatment through it 1st, it may only be a fuel injector clogging up, are you burning ethanol gas? i would go with fueling with good gas and adding the lucas fuel treatment !st before you do anything else. if that does'nt work then replace the fuel filter, if not that then i would replace the idle control sensor.hope this is some help to you!!

Nov 11, 2010 | 2001 Dodge Ram 2500 Truck

1 Answer

1997 jimmy car shut off while driving. replaced


SCAN IT SOUND LIKE IDLE SPEED CONTROL PROBLEM.BUT I AM LOOKING AT VACUUM LEAK AT THE INTAKE MANIFOLD BROKE VACUUM HOSE. OR FUEL INJECTORS SEALS LEAKING.

May 12, 2010 | 1997 GMC Jimmy

1 Answer

4.3 liter engine, got bad gas, fuel pump went out, replaced it, in line filter has been replaced 3 times now and it still starts bad and idles rough, runs good at higher speeds though, just changed the...


Are you sure it's bad gas causing the problem? It could be a faulty idle sensor or more than likely the coolant sensor near the thermostat housing malfunctioning. It could be sending the wrong signal to the pcm(power control module) causing the timing to be too far advanced thus causing the low speed chugging & hard starting. Good luck!

Apr 17, 2010 | 1999 Chevrolet S-10 Pickup

2 Answers

1996 Jeep Country Wagon. Replaced fuel filter and


does your jeep run rough? idle is real low? and when you are driving and push the gas hard it doesnt want to move? if so it is most likely the mass air flow sensor. i had to replace that 2 or 3 times on my 1999 jeep cherokee

Jun 22, 2009 | 1996 Jeep Cherokee Country

3 Answers

1995 Chevy K1500 4.3L V6. Engine has inconsistant idle


Have you changed the fuel pump yet?I had the same exact problem.I replaced my fuel pump with an AUTOZONE PIECE OF JUNK fuel pump.That pump lasted almost 2 days.The second day i had it the truck didnt want to start but it did and it ran like ****,and when i put it in gear it ran as long as I didnt touch that gas pedal.You could go get a fuel pressure test or just replace it,your call.You might want to check your filter too but im sure its the pump.Good luck

Apr 13, 2009 | 1997 Chevrolet K1500

3 Answers

2002 Ford Taurus ses 24v DOHC


1st thing change fuel filter. You probably pulled in some crud from the bottom of the tank. countrycurt0

Sep 09, 2008 | 2002 Ford Taurus

2 Answers

Ran out of gas and now she won't run!


i would say that you have a bad fuel pump or if you have a carb on it the float inside the carb is stuck check these and i'm sure you will find it's one of these.

Sep 06, 2008 | 1987 Ford F 250

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

69 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...