Question about 2001 GMC Yukon XL

1 Answer

Having problems when turning the engine off it dosen't want to start again. Usually have to wait 15-30 minutes, then will start. Runs good when running. The other day it wouldn't start for 2 hours, I called a mechanic and he said just to get out of a jam get under the truck and hit gas tank. It started right up, whats the problem?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 136 Answers

Sounds like the fuel pump is going bad.

Posted on Jul 13, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Starts fine runs fine. After turned off, will not start. Wait or try again and it starts. What's wrong?


Car will sometimes not start after warm. - CarGurus

www.cargurus.com > Questions > Pontiac > Grand Prix

CarGurusJan 2, 2013 - When i start my car, for the first time during the day- I have no problem.... When I go somewhere and shut it off, sometimes it won't resatrt. ... I have to keep my foot on the gas and rev it up to keep it running- then it's fine. .... When your carstarts fine cold, then fails to restart while warm, it is usually a coolant ...

Blazer has to be jumped, then i shut it off and won't start.

www.cargurus.com > Questions > Chevrolet > Blazer

CarGurusDec 21, 2013 - I jumped it and it ran fine, but as soon as I turned it off I couldn't start it again. No clicking just like the battery is drained. ... Then run the car for ten minutes and shut it off and if does not start, replace the battery. ... Blazer starts fine first time but after shutting off,has hard time starting-takes up to 10 key turns or ...

Engine Performance Problems Due to Crankshaft Position ...

repairpal.com > Problems > Mercedes-Benz > ML320
"Crank no Start" Due to Failed Crankshaft Position Sensor on Mercedes-Benz ML320... It usually ocurs after I've turned the car off and try to restart after about 15 minutes. I typically allow it to ... fine. Stalling and starting problems intermittent at first, but now more frequent. ... Car runs fine then without out warning it won't start.

Jan 05, 2016 | Cars & Trucks

1 Answer

Check code engine po171


I'd be more concerned at looking into the fact that it takes a while to cool off in order to start up again. P0171/174 codes mean a lean condition. I'd suspect that you may have a problem with Vapor lock on the one bank, which is causing air to form in the fuel rail on that side. Since air compresses, the fuel pressure doesn't necessarily come up enough to restart the engine until the fuel has cooled down enough to stop boiling. Did this start happening once the weather in your area started getting warmer?

Apr 22, 2014 | 2005 Chevrolet Uplander

1 Answer

Acura Legend 86 wont start after initially running fine


fuel pump going out and it will not run at all
coil problem will starteasy but fail after running for a while
fuel pump relay again it is running after starting and if the relay is no good , it will not pump fuel
try having the fault codes read first then have the faulty sensor replaced

May 13, 2017 | 1986 Acura Legend

2 Answers

2002 mercury grand marquis wont start when engine at normal temperature must wait 15-20 minutes


I have exactly the same problem started last winter, ran fine all summer then as soon as it got below freezing again if I start it and run for 15 20 minutes wont restart I have to let it sit for 20 minutes or so and then it will start again. no codes and just turns over without starting. cant be fuel pump like i said had this problem last winter then ran fine all spring summer and fall! Anybody got the answer for this one??

Mar 09, 2012 | 2002 Mercury Grand Marquis

3 Answers

I have a 2001 saturn sc1 that is having intermittent starting problems. At times after its been driven ill go out to leave again and it won't start. No clicking when I try and start it either. Wait for...


I am having the same problem. did you figure out what was wrong with yours. I have tested all of the wires in the harness under the dash, they r fine. I pulled off the starter and had it tested; O'rilies said it was fine. It is a 5 speed, and I can push start the car just fine any time. Like yours, some days my car starts, some days it doesn't. The days it starts, it runs fine with no problems starting or running. the problem is the days that it wont start.

Feb 25, 2010 | 2001 Saturn S-Series

1 Answer

1992 Jeep Sport - hard start - AND - when started and after running at highway speed for 15-20 minutes it suddenly dies. You must come to a complete stop - turn it off wait a couple minutes then turn on...


Sounds like a fuel problem??On the chasis rail back near the fuel tank there is a fuel filter that is often overlooked.Get that checked and I hope that is the only problem.If it is not.Come back to me and I may be able to help

Nov 04, 2009 | 1992 Jeep Cherokee Sport

1 Answer

1990 ford festiva stalls out when it snows.


Well did you use 10w - 30 if so then switch to the 5w-30 the reason the car needs a lighter oil in the cold weather. i usually use 10w during the summer helps keep the engine a little cooler on longer runs but during the winter u need the lighter oil so it don't have to work so hard to keep going.

Mar 22, 2009 | 1990 Ford Festiva

2 Answers

1990 626 won't start when engine is hot


I had the same problem a few years ago. The problem was a cracked coil. The unit would expand and separate when the car got hot and it took a while to cool off and reconnect.

Nov 26, 2008 | 1997 Mazda 626

1 Answer

Stalling


Possibly faulty ignition module is the problem, stalls when engine is hot when you sit for a while it cools off and runs again until it heats up again, those are usually the symptoms of a bad ignition module and after a while it may give out all together and not run at all, usually if the module is at fault it shuts down the fuel pump so the engine don't load up with fuel, do to when engine continuously cranks over the injectors never stop squirting fuel and flood the engine do to lack of spark which is produced by the module, this could possibly be your problem.

Nov 01, 2008 | 1998 GMC Sierra

Not finding what you are looking for?
2001 GMC Yukon XL Logo

Related Topics:

46 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...