Question about 2003 Hyundai Tiburon

1 Answer

Same as above...

Car is shooting a P0717 code. Doesn't shift out of 1st gear (sometimes goes back to normal after pulling over to restart engine), gas pump shuts off every few seconds. Just started happening today. Car is 1999 Hyundai Tiburon 130k. Help! I heard if ignored, WILL destroy tranny

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 382 Answers

Your fault code says that the turbine shaft speed sensor (tss) has no signal.on this vehicles each and every sensor is important as they communicate to the ecu threw a can system which in turn communicate to the tcu (transmission) funny things will happen if the line of communication is disrupted pls respond on your findings

Posted on Jul 16, 2009

  • 7 more comments 
  • your fault code says that the turbine shaft speed sensor (tss) has no signal.on this vehicles each and every sensor is important as they communicate to the ecu threw a can system which in turn communicate to the tcu (transmission) funny things will happen if the line of communication is disrupted pls respond on your findings

  • your fault code says that the turbine shaft speed sensor (tss) has no signal.on this vehicles each and every sensor is important as they communicate to the ecu threw a can system which in turn communicate to the tcu (transmission) funny things will happen if the line of communication is disrupted pls respond on your findings

  • thanks for the fault code.this code means that the turbine shaft speed sensor(tss) has no signal.this explenation will give you a guide line of what to look for each and every sensor on this vehicle is important as it is a line of communication between the ecm threw a can system connected to the tcm.should any of the sensor fail or give the wrong reading funny things will happen to the vehicle.one more thing have the tps sensor ( throttle) checked

  • if your fault code is correct then it means that the tubine shaft sensor (tss) has no signal.plse check the following items in order to rectify your problem.wiring, tss sensor,ecm,pcm,tcm. then reset fault codes

  • dear friend-interesting name for your baby.thanks for the fault code.it means that the turbine shaft speed sensor has no signal.this could be a wiring problem or the sensor or the ECM/PCM/TCM could be at fault.these modules all work together and should they receive the wrong or no signal the vehicle will act funny.

  • dear friend-plse look at the following items in order torectify your problem.intake or exhaust leak,air system,MAF,VAF sensor,feul pressure/pump,injectors.

  • dear friend-plse check the following;wiring,tss sensor,ecm/pcm/tcm as al these items relates to your fault code,turbine shaft speed sensor no signal

  • dear friend-your fault code points finger at the turbine shaft sensor(TSS)no signal,plse check the following items:wiring,TSS sensor,ECM/PCM/TCM.BEAR IN MIND THAT IT IS A COMMUNICATION PROBLEM.

  • dear friend-you have a communication problem between the ECM/TCM AND PCM,that is why your vehicle does all kinds of funny things.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

350z 2004 a/t with 120k miles 3 days ago my car overheated but reached just half of the temp gauge and i stopped the car and by the time it went back to normal i turned off the engine to cool down....


I don't think overheating of the engine has much to do with the transmission, either automatic or manual. If you have an automatic transmission, did you check the fluid? Sometimes low fluid stops certain gears from changing, as the torque converter doesn't have enough fluid to pressurize the servos to engage the clutches.

Feb 17, 2015 | Cars & Trucks

1 Answer

Malfunction indicator on, Kia Forte 2012


Soooo...some of you that have seen my posts and responses may be able to tell that I am a "Hot-Head"!! I graduated from Montclair State university this past semester and had my graduation at the IZOD center at the Meadowlands yesterday..long story short, I was in a really rough mood for whatever reason and when Im in one of those moods, I shouldn't be driving especially in north jersey. Anyway, I was ripping my car around in sports shift mode because i have a 2010 Forte Koup 2.4l Automatic 5-speed trans. I'm used to driving it and ripping it around in sports shift since i got the car a couple years ago. To explain this correctly, I drive the sports shift kind of like it has a clutch (but we all know it doesn't) meaning when I go from 1st to 2nd I remain on the gas but sometimes when i like to hear the shifting take place, i will let go of the gas and shift the sports shifter up into 3rd gear. this is definitely NOT needed in an automatic, I'm supposed to keep my foot on the gas while shifting into a higher gear. So after a while of screwing around and driving like a mad man trying to get to my graduation, i came to a red light and for some reason the tip-tronic would not let me downshift to 1st gear nor would the engine automatically downshift to 1st like it is supposed to and usually does. At this point I would only be able to take-off in 2nd or 3rd gear (very weird I know). So i pulled over, turned the car off and restarted it and it seemed to be fine, then I put it in tip-tronic again and it did the same thing: wouldn't let me shift down to first while coming to a stop and remained in 2nd gear. when i finally arrived to my graduation the Engine Malfunction (AKA check engine light) came on. i know this can be due to more than 100 reasons but has anyone ever experienced this before driving their automatic KOUP while driving in tip-tronic? I have an appointment at my dealer for Monday morning and can't wait to see whats wrong with it. Also when i was leaving my house this morning, i put the car in tip-tronic and took off it seemed to be fine, then when i came to a stop sign the same thing happened again where i couldn't downshift to 1st and when i took off in 2nd and shifted to 3rd the car threw itself forward whereas if someone was close to me in front i probably woulda hit them from behind (thank god I didn't). After that happened this morning, I pushed the shifter knob back into regular automatic drive and the engine seemed to lose almost all power meaning when I pushed the gas and even floored it, the car did not pick-up or go anywhere. What could be happening here?!?! Please someone HELP!!!

Oct 20, 2012 | Kia Forte Cars & Trucks

1 Answer

92 suburu svx it has wiring gremlins check engin light comes on sometimes but I lf I turn the car off and restart it, then it's gone. And gas gadge doesn't work sometimes come on. And no cruse...


The check engine light will set a code, to read this code you must have the system scanned with a special tool. This is not a wiring GREMLIN, trust me. As far as the gas gauge goes you will need to pull the fuel tank out and replace the gas gauge fuel level sending unit.

Feb 25, 2012 | 1992 Subaru SVX

1 Answer

Goes into neutral and then shifts hard into 1st on slowdown


It sounds like your input clutch seals are rolling. Is the check engine light on. It could also be the pressure control solenoid could be causing the problem aswell

Sep 02, 2009 | 1998 Buick Century

2 Answers

WHEN YOU PUT THE CAR IN DRIVE IT WILL NOT GO ANYWHERE


Its the electronic shift control located just under the battery ontop the transmission replace or repair will solve the issue

it'll go into drive but once it reaches 1500 rpm it'll drop into neutral as a safety because at this rpm it is being told to shift gear and when it fails to do so it safely goes into neutral

it will go into reverse just fine and park and you can run all the low drive gears until you reach 1500 rpm then it'll cut it off

i pulled mine out re soldered bad components on the board to fix it but im an electronics engineer it may be easier for you to just replace it

Aug 09, 2009 | 1995 Dodge Avenger

1 Answer

Car won't go into gear properly


it could be a few things bent shifting fork or first gear is out reverse runs off an idler that is conected to first gear.

Jun 05, 2009 | 1999 Nissan Altima

1 Answer

Nissan 1999 Altima won't go into gear properly


howdy,you need a clutch..thats for sure,101%

Jun 05, 2009 | 1999 Nissan Altima

Not finding what you are looking for?
2003 Hyundai Tiburon Logo

Related Topics:

227 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hyundai Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8518 Answers

Are you a Hyundai Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...