Question about Ford Expedition

1 Answer

I changed the antifreeze and flushed the radator but did not change the thermstat at first. I turn the car on and the heater on high and notice the the service engine light stayed on, I also notice that there was no flow because the top hose was soft like no flow threw it thanks kevin

Posted by on

  • 1 more comment 
  • kdaigr1411 Jul 12, 2009

    I think the temp got hot enough to open the thermerstat becaue I drove this for about 3 miles. How long can I run without a thermerstat (live aroung dalls texas - hot ) It will not the computor if I unplug the negitve cable. It would take 24 hours to reset.

  • kdaigr1411 Jul 12, 2009

    I think the temp got hot enough to open the thermerstat becaue I drove this for about 3 miles. How long can I run without a thermerstat (live aroung dalls texas - hot ) It will not hurt the computor if I unplug the negitve cable. will it really need to take 24 hours to reset.



    thanks

  • kdaigr1411 Jul 12, 2009

    thanks

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 784 Answers

The top hose is soft like no flowing because the Thermostat didn't open yet. It only opens at certain temp based on your Thermostat made for. Don't be panic.

1- If you really want to check teh flow then take out Thermostat, then run the engine you can feel it.
This way you can see if your radiator still good since your intention flushing it to make sure it doesn't get clogged up.

2- If you don't want to do that, just wait after 10 minutes ro temperature gauge at 95 or above and wear a mitten to touch the top hose to feel the flow.

3- Your engine light on can be fixed by removing the ground cable on your battery over night and put back in the morning to reset the error state that might happen when performing the flushing.
Hope this can help.

Posted on Jul 12, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1997 ford Taurus 3.0 6cyl. Has not heat


Empty cooling system and reverse flush the heater core with water hose till water comes out clear. Then reverse procedure till water is clear. Fill system with water and turn car on, while car is running open drain plug and continue to keep radiator full while draining it at the same time turn on your heater with heat on high and blower on high When water is clear flush system and wait for engine to cool down. Refill with antifreeze and turn engine on, check for leaks and to see if you have heat. If still no heat change heat core.Let me know how you make out.

Dec 22, 2014 | 1997 Ford Taurus

1 Answer

I have a 2006 ford taruas my heater blows cold air out where is the fuse box located .


Try checking the antifreeze level, make sure the Hose to the Heater core isn't kinked and the cable valve is open. Then I would install a Flush kit and change the Thermostatand antifreeze after flushing.

Oct 22, 2014 | 2006 Ford Taurus

2 Answers

Truck doesn't heat while idling


Could be low on antifreeze. The heater core is the highest spot in the cooling system and it may develop an air pocket. Another possibility is the thermostat is stuck partially open and doesn't let the engine warm correctly, watch your temp gauge on the dash and see if it comes up to the middle like it should while idling. If it doesn't, it may need replacement.

Oct 19, 2014 | 2001 Dodge Ram 1500 Truck 2WD

3 Answers

The heater isn't putting out hot air


check to see if there is plenty of antifreeze in radiator , may have a air bubble in system .

Jan 28, 2013 | 2005 Chevrolet TrailBlazer

2 Answers

How to drain and flush radiator


at the bottem on the left or the side there is a small key like screw ( righty tighty lefty lucy } then u must remove the radiator cap and also remove the themastate be sure to attach the therma housing and hose and unatch it at the top of the radiator the put water hose in the open cap area and flush for 20 mins turn on engine and let run for 2 min and repeat flushing untill all antifrez desapears. be sure to put every back tack pitchures as you remove so to put back the same way it might be good to get new thermastate

Jun 25, 2010 | 1998 Ford Taurus

1 Answer

It over heats we replaced the thermistate (spelled wrong)flushed the radator still over heated took thermastate back out left it out it worked good but now is over heating again


CHECK WATER PUMP WEEP HOLE SEE IF ITS LEAKING ANTIFREEZE IF SO WATER PUMP SHAFT BEARING GOING BAD CAUSING WATER PUMP LOCK UP HARD TO TURN.MAKE SURE DRIVE BELT NOT SLIPPING DUE TO BAD BELT TENSIONER.CHECK TO SEE IF COOLING FANS TURN ON WITH AIR CONDITIONER ON HIGH.IF NOT CHECK HEATER + AC IGNITION FUSE.IF FUSE GOOD.YOU HAVE FAULTY COOLANT TEMPERATURE SENSOR.IF ALL LOOKS GOOD.CHECK ENGINE OIL IF LOOKS LIKE MILK SHAKE YOU HAVE LEAKING HEAD GASKET.IF OIL LOOKS GOOD.YOUR ENGINE CYLINDER BLOCK WATER CORES CLOGGED UP WITH RUST RESTRICTING COOLANT FLOW THROUGH THE ENGINE BLOCK TO REMOVE HEAT AWAY FROM THE ENGINE.BLOCK PROBABLY NEED FLUSHED OUT AT RADIATOR SHOP.

Jun 23, 2010 | 2001 Pontiac Grand Am SE

2 Answers

Engine overheating


is the fans working? also check the water pump, by running car and open the radator cap to see if the water is moving.

May 20, 2009 | 2000 Daewoo Nubira

2 Answers

1998 Saturn sl 16 twin cam engine overheats.


It could be either the radator or the timeing is too far advanced. Did you put a 50/50 mixture of antifreeze? To much antifreeze vers water will also cause overheating. Non Exhaust. 

May 09, 2009 | 1997 Saturn SL

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

63 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5470 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...