Question about 1999 Chevrolet Silverado 1500

2 Answers

When first start hot or cold, spits and sputters for about 60 secs then is fine.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 25 Answers

Check your air filter or your spark plugs...

Posted on Jul 12, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 41 Answers

Have you checked your spark plugs, wires, and cap and rotor. More than likely you have a spark plug fowling out. The cap and rotor may need to be replaced too.

Posted on Jul 12, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wont stay running spits and spudders


smoke smell like burning oil or hot antifreeze..

Feb 24, 2013 | Ford Explorer Sport Trac Cars & Trucks

1 Answer

T10 blazer hard to start when cold,easy to start when hot


4.3L V6 CPI - center port fuel injection . you need 62 psi .When cold give it a shot of carb.cleaner or starting fluid ! does it start then ?

415-455 kPa (60-66 psi

Mar 18, 2017 | Cars & Trucks

1 Answer

05 taurus spits and sputters on startup when cold


This can be caused by a problem in the fuel pressure check valve of the fuel pump. Have a pressure leak down test run by a shop, if the system is losing pressure then the pump assembly must be replaced. The fuel pump is located inside the gas tank and is electric

Sep 19, 2012 | 2005 Ford Taurus

1 Answer

Hard hot start


Usually a sign of leaking fuel injectors or a fuel problem.
Starting with a wide open throttle turns off the injectors which would clear out the cylinders of fuel. Could also be a leaking fuel pressure regulator if it is getting too much fuel.
Does it eventually clear up once you get it started ? Is the check engine light on ?

Sep 02, 2012 | 1990 Cadillac Eldorado

1 Answer

93 wrangler spits sputters and backfires sometimes ,them will take off and run fine ? Has over 130000 miles on it , is in good shape . Has 4.0 in line six cly. will a elec. fuel pump cause this?


when it hit 60/70 miles it spit sputters somtimes i change plugs , wires, cap still does the same
can you tell me what i need to look for.


thanks G man

Jan 25, 2011 | 1993 Jeep Wrangler

2 Answers

97 nissan altima just started runs fine when cold when it gets warn it starts to spit and sputters giving it gas wont help, i checked plugs and there fine checked cap and rotor and they look good i even...


Sounds like plugged catalytic converter, Disconnect exhaust in front of Cat. and see what happens. Check to see if you are losing fluid from radiator.

Jan 11, 2010 | 1997 Nissan.5 Altima

1 Answer

1995 Jeep grand cherokee is missing while running. When it is under a heavy load (driving fast) it runs fine. When idleing and slow driving it spits and sputters.


I have the same problem on my 95 grand cherokee laredo. Sometimes it starts out fine and after about 10 miles it starts spitting and sputtering. Then after a while it seems to clean out and run fine again for a little while. Then other times it starts out spitting and sputtering at the begining. I changed the fuel filter and that was not it. It is a 4.0L 6cyc. Any Ideas?

Thanks,
Broken Arrow, OK

Jul 02, 2009 | 1995 Jeep Grand Cherokee

1 Answer

No throttle response


First check for water in fuel.

May 05, 2009 | Ford F-350 Cars & Trucks

Not finding what you are looking for?
1999 Chevrolet Silverado 1500 Logo

Related Topics:

186 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

80668 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...