Question about 2003 Chevrolet Silverado 1500

1 Answer

Chevy silverado 1500 2003. For several months the fan has only worked on "5". Today, even when off it only blows high. I had to pull the fuse for the blower. Any ideas?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Chevrolet Master
  • 3,854 Answers

The blower resistor needs to be replaced, that is why your only have the highest setting working since the blower speed resistor's are being by past. The other thing that happened is since the blower is always on high, the high current most likely burnt out the blower relay and ir stuck in the close loop and needs to be replaced. pay attention to the wire harness, since it got hot enough to damage the relay, it may have damaged the wire harness to and fire may start due to a short. Good luck and hope this helps.

Posted on Jul 11, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

2009 chevy AVEO 5 ac blows hot air


The guage needs to read between 35/40 psi.. If its much higher you may be overfull, this causes it to not cool.. Fix by letting some freon out, then top it back to needed pressure.. If pressure is correct, it would be a clog in the system.. Usually an orafice tube or accumulator..good luck!

Apr 09, 2014 | 2004 Chevrolet Silverado 1500 Crew Cab

2 Answers

My fan blower will not work on high speed on my chevy 2005 silverado


if you got heat on all speeds and the blower motor is working properly then you probably need a new HVAC switch.

Jan 19, 2013 | 2005 Chevrolet Silverado

1 Answer

2005 Chevy 2500hd a/c blower switch #5 not working. Only 1 thru 4.


switch has failed and needs replaced would be my suggestion....good luck...

Aug 19, 2012 | 2003 Chevrolet Silverado 2500HD

1 Answer

My 1988 chevy silverado blows the heater/ac fuse when engaging 4w


There is an electric actuator on the front axle that engages 4WD. This part commonly fails resulting in no 4WD. Unhook the electrical connector to this part and see if heater still blows fuses. If It does not blow the fuse, the problem is in the actuator. If it still blows the fuse then it could be in the wiring. Buy a repair manual and trace the wiring schematics.

Feb 02, 2010 | 1998 Chevrolet K1500

1 Answer

2004 silverado heater fan problems


Check the blower resistor and the connector. The tend to fry the terminals together. You can get a connector and install it yourself fairly easily.

Feb 02, 2010 | 2004 Chevrolet Silverado 2500HD

1 Answer

2003 chevy silverado 1500HD LT. A/C fan works intermittently


First check fuses, then test blower motor, Last Temp control switch

Jul 21, 2009 | Chevrolet Silverado 1500HD Cars & Trucks

1 Answer

05 chev silverado fan wont turn off


Replace the blower resistors/relay. It is one piece, they are made together.

Feb 26, 2009 | 2003 GMC Yukon

1 Answer

Blower fan only works on high


If it is working at all then the relay and fuse is good and the problem is either the little vacuum hose on the back of the control switch panel or the panel itself.

Feb 01, 2009 | 2001 Chevrolet Silverado

6 Answers

2001 tahoe front heater not working, rear heater blows warm air


I have the same problem with my 2001 Tahoe. The front blower is working, its blowing strong, but its cold air even with the temp setting as high as it can get. The rear blows hot air. The engine temp guage is at about 210ish which is close to being normal (220). I just replaced the thermostate a few months ago, I don't know if its bad again, or it I deluted the antifreeze too much and it frooze the heater core, or if the heater core just went bad. Any one know what the cause could be?

Jan 05, 2009 | 1998 Chevrolet Tahoe

Not finding what you are looking for?
Cars & Trucks Logo

183 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

81423 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22359 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...