Question about 1992 Ford Explorer

1 Answer

Battery is getting hot and it killed my last one 300,000kms other runs well but it is getting feed back from somewhere???

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 89 Answers

Alternator is possibly overcharging

Posted on Jul 11, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My ignition switch will not start the car however it will turn the car off if it is directly connected from the starter to the battery


The starter motor usually has two voltage circuits, one comes from the battery, hot all the time. The other circuit goes hot with key in the crank position and is wired through the neutral or clutch switch, depending on the tranny. When you turn off the key, it kills ignition switch feed to engine components, so, yes it will kill it.
The starter motor usually grounds through the engine block.
I can't post wiring diagram because I don't know year--make--model. My database only covers vehicles sold in the US.

Feb 20, 2017 | Cars & Trucks

3 Answers

Kia start normal after run the battery cable very hot and shut down and again start can not start motor hard to rotate


Nader, you will have to have a good Tech. check battery and starter, then diagnose and estimate repair.
"I hope this helped you out, if so let me know by pressing the helpful button. Check out some of my other posts if you need more tips and info."

Aug 11, 2016 | Kia Cars & Trucks

1 Answer

Car was running, electrical wire burning smell, starter makes grinding noise, with the car running, stop the car, starter keeps making grinding noise, with the car turned off, ABS and trac control


You have the polarity of the battery backward somewhere. Did you replace the starter and hook it up backwards. Difficult but possible. Check your positive and negative on the battery itself.

Nov 23, 2015 | 2001 Mercury Grand Marquis

1 Answer

2001 tundra v6 auto 2wd. the gauages, turn signal, ac, and radio all quit working all of a sudden. have checked all the fuses (both hot and grounds) and all are good


All those things have in common is the ignition switch, that only in accessory, or on (run), or start, allows power to that portion of the fuse block protecting those circuits, everyone you mentioned that quit.
Use a test light or voltmeter, pick a fuse -gauges. With key on, the fuse should show power on it, and across it if the fuse is good. If it doesn't have voltage to it, trace it back to how the ignition switch turns that portion of the fuse panel on (possibly a relay-ignition or accessory relay...I'm guessing), and further, whether any relay involved has a "hot at all time" supply of battery power as the power feed for that portion of the fuse block. This relay's power source would be from a maxi fuse or a fusible link, if equipped, all under the hood.
If the fuse block for all those is powered up with key on, then it may be a common ground problem-somewhere behind the dash.

Mar 18, 2014 | 2001 Toyota Tundra

1 Answer

Help! Truck starts then dies right away


Alternator is not charging battery starts a car and then alternator runs all power needs...

Dec 15, 2013 | 1999 Chevrolet C/K 2500

1 Answer

My 2008 artic cat 700EFI 4x4 runs fine when cold once it gets hot it starts to miss then kills starts right up but wont idle and continues to kill and run ruff it fixes it self if left to cool I...


check the valve clearance adjustments indicates that the clearance is no exixtent when hot and the poor running is from the valves not seating properly

Oct 11, 2017 | Cars & Trucks

1 Answer

I recntly had a 1500 wat amp connected to my battery it somehow killed my battery and now i have a new 1 when im driving the light comes on as it did when my amp was connected my amp is not connected now...


yep you have a short somewhere withthe positive side of the battery disconnect the positive side of the battery feeding the amp before you burn it down to the ground.

Jul 22, 2009 | 2003 Mitsubishi Lancer

2 Answers

Heater/AC fan motor keeps running after car is shut off


that's normal when hot, but should't run down the battery. if severly overheats ffnd/fix that problem. the other will probably dissapear . if not excessively hot then the fan heat sensor is faulty....

Jul 22, 2009 | 2001 BMW 325

Not finding what you are looking for?
1992 Ford Explorer Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

Marvin
Marvin

Level 3 Expert

81423 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22359 Answers

gerry bissi

Level 3 Expert

4376 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...