Question about Ford Cars & Trucks

1 Answer

I have a 99 ford expedition and when idling it will die what could be the issue

Posted by Anonymous on

  • paulmacintyre
    paulmacintyre May 01, 2015

    Possibly a defective idle air control motor. Although a cleaning of the throttle plate may correct this issue. Remove the hose from the air filter box to the throttle assembly and look inside the throttle. If it is all black and dirty, I would get some carb spray and clean the throttle bore and plate assembly using a tooth brush. You may have to hold the gas pedal down a bit after this procedure to get it to start. If it idles after this procedure then problem corrected. If not you will have to get the IAC motor checked out for proper operation

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 168 Answers

Could be a number of reasons for the stalling. Check all the vacuum hoses, look for cracks in the hose or disconnected hose.

Posted on May 05, 2015

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

wireguy212
  • 1627 Answers

SOURCE: radiator leak 99 Ford Expedition back drivers side

You are likely leaking coolant from a heater line or hose,check the hose that comes from the water pump{smaller of the two] and see if it has a leak in it or if there is just a loose hose clamp.If you can't find a leak in the hoses or any steel tubes then you need to take it to a radiater shop and have it pressure tested to see if you have a leak in the intake manifold gasket or maybe even the head gasket,good luck.

Posted on Dec 02, 2009

  • 73 Answers

SOURCE: My 99 ford explorer cuts out and dies when accelerating in drive

You may have dirty or clogged fuel injectors, may also be problems with the ignition system. Might also check the fuel pressure to make sure the fuel pump is working correctly.

Posted on Mar 28, 2010

  • 518 Answers

SOURCE: 99 expedition running lean and dying when at idle

Sounds like a vacuum leak. Look for obvious vacuum hoses broken,squished or off. Check at egr valve, dpfe sensor & solenoid. These are all common to go bad. If not obvious take carb cleaner with snorkel attached, spray intake manifold & hoses etc. If idle raises while spraying you located vacuum leak. The propelent in the can temporarily seals leak while its being sprayed. Be careful not to spray on wires or anywhere there is a spark.

Posted on Jun 14, 2010

BCAS1298
  • 3092 Answers

SOURCE: Everytime I stop and try

On top on the engine, all the way to the back, and down a little, there some vacuum connection, one has an elbow that always leak's, start engine and feel back there, 9 out of ten time's that's the problem, that will also set an engine light on for lean.

Posted on Aug 09, 2010

Testimonial: "Thank you so much. That was exactly the problem.. I never would have found it on my own."

  • 7 Answers

SOURCE: 2000 ford expedition ,,rough idle in park..rough

Check the fuel pressure at the rail assembly, there should be a min of 40 lbs at the rails. Do you have any loss of power under a load? You may have an issue with your o2 sensor that is causing the ecm to send an improper signal to the engine ign/fuel map.

Posted on Dec 07, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Where is the egr valve on a 99 Ford expedition


The EGR valve is in a very difficult spot to work on. If the EGR is bad it will set off the check engine light and make the vehicle run rough or stall at idle. It really doesn't make it run rough while driving or accelerating. What are the conditions when the car runs rough?

Mar 01, 2014 | 1999 Ford Expedition

1 Answer

My 1999 ford expedition idles rough when I turn on the air conditioner


the rpms drop because you are adding more of a load to it. it should level out after a few seconds.

May 04, 2017 | 1999 Ford Expedition

1 Answer

99 ford expedition 5 .4 engine.driving along-heard 3 beeps,then lost all electric,then another 3beeps.car made it to the house,then refused to start-as if dead battry. alternator died?


Check to make sure your battery terminal connections are clean and tight. It is the most common cause for losing power like this.

Feb 12, 2011 | 1998 Ford Expedition

1 Answer

2000 ford expedition ,,rough idle in park..rough idle in drive,, sometimes dies..rpm's in drive at idle 400...replaced iac


Check the fuel pressure at the rail assembly, there should be a min of 40 lbs at the rails. Do you have any loss of power under a load? You may have an issue with your o2 sensor that is causing the ecm to send an improper signal to the engine ign/fuel map.

Dec 07, 2010 | 2000 Ford Expedition

1 Answer

Everytime I stop and try to just idle my expedition has started to try to die or die. I have a 1997 Ford Expedition. The check engine light is also on.


On top on the engine, all the way to the back, and down a little, there some vacuum connection, one has an elbow that always leak's, start engine and feel back there, 9 out of ten time's that's the problem, that will also set an engine light on for lean.

Aug 09, 2010 | 1997 Ford Expedition

1 Answer

99 expedition running lean and dying when at idle


Sounds like a vacuum leak. Look for obvious vacuum hoses broken,squished or off. Check at egr valve, dpfe sensor & solenoid. These are all common to go bad. If not obvious take carb cleaner with snorkel attached, spray intake manifold & hoses etc. If idle raises while spraying you located vacuum leak. The propelent in the can temporarily seals leak while its being sprayed. Be careful not to spray on wires or anywhere there is a spark.

Jun 14, 2010 | 1999 Ford Expedition

1 Answer

2004 Ford Expedition sluggish idle


these vehicles do have problem with Idle Air Control Valve, this component is controling your idle speed. it's very easy to replace.
it's located on the throttle body


c5d0fe5.gif

Mar 29, 2010 | 2004 Ford F150

1 Answer

99 Ford Expedition, turns over but won't start..


My 02 Explorer had a similar problem and it was the Idle Air Control value. Had it replaced and it started and ran fine. Not had to replace if you that's the problem. I had it towed and then the mechanic read the codes and replaced the IAC.

Oct 19, 2009 | 1999 Ford Expedition

1 Answer

99 Expedition, runs rough, won't idle, no power.


it could be two things a bad injector or a the intake gaskets are leaking

Apr 01, 2009 | 1999 Ford Expedition

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

19 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...