Question about 1998 Ford Expedition

1 Answer

WHY is MY INSTUMENT panel not working?

All the gauges do not work and the fuses appear good.

Posted by Anonymous on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 3,218 Answers

Try slapping your hand on the dash above the instrument cluster a couple of times to see if it comes back. If not, there may be a fuse that you have overlooked

Posted on Apr 26, 2015

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedometer and Battery Gauges stopped working. could it be a need to replace fuses or is it a problem with the motors that drive the gauges?


there is a lot of issues with GM instument clusters .I have a 2004 chevy cavalier in my shop with the same problem. just replace the instument cluster

Oct 30, 2012 | Cars & Trucks

1 Answer

1997 mustang instument cluster problems


If the warning lights work we will assume the fuse for "cluster" or "gauges" is good, so the problem may be in the printed circuit board inside the cluster. I can't tell if there is more than one power wire for the cluster from the fuse box.

Aug 16, 2012 | Ford Cars & Trucks

1 Answer

Instument panel not working..gas guage, speedometer,etc.


check the connectors on the back of the cluster,and the solder joints on the pc board.these are known for being intermittent on the 97 to 2000 cherokee.also check the gauges fuse in the fuse panel

Apr 14, 2010 | Jeep Cherokee Cars & Trucks

1 Answer

Ford galaxy 2004 instument panel lights not


You may have a faulty circuit in the instrament panel assembly, only further testing would prove or disprove my theory?

Oct 31, 2009 | 2004 Ford GT

1 Answer

2003 1500HD 4x4 instument cluster not working


you may want to trace the fuse for the instrument panel check the voltage on it ,take juice from some other fuse and help it ,for more options you may want to trace both ground and power to the back of the instrument cluster,if fuse has no power relay or bad wire may be the fault

Aug 16, 2009 | 2005 Chevrolet Silverado 1500HD

1 Answer

Instument panel does not work


Hello,I will try to give my input.Try looking under the drivers side and passengers side of the dash.If not there look in the kick panels.The kick panels are as follows;To the left of your feet,sitting in the drivers seat,and to the right of your feet sitting in the passengers seat.If no luck finding the fuse box in the vehicle,look in the owners manual under fuses,and it will direct you to a page number,If you find out there is no other fuse box,or the fuses you find are all good,pull the cluster(where you where talking about,the gauges and ect.)and look for the bad ground.If I can be more helpful,please contact me >roniecon@gmail.com

Jul 12, 2009 | 2004 Buick Rendezvous

1 Answer

No lights work on instrutment panel


Check 2 fuses. Instument lights / panel and also the brake light fuse. Sometimes the brake light fuse blows and you have no dash lights.

Apr 03, 2009 | 1991 Jeep Wrangler

1 Answer

Instument Guages


well the issue is youe enitre gauge cluster i do understand that your speedometer is working but it is a cable speedometer not electronic like everything else in the gauge cluster so first i would recomend checking the voltage getting to your gauge cluster then just replace the guagecluster they are really cheap i a salvage and not hard to install at all but the cluster itself is not very comon to go out so make sure you check voltage to it first i wouldnt want you to go through buying and replaceing the cluster and that not fix it

Jan 20, 2009 | 1991 Mitsubishi Eclipse

1 Answer

Instrument panel is not working


Found the problem! The main cable going to the under-hood fuse box was rubbing against the metal bracket that the fuse box mounts on. Can we say poor electrical layout?? It had rubbed the sheathing off the cable and had broken one wire (the one supplying power to the instrument panel.) So I fixed that and cut a section of rubber hose and put it over the bracket to help prevent such events from occurring in the future.

Dec 21, 2008 | 1997 Pontiac Grand Am

Not finding what you are looking for?
1998 Ford Expedition Logo

Related Topics:

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

fordexpert

Level 3 Expert

5546 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...