Question about Chevrolet Cars & Trucks

1 Answer

My 93 Chevy truck 4.3 has a miss in it I replaced the plugs,wires ,distributor ,and rotor .and all of the filters ,and belts . And still have the same miss in it ? It starts perfect but idles rough .

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 12,537 Answers

You could have a burnt valve on the cylinder that's misfiring ! Do a compression test ! could have bad fuel injector ! What type of fuel injection does yours have TBI - throttle body injection , MFI - multiport fuel injection . Pull plug wires one at a time to see what cylinder is not contributing !

Posted on Apr 26, 2015

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: 1997 chevy truck running rough

Is this a 5.7? They are notorious for intake manifold gasket leaks. When mine did it, the diagnostics blamed it on an ignition misfire also! Replaced the gaskets and it runs smooth!

Posted on Apr 01, 2009

  • 77 Answers

SOURCE: 1996 Honda Accord Rough Idle Even After tune up

Perform a valve clearance inspection and adjust if necessary. Tight or sticking valves will cause a misfire or rough running concern. Note: Perform valve adjustment when the engine is stone cold. 4cyl: INT 0.26mm EXH: 0.30mm (V6 engine are hydraulic and no adjust necessary.) Also check for a sticking or stuck open EGR valve. For diagnostic purposes only: Remove the EGR valve. Place a business card over the EGR passage and bolt the EGR valve back on. This plugs the EGR ports and if the misfire goes away the EGR valve is partially stuck open and is defective.
Check for low fuel pressure. Check for low compression. Check cam timing. Check for a weak ignition coil. Also don't over look the possibility of worn or broken engine mounts which cause excessive engine movement and engine vibration. -hope this helps

Posted on Mar 05, 2010

  • 1 Answer

SOURCE: I have a 1997 Mitsubishi Galant with rough idle

I am having the same issue on Mitsubishi Galant 02. Clattering on acceleration, herky jerky idle. Pulled a code multiple cylinder misfire. My mechanic's diagnosis is bad valve cover gasket causing oil to seap into the spark plugs and bad timing belt, which I have not replaced at 150k miles. I do however know my fuel injectors do need cleaning, he hasn't ruled that out either. Have you pulled any code on it? I have read on engine knock sensor going out on some of these also. Hope this helps some.

Posted on Oct 22, 2010

  • 24 Answers

SOURCE: My 1994 Chevy Silverado 5.7

This misfire could be an intake valve or exhaust valve stuck open. Remove spark plug, and use a fiber optic camera to look in the chambers to look at the valves. It could be a bent valve or badly worn edge of a valve or simply a build up of carbon debris. I own a 95 Jimmy with a V6 Vortec and it has the same problem with a miss. mine is a bad valve, I hope yours is something small, but I hope it helps anyhow.
D

Posted on Jan 06, 2011

SOURCE: Ford F150 engine backfiring, running/idling rough

I Have a 1999 ford f150 4.6 that back fires and is just running really ruff when idling alot of nack fire a sord of like a pulse going on what is my problem?

Posted on Oct 12, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Every time it starts raining truck starts missing and cutting out it's a 97 f 150 ford 4.6 motor.


Possibly a plug wire or cracked distributor cap. I'd take a spray bottle and while it's running (be careful not to get your body parts in danger of the fan) spray some water on the cap area. If everything seems fine, you could spray down each plug wire at a time. See if you find the culprit that way. For a vehicle so old, if you haven't done a tune up lately. It's probably a good time. Replace the distributor cap and rotor. Plugs and wires.

Mar 27, 2016 | Ford Cars & Trucks

1 Answer

I have a miss in a 5.7 chevy replaced plugs wires timing chain mass air flagging 1,2 and 3 all have 180 compression also replaced distributor new cap and button


What year? Does it have a distributor? If so, possible distributor cap/rotor issue. If coil over plug, you need to run a compression test to see if a cylinder is weak/valve issue

Jul 30, 2015 | Cars & Trucks

1 Answer

Missing problem


Missing problem requires to check the following systems and components:
1. Fuel system. (Fuel pump, fuel filter, fuel injectors).
2. Ignition system. (Spark plugs, spark plug cords or wires, ignition coil, distributor (cars with distributor type ignition system, rotor, distributor cap, ignition amplifier), Coils On Plugs (COP) and correct sequence of the spark plug wires and or Igniter connectors.
3. Air leakage in the intake manifold.
4. Detached vacuum hose.
5. PCV Valve.
6. Servo brake booster pipe or diaphragm.
7. Valve clearance.
8. Cylinder compression.
9. Contaminated fuel.
10 . ECM.

Oct 06, 2013 | Toyota Corolla Cars & Trucks

1 Answer

I have a 2001 chevy blazer that is missing i have already replaced the distributor ,cap and rotor button and the plugs and wires what else do i need to check


make sure spark plugs gaps correct for the 4.2 engine gap need to be 0.050 for the 4.3 engine gap need to be 0.060. replace fuel filter and clean fuel injectors. missing problem also caused by weak ignition coil.vacuum leaks around intake manifold look for leaking hoses.if all is good do a compression test engine could have burn out valves.

Aug 02, 2013 | 2001 Chevrolet Blazer

1 Answer

Ok so i have 95 chevy silverado i change plugs wires,plugs,rotor button, distributor cap, fuel pump,fuel fiter and it still is missing up i have to hold it to the floor and it takes a bit to crank anyone...


Check distributor I have a 93 1500 pull cap and trun engine over watch the shaft if nothing turn truck off and check free play on rotor bug shaft

Jan 28, 2013 | 1995 Chevrolet K1500

1 Answer

Ok I have replaced the Distributor, Cap, Rotor, checked all spark plugs and my 93 chevy c1500 is still jumping RPM'S when driving and will shut off! Can someone please help me??/


It could be a fuel problem, the pickup coil in the bottom of the distributor, or the ignition module among other things.
Someone would need to figure out if the ignition system is causing the problem or if one of the injectors is failing.

Sep 30, 2012 | 1991 Chevrolet C1500

1 Answer

1999 chevy blazer not starting


Check the plug wire from the ignition coil to the distributor cap.
If you haven't already, replace the distributor cap and rotor.
The GM Vortec's have issues with moisture getting inside the cap and rotor and causing problems.

Apr 24, 2012 | 1999 Chevrolet Blazer

1 Answer

Motor missing on my 1995 3/4 ton chevy truck. Replaced wires, plugs rotor distributor cap and coil. Still misses


compression test the cylinders... could be gasket / valve leakage so its worth a try. if low readings on any cylinder then remove head to find out problem.

Jul 31, 2010 | 1995 Chevrolet K1500

1 Answer

I have a 93 mercury topaz that stalls while driving


if it only stalls hot relace the ign module on distributor

Oct 05, 2009 | 1993 Mercury Topaz

2 Answers

93 chevy g20 van


More than likely it's the distributor. They have a tendency to build up corrosion and rust and have personally went through the same situation three weeks ago on a suburban. Check to see if you are getting spark from the distributor first. Have the ecm in the distributor checked at Oriellys for free. It's under the rotor and has two 8mm head bolts with wires plugged in at each end.

Jun 22, 2008 | 1993 Chevrolet S-10 Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

83 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...