Question about Cars & Trucks

Open Question

Turn signals speedometer tachometer does not work

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 27 Answers

SOURCE: Speedometer/ Fuel Gauge & Tachometer not working

check for loose connection at the instrument cluster.

Posted on Jun 29, 2008

emissionwiz
  • 75005 Answers

SOURCE: speedometer and tachometer

Both are in need of repair, nothing else will cause this kind of problem except the inner electronics of both instruments, they can be repaired by any authorized Hyundai electronics repair station, but it won't e cheap.

Posted on Nov 18, 2008

  • 1 Answer

SOURCE: speedometer and tachometer stopped working

If the speedo isn't working properly, the first thing to check is the output speed sensor wires on the rear right side (near the bar code) of the tranny case. Follow the wires and make sure it hasn't been cut, pinched or shorted.
If all is well there, take the output speed sensor off. Watch out cause you'll get wet with tranny fluid (Dexron 6). (Be ready to plug it up.) If there are no metal chips or debris on the magnet inside, check it with an ohmeter on the two pins to see what the reading is. It should be around 6 to 10 ohms. If it's not steady, get a new one. Make sure the pins are clean on the connectors.
Apply some white or build grease around the shaft and "O" ring and re-install. Don't overtighten. The bolt is a "tap-tite" and should need only about 5 or 6 ft/lbs torque. (Run it in and give the bolt a quarter turn.)

Posted on Apr 15, 2009

  • 1 Answer

SOURCE: 2000 ford winstar- speedometer,tachometer started

Same exact issue with 99 Windstar...is it the alternator, contacts in cluster or what. Checked the fuse and all was good. Anyone have any ideas?

Posted on Aug 20, 2010

Z71guy
  • 154 Answers

SOURCE: Speedometer and tachometer dont work when vehicle

Pretty common problem with these. Here's a guide to learn how to fix GM instrument clusters yourself, I used it to fix mine and it worked great.How to guide for Sierra instrument cluster repair

Posted on Oct 05, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 96 Ford Explorer 4.0 tachometer goes backwards when I rev it up


Tachometer / Speedometer Problems: - Ford Explorer and Ranger ...

www.explorerforum.com > ... > Under the Hood

Jul 31, 2006 - 13 posts - ‎11 authors
Tachometer / Speedometer Problems: Under the Hood. ... upon restat the speedo goesto (is driven to) zero, the tach goes to ... 88 89 93 95 96 Aerostars ... in cold weather it seems to stick. but once the truck's interior warms up, .... 1995 Ford Explorer 4.0Automatic My Tach Quit Working And So Did My ... 5R55S harsh shifting; bump engaging reverse;
17 posts
Sep 3, 2011
Not starting - speedometer / tachometer needles going ...
3 posts
Jun 29, 2011
Tachometer Problem
12 posts
Nov 7, 2009
Solved 5R55E - No First Gear Problem
19 posts
Dec 7, 2000
More results from www.explorerforum.com

1999 Ford Explorer , Erratic RPM Problem - YouTube



Jan 01, 2016 | Ford Cars & Trucks

1 Answer

HOW TO FIX MY SPEEDOMETER AND TACHOMETER. AS THEY ARE NOT WORKING AT ALL. THE SPEEDOMETER HASNT WORKED SINCE OWNING THE CAR AND THE TACH JUST STOPPED WORKING.


replace the cable for the speedo as it may have been removed so that correct mileage was not recorded
the tacho gets its signal from coil impulses or ignition module so check for disconnected wires

Dec 12, 2015 | Cadillac Cars & Trucks

2 Answers

Turn signals not working, speedometer and tachometer not working


Provided you've checked all fuses etc first, You may want to have a look at this article. Googling ( soldering dodge caravan cluster ) as well . There are videos on you tube.
Here's the link. ( http://www.allpar.com/model/m/repairs/3G-cluster.html )

Mar 23, 2014 | 2001 Dodge Grand Caravan

1 Answer

Pontiac sunfire Gauges not working after Battery change


Just pull out the 10amp cluster fuse and put it back in. The cluster will pop right back up. My 2004 does it every time the battery goes dead.

Apr 23, 2012 | Cars & Trucks

1 Answer

My Tachometer works ,but my speedometer doesnt ? In mornings when cold it hesitates and misses, once it warms up it does great. Why ?


The hesitates and misses is probably a chock problem, especially since when it warms up, it does great.

Since you weren't very specific on your indications, I thought a general troubleshooting guide might be helpful to you. But you might want to look on ebay for a shop maintenance manual for your vehicle if you plan on keeping it for awhile and doing your own maintenance.

This answer is applicable for many BMWs in addition to the one listed below.

Q

The tach and speedo work most of the time, but sometimes work sporadically.


A
Here is a write-up on the initial steps in tracking down a speedometer and/or tachometer problem.
Applies to: E23, E24, E28, E30, E32, E34 with speed sensor units mounted in the differential housing cover.

1) Speedometer - The speed sensor may be faulty. The sensor is mounted in the differential cover. Remove the harness plug and remove the sensor. Clean the sensor and measure the resistance (should be 0.0 Ohms). If there is any resistance higher than 0.0 (zero Ohms), replace the sensor. If the resistance reads correct, reinstall the sensor.

2) The wiring at the connector plug for the speed sensor (in the differential housing) may be faulty and corroded .... pull the boot back from the plug housing and inspect the wires and the pins.

3) The actual speedometer and/or tachometer head may be faulty. It may have a loose connection within it or a cracked circuit board.

4) The speedometer or tachometer head may be loose on the main instrument circuit board (do the gauges change or move if you smack the top of the dash, above the gauges?). Remove the instrument cluster and check the mounting of the speedometer/tachometer to the circuit board. See the attached issues of our Fast Times newsletter for assistance in removing the instrument cluster, on E30 3-series models (see the articles on replacing the PC board and replacing the odometer gears for info on the removal of the instrument cluster).

Fall 2005 Fast Times Winter 2004/2005 Fast Times
DIY E30 PC Boards DIY Odometer Repair

2005_n405_newsletter.gif 2005_n105_newsletter.gif

5) The plug that carries the impulse signal into the instrument cluster may have loose contacts. The plug for the speedometer signal is located on the driver's side of the back of the instrument cluster (on the E30 chassis). If you remove the lower dash trim panel (the one above the driver's knees), you can reach up and touch the plug. It is in a vertical position and has up to 26 wires in it. If you wiggle the plug, while driving, and the speedo comes & goes, you have loose contacts in the plug connection.

6) You may have a problem with the service interval PC board and it's NiCad batteries. If your oil change and service interval lights can not be reset (or will not stay reset for an appropriate time period), the PC board is likely faulty. This can affect the various gauges, including the speedometer and tachometer. If the PC board is faulty, I would suggest replacing it (after checking the other areas noted above). See the attached Fast Times newsletter article on replacing the service interval PC board.

In your specific case, I would suspect that you need to replace the service interval PC-board, if your service reminder lights can not be reset or do not stay reset.

Jun 02, 2011 | 1997 BMW 7 Series

2 Answers

2000 ford winstar- speedometer,tachometer started to move crazy,then the tachometer dropped to zewro and hasnot worked since,but the speedometer works sometimes,and acts crazy sometimes. How does the...


Same exact issue with 99 Windstar...is it the alternator, contacts in cluster or what. Checked the fuse and all was good. Anyone have any ideas?

Aug 16, 2010 | 2000 Ford Windstar

1 Answer

No speedometer or tachometer


according to all that you said it has to be only one problem. there are no GND connection. all you have to do is to make sure that body is connected to engine body (thick copper wire) and both of them are definitely connected to battery - ploe.

Mar 27, 2009 | 1996 Volkswagen Golf

1 Answer

Cars


You have two sensors on the engine that send a signal to the computer, speedo, and tach. If just one of these sensors goes bad your speedometer and tachometer can just stop working. Check if these sensors are blocked or if broken then replace.

Good Luck!

Dec 13, 2008 | 2004 Mitsubishi Endeavor

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

14 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...