Question about 2009 Nissan Versa

1 Answer

I have a nissan versa 2009 and the car engine start, when i put the drive on he don't want acelerate ( walk) more than 20 km ( no check engine light on ) somebody could help me?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

You have to check petrol filter ,
if not , there is high sound when you accelerate the car

Posted on Apr 18, 2015

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2009 versa hatchback my service engine soonlight came on .i checked my gas cap it wasn't on right so I fixed the problem but the light is still on .How do I get rid of it


you could unhook the battery terminals for a little while then reconnect them. or you could reset code using a code computer. your local auto zone could do it for you, or mechanic. very easy

Apr 05, 2017 | 2009 Nissan Versa

1 Answer

Nissan Versa 2009 P0420 code need to get fixed. Do I change the catalytic converter right off the bat or is there cheaper routes to start with? Thanks


Someone was telling to put paint thinner to gas to burn the stuff in catalytic. Get more info.Chip catalytic still PO420 .It is big problem I have the same but did not try thinner because I changed catalytic.

Oct 10, 2016 | 2009 Nissan Versa

1 Answer

My hazard lights and rear defrost buttons don't work. How Where are they located and how do I replace them??


Did you look in the ipdm module
https://www.youtube.com/watch?v=tazwT1wqodw
use a voltage probe to easily find blown fuses
https://www.youtube.com/watch?v=gKgmIcmp7eo
https://carmanuals2.com/get/nissan-versa-2009-owner-s-manual-89355
page 8-24
shows engine bay locations

May 25, 2017 | 2009 Nissan Versa Hatchback

1 Answer

What does it mean when a 2009 nissan versa does not accelrate


run the fault codes first
it could be a blocked cat converter of fuel pressure problem

Apr 12, 2015 | 2009 Nissan Versa

1 Answer

I have a 2004 Nissan Murano that loses aceleration completely while driving.The vehicle crank well and start but loses acceleration after just 15 minute of driving,then I have to pack and start again...


There should be a check engine light on.You will need to retrieve the diagnostic coded from the computer to help you pin point why this is occurring. Go to autozone they will do this for free.

Feb 23, 2015 | 2004 Nissan Murano

1 Answer

Transmission on 2009 Nissan Versa Hatchback SL


dont go to mr transmission. I have had to go back 15 times then i finnaly sold the car because they recked it. sounds like a speedo sensor or the sterio installer cut the wrong wire

Mar 13, 2013 | 2009 Nissan Versa Hatchback

2 Answers

Blue light on left side of dash looks like a thermometer on a 2009 Nissan Versa


This is simply a notification that the vehicle is not yet up to temperature. Once the vehicle warms up after a few minutes running, this light will go out.
This is there to warn the driver not to use the vehicle too aggressively while the vehicle is cold as this will promote a greater amount of wear and tear on the engine.

Nov 03, 2012 | 2009 Nissan Versa

1 Answer

Good idle poor acleration and check engine comes on


vehicle in limp mode --have the check engine light checked most auto stores offer this service for free the code will assist in solving your problem

Aug 24, 2017 | 1994 Toyota Celica

1 Answer

I have a 2006 Nissan Maxima and it is causing me problems. Check Engine light came on about three months ago but drove fine. No loss of mileage or anything. Did not pass smog do to a P2A00 code (O2 sensor...


i have a 2006 nissan maxima 6 spd. when i purchased it there was 89,500. i replaced the clutch disk, release bearing, pressure plate and added a brand new flywheel(from the nissan dealer). a few days afterwards, the check engine light came on with a P2A00 and a P0420. when replacing the clutch kit i had to remove the exhaust system. i thought that i did not correctly install the exhaust system. after many inspections, i did do a good job installing the exhaust system. at this point i replaced the upstream, bank one oxygen sensor(a pain in the rear). i pray for God to lead me to the problem. don't try this at home but i jacked the front of my car up and rested it on jack stands and chock the rear tire. i started the engine and got under the car under the engine. i heard an exhaust leak at the bottom of the bank one, rear catalytic converter. one that catalytic converter, it has a small heat shield tack welded at the bottom. after taking that heat shield off, i found that the two tack welds at the top of that heat shield had broken causing an exhaust leak. THANK THE LORD! after plugging those holes and drive my car normally for the next two days, the check engine light when off. problem solved!

Sep 06, 2009 | 2006 Nissan Maxima

Not finding what you are looking for?
2009 Nissan Versa Logo

Related Topics:

181 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...