Question about 2000 Oldsmobile Silhouette

1 Answer

How to troubleshoot a no fuel problem, no fuel at fuel rail in a 2000 olds sillhouette.

New pump, relay in fuse block good. good fuse

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Oldsmobile Master
  • 2,486 Answers

First check there is battery voltage to the pump and the pump starts when the ignition is switched on , if not check fuse and relay, check wiring from relay to pump. If ok and the pump is working , check for fuel blockage from the tank inlet to the pump , some have a sock type filter in the tank pick up tube, if all ok remove the fuel filter , switch on and fuel should flow at the filter, fit a new filter, if still no fuel at the rail fit a fuel pressure gauge an check for low pressure , if ok, the fuel pressure regulator may be stuck causing a air lock replace it.

Posted on Jan 03, 2016

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 232 Answers

SOURCE: falls dead when driving, will restart after awhile

Did you try checking or replacing the coolant sensor? I think you should replace it along with the thermostat. Are there any problems like sputtering or any unusual noises or symptoms? Smoke, anything?

Posted on May 06, 2009

cadman000
  • 607 Answers

SOURCE: Fuel pump relay

GM relays don't reset. My guess would be the electric fuel is not operating, For openers , I would start with the FUSE for the fuel pump. In a fuse panel UNDER THE HOOD. Should be marked. Probably a 30-40A maxi fuse. CHECK WITH A 12 VOLT TEST LIGHT. If that area passes all the tests, I would check for power to the fuel pump ( with the ign key on. 12 volt test light will go ON then OFF ) Could be a faulty fuel pump, Hope this helps

Posted on May 07, 2009

  • 273 Answers

SOURCE: 1989 Cutlass Supreme Won't Start, 3.1 v6

possibly a blockage on carb fuel inlet

Posted on May 13, 2009

emissionwiz
  • 76691 Answers

SOURCE: Fuel system of 94 olds ciera 3100

the fuse is marked ECM 1 or ECM 2 and is under the hood, as is the fuel pump relay, also these have fuel pump connector problems, did u carefully inspect the pins for heat damage?.

Posted on Jun 05, 2009

  • 395 Answers

SOURCE: 98 olds regency fuel relay were is it

its under hood on side panel it's black take top off look for relay that says fuel

Posted on May 22, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Truck fires but wont stay running....... but everything was working great 8 hours ago


check oil pressure switch
after prime 3sec. the run relay for the fuel pump passes through
oil pressure switch on block before run on fuel pump can carry
fuel pres to injector rail

Feb 22, 2012 | 1999 Chevrolet Silverado 1500

3 Answers

Here's one for the books. 2000 Jaguar S Type 4.0 Sport - no fuel pressure past fuel pump. Checked inertia switch, fuel pump fuses and relay - all good. Installed new fuel filter, fuel pump was shot -...


check if the input side of the fuel pump has a restriction . a perished rubber hose can be a problem , the pump should be able reach a pressure 35 psi + and a flow of a quart every 30 seconds at this pressure.

May 16, 2011 | 2000 Jaguar S-Type

3 Answers

I have a Jeep grand cherokee laredo and i have installed a new fuel pump and fuel filter but it will not start i have checked all fuses and relays please help.


Having same issue with my 2000 grand cherokee. sometimes fuel pump will prime and car starts the other 50% of time no fuel pump noise only smaller radiator fan will come on and make vibrating whining noise. I have changed out fuel pump and filter as well as checked and ruled out all fuses/relays involved. Need help too

Aug 04, 2010 | 2000 Jeep Grand Cherokee

1 Answer

Fuel pump is not getting power, pump is brand new, not sure what fuses, or where the ground is located.


Hi....
Fuel PUMP fuse and relay is located in the Engine compartment
Fused block . Driver side. under the hood.
The Fuel pump relay Is labeled F/Pump.
And the Fuel Pump Fuse is labeled ECMB ( 20 amp.)
The ground for the fuel pump is located At left rear Frame rail.
Some times the Fuel pump harnes connector burn with the old pump.
Check the connector....

OK.. I hope this help on your question.
Thank you for use fixya..

Feb 03, 2010 | 2003 Chevrolet S-10

2 Answers

2000 Jaguar S-type 4.0 sport no fuel pressure at fuel rail new fuel filter, fuse is not blown, and can't find a fuel pump relay anywhere. Cranks over well, should my next step be to replace the fuel pump...


this is the fuel pump itself that has failed, replace it. It is located inside the fuel tank and is sold as a module assembly about $675
BOSCH Part # 67935 {Fuel Pump Assembly}
or as just a pump which you splice into the old sender assembly fuel pump module for around $120
AIRTEX Part # E2314 {In Tank Electric Fuel Pump}
Strainer included with pump.

Oct 14, 2009 | 2000 Jaguar S-Type

1 Answer

2000 jeep wrangler just shut off changed fuel pump


check foe fuel pump presure at fuel rail,,,if u have fuel pump presure check all fuses with a test light not buy sight,,could be deceviving ,look at and check to see if fuel pump relay is working if no fuel presure i,if u have presure in fuel rail ,replace the cranck shaft sensor

Jul 03, 2009 | 2000 Jeep Wrangler

1 Answer

Ran yesturday, tried today no fuel in lines, or pressure in rail, fuel pump not activating


Check the fuel pump fuse and relay under the hood in the fuse panel. If both fuse and relay are good then fuel pump may be at fault, but it seems too new for a fuel pump replacement. Hope this helps. Keep me posted please. Good luck

Apr 27, 2009 | 2005 Dodge Ram 1500

1 Answer

2000 S-10 NO power to fuel pump


check your fuel injectors fuses they tie in with fuel pump.

Apr 12, 2009 | 2000 Chevrolet S-10

Not finding what you are looking for?
2000 Oldsmobile Silhouette Logo

118 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8531 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...