Question about BMW Cars & Trucks

1 Answer

99 bmw 540i 6spd. Tach and speedo quit. Works sometimes. Sometimes not. Affects numerous things. Throttle, a/c blows warm, DSC light, temp gauge etc. You think its speed sensor or abs module?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • BMW Expert
  • 113 Answers

Most likely speed sensor. the fronts are the same, and the back 2 are the same. but the fronts are not the same as the back. I believe it's the right front for the above problem.

Posted on May 19, 2015

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
jmeyer847
  • 185 Answers

SOURCE: ABS Problems

Gary,

Just went through this problem with my Dakota as well. This is a very very very common problem with the Dodges. First things first. Replace the Vehicle Speed Sensor on the rear differential. Cost around 40 dollars at your local auto parts store or even from the stealership. Its easy to change as well one nut and off comes the bracket then the stud comes off and then you can take out the sensor. They big key is here to be VERY careful pulling out the sensor or you will break it off in the housing. You will need to slowly turn and pry it out with a small screwdriver (as there is an Oring holding it in). Reverse the process to install the new one. After you get the sensor in, reset everything by pulling the negative off the battery and leaving it off for 30 min (some require less time but 30 min is safe) to ensure all is reset. Hope this helps you.

Sincerely,

Jeremy

Posted on Nov 10, 2008

  • 261 Answers

SOURCE: electrical

the actual proble is in the BCM which means body control module, i will first check and make sure that all the grounding cables to this vehicle is tight and clean and if they areok and the problem continues it is time to get a new or rebuilt BCM.

Posted on Nov 24, 2008

  • 151 Answers

SOURCE: gauges not working

Ur instrument cluster is most probably the culprit. Smack the dashboard to see if it helps. If it does, bingo, most probably a bad weld on the cluster circuit board. Happens alot on VW's.

Posted on Feb 03, 2009

  • 7 Answers

SOURCE: 99 lancer,speedo tacho n gauge problem.

probably burnt or cracked circuit board on back of gauge cluster

Posted on Jun 21, 2009

  • 1 Answer

SOURCE: BMW warning lights: BRAKE, ABS and DSC

i need anyone one to help me with this problem, i have a BMW328ci and i tried tyo get out of my house this morning and all roads were frozen and the car started sliping and i activated the dcs button and car was still slipering and then brake, ABS, CBC & DSC lights turned on and i need to know how i can reset these lights so they can come off

Posted on Jan 12, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 Satria, Tacho and Fuel gauge dont work . Fuel gauge comes up now & again low fuel light works. Tacho works now & again. But speedo and temp do work all the time.


It may be that the speedo and temp are mechanical, whereas the tach and fuel are electrical. Check fuse for inst. cluster for clean and tight fitment. Check electrical connection at back of inst. cluster.

Dec 09, 2014 | Cars & Trucks

1 Answer

Air conditioner doesnt always blow cold. It does sometimes. P


One thing that affects both the cooling system and the a/c is the cooling fan.
Could be a bad fan motor or relay. Or a connector.

Jun 29, 2012 | 2000 Volkswagen Jetta TDI

1 Answer

Tach & speedo not working


Had same problem with my 2000 dodge stratus 2.4 liter and transmission would not shift out of 1st gear. Solution was ignition fuse under the hood was blown, one side of fuse working, replaced 10 am fuse everything works, tach, speedometer, gas gauge and transmission started back to shifting.

May 27, 2010 | 1996 Oldsmobile Achieva

1 Answer

Instrument Panel Problem - Electrical


check all wiring and maby youl get it right

Sep 18, 2009 | 2005 Chrysler PT Cruiser

1 Answer

I've got a 1991 BMW 525i which has done 253,000 km. It's been a good car but, the instrument panel on the dashboard has gone silly over the past couple of weeks. When I first start the car in the morning,...


this is just a rough guess, but i think it would be the battery or the alternator. Some part store have testers that they will check both for free.

Aug 14, 2009 | BMW 525 Cars & Trucks

1 Answer

99 lancer,speedo tacho n gauge problem.


probably burnt or cracked circuit board on back of gauge cluster

Jun 21, 2009 | 2002 Mitsubishi Lancer

2 Answers

Fuel and Temp Gauge go on and off intermitently


faulty wiring for the lights, and blinkers....

broken gears for the fuel and temp gauge...

just get rid of the damn car, get a Civic of the same year.

I was given a 323 once, unsiezed the rear brakes (the idiot left the thing parked with the e-brake on all winter), then sold it for beer money.

Apr 18, 2009 | 1988 Mazda 323 Hatchback

1 Answer

98 540I 6spd Hessitation problems at W.O.T.


i have came across this problem before.timing out by one tooth on timing gears; get it checked out.hope this helps yo.adrian

Feb 18, 2009 | 2003 Audi A4 Cabriolet

1 Answer

Speedo/tach only works after car has been sitting


More then likely the tiny electric motor called the "stepper motor" is defective, a common failure.

May 01, 2017 | 1995 Volkswagen Golf

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Frankie B

Level 2 Expert

65 Answers

Fred Sops

Level 2 Expert

272 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...