Question about Cars & Trucks

1 Answer

Turbo Seca the instrument cluster doesn't light up. Cranks and doesn't start. Only happened after the new battery went dead. No headlight, horn or turn signals, after full charge

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cars & Trucks Master
  • 44,435 Answers

Use a scan tool to reset the ECM and CPU program
the dead battery has probably corrupted the program

Posted on Apr 14, 2015

  • 1 more comment 
  • Lance Mobley Apr 14, 2015

    1982 Yamaha xj650lj. Motorcycle. Couldn't post it under motorcycles on my phone. So I posted under automotive.

  • Lance Mobley Apr 14, 2015

    1982 Yamaha xj650lj. Motorcycle. Couldn't post it under motorcycles on my phone. So I posted under automotive. Doesn't even crank over when I remove the CDI. Maybe a bad rectifier?

  • Lance Mobley May 04, 2015

    Motorcycle. How do I connect a scan tool? Went through the harness and soldered all the crimp on connectors. Got the cluster back operational. No cranking now. Doesn't start.

×

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 4 Answers

SOURCE: Instrument panel went dead

Checked Every fuse in the fuse box (no small task).This includes #4 - Power point Instrument Panel, #14 - Day time running lamps (auto lamps doesn't work nor does auto lock), #27 - ignition switch run feed, #35 - Instrument Cluster, #41 - Instrument Cluster, #42 - Delayed Accessory, #45 - Ignition switch run/start feed, #102 - Door locks body security module, #103 - Ignition switch, #110 - Ignition switch, & #116 - Ignition switch. But I also check all other ones as well, they all register OK. AC panel & radio work. Turn signals work. Mileage does not work, trip computer does. So, basically, everything works except auto head-lights, auto locks, and the dash cluster (no MPH, RPM, mileage display, Fuel, Temp, Tran Temp, and Oil Pressure).

Posted on Sep 30, 2009

johnjohn2
  • 5763 Answers

SOURCE: 2004 Impala battery goes dead sporatically.

try removing radio, ive had 3 impalas that drove me crazy! daignosing, they would drain the battery if car sat a weak,ending up being the radio shorting inside, dont know if thats your problem but i would start there, dont remove fuse have to remove the radio! hope this helps.

Posted on Nov 16, 2009

  • 1596 Answers

SOURCE: 1999 dodge caravan intermittent instrument cluster

This Seems Indicative Of a Poor Connection AT The CLUSTER Or A Junction Connecter Close to the Cluster. This is Assuming you Have Ruled OUT ALL ABS COMPONENTS, LOOK at These VERY CLOSLY Because of the Small Volts These Wires Carry , the SMALLEST DEFECT WILL Cause this Type of Symptom that you have given. Please try all of the Above, I feel Confedint that athis is where your Problem Is.

Posted on Jul 16, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

03 silverado cluster went dead when battery went dead ,put new battery in and sill nothing ,can you help me


Do you own a professional type scan tool ? Would need to see if the instrument cluster can communicate with scan tool . That would be a priority . If the instrument cluster ,for some reason wouldn't be talking,checking power an ground for the cluster . Batteries going dead , changing batteries without a alternative power supply can cause modules to go to sleep permanently ! Battery Disconnect or Replacement Problems I'am not saying that's what happen to your's . 2003 to 2006 GM had cluster problems ! The solder use in the cluster caused silver migration , instrument cluster caused a drain on the battery overnight . Watch these videos !

Chevrolet Truck Battery Dies Overnight Part II

Chevrolet Truck Battery Dies Overnight Part

Apr 04, 2017 | Chevrolet Silverado Cars & Trucks

2 Answers

Have 2001 cavalier headlights and instrument cluster not working what could be the cause


2001 Cavalier Gauge Problem - YouTube





? 7:50


https://www.youtube.com/watch?v=RzilY3gxexA

Jun 22, 2011 - Uploaded by 04holmes1

My 2001 Cavalier gauges go out in a very strange way. The 2min describe the problem, then at 4:54 you can ...





2000 Cavalier electrical problem - YouTube





? 1:02


https://www.youtube.com/watch?v=o7NU0y09mOo

Feb 25, 2011 - Uploaded by kodykills

Heres my car, being a piece of crap. If you know what might be wrong, let me know! **UPDATE** The problem ...





2002 Chevy Cavalier Gauges: Electrical Problem 2002 ...




https://www.2carpros.com/.../chevrolet-cavalier-2002-chevy-cavalier-ga...







Electrical problem 2002 Chevy Cavalier 4 cyl Front Wheel Drive Automatic ... I have a 2002 Cavalier and the instrument cluster did not work after replacing the battery. ...My 2001 honda civic lx gauge cluster turns on then turns off then turns on ...




Chevrolet Cavalier Questions - Why do my gauges stop ...



Jan 13, 2016 | Chevrolet Cavalier Cars & Trucks

1 Answer

Odometer won't work unless headlights turned off, radio lights dim, blinker won't blink all the time now battery light comes on but battery tests good. Intermittent issues getting worse. Horn


You probably have a bad ground in the electronic instrument cluster, or cluster connection to wiring harness. I would recomend you have a qualified auto tech diagnose it. It is not a easy fix.

Mar 16, 2013 | 2000 Ford Expedition

1 Answer

How to change the horn on a 2011 ford fiesta


How do you know it's the horn ? Do you have a volt meter ? Check for voltage at the horns . Before replacing parts , test . Go to youtube an watch a few basic electrical trouble shooting videos . Your vehicle has two horns an the possibility of both going out is 0 . When you press the horn switch it is a signal to the BCM - body control module , then the BCM turns on the horns . Do you have an airbag light lit on the instrument cluster ? The clock spring in the steering column could be open .What fuse did you check . F32 in the battery junction box - fuse box under the hood in engine compartment . How cars clock spring works

Nov 12, 2012 | 2011 Ford Fiesta

1 Answer

2002 ford ranger tail lights and instrument cluster lights out


There are a total of six fuses that control exterior lights and dash lights. Check all of these Fuses: 10, 21, 3, 7, 13, 33
Does the high mount stop light work when you apply the brakes?

Jul 19, 2017 | 2002 Ford Ranger Regular Cab

1 Answer

Headlights, taillights, tack, horn, stopped working on my 93 dodge dakota


Jerry,
One simple thing is taht none of the Instruments can work or illuminate without 12 Volt Power. Obviously, you have many possibilities that can cause your problem. 1. Age of Vehicle and it's wiring system. 2. Have you checked the fuses using an Ohm Meter to really check that they are good? 3. Any flexible printed circuitry in the Instrument cluster can come detached from the plastic backing and no longer mate with the Wiring Harness Connectors. 4. Are there any Idiot Light Bulbs? If so, check each one individually after removal with a known good 12 Volt power supply.

Check all sources of Power starting at the Battery and work your way up to the Instrument Cluster making sure that you are getting 12 Volt power to the cluster. Also check for Ground at the cluster. This will require an Ohm Meter. Any wire can be fractured invisibly inside the Insulation. The older the vehicle, the greater chance for this to happen. Many fractures occur from Opening and closing door(s), Vibration and Road Shock while running over severe bumps and under hood heat. Grounded points under the Hood and Chassis often become corroded and no longer have good enough continuity to provide a good ground connection. Any one of these things can be very time consuming to trouble shoot. Firewall connectors where many vehicles have upwards of 20 contacts are a very common problem for corrosion especially from Road Salt Spray. These must be thoroughly inspected, cleaned and lubricated with white grease to prevent further corrosion. You might find one or more contacts deformed during original factory assembly. This is not uncommon. To properly diagnose your problem you will need a complete wiring diagram for your vehicle.

Good luck!

Dec 15, 2011 | 1993 Dodge Dakota

1 Answer

Instrument cluster went dead except lights. was told it was an Instrument cluster problem. Put in new cluster it is also non responsive except for lights


Replaced once before and still periodically happens. Disconnect battery and reconnect and it starts working on our voyager.

Feb 07, 2010 | 1997 Plymouth Grand Voyager

1 Answer

Instrument cluster going dead after airbag light comes on


I had the exact same issue with my 1999 cherokee. None of the gauges worked, the red airbag light was on, the horn didn't work etc.... After going to several different mechanics, it was determined that i had a bad ECM computer. I got online, went to autocomputer exchange.com, got a remanufactured computer, put it in... and all the gauges now work. I highly recommend doing this, because the dealership will screw you for almost $1000 for a new computer... whereas, I paid only $225 for the one from autocomputer exchange. Anyhow, everything works great now.

Dec 14, 2009 | 1998 Jeep Cherokee

4 Answers

Instrument panel went dead


Checked Every fuse in the fuse box (no small task).This includes #4 - Power point Instrument Panel, #14 - Day time running lamps (auto lamps doesn't work nor does auto lock), #27 - ignition switch run feed, #35 - Instrument Cluster, #41 - Instrument Cluster, #42 - Delayed Accessory, #45 - Ignition switch run/start feed, #102 - Door locks body security module, #103 - Ignition switch, #110 - Ignition switch, & #116 - Ignition switch. But I also check all other ones as well, they all register OK. AC panel & radio work. Turn signals work. Mileage does not work, trip computer does. So, basically, everything works except auto head-lights, auto locks, and the dash cluster (no MPH, RPM, mileage display, Fuel, Temp, Tran Temp, and Oil Pressure).

Aug 19, 2009 | 2003 Ford Excursion

2 Answers

Instrument Cluster lights do not go on, emergency lights steady- Sable 2002


Has anyone figured this problem out? Our 2002 Sable just started this as well...instrument cluster lights out, turn/hazard lights on when the headlight switch is turned on. This has the auto on/off switch with fog lights. This is happening in the auto and manual on mode. Any solutions would be appreciated.<br />

Oct 23, 2008 | 2001 Mercury Sable

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

50 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...