Question about Cars & Trucks

1 Answer

I've replaced fuel filter, crankshaft sensor, everything spark related has been cleaned or new

When first started rpm revs high for a minute then normals out, when car stalls smells like a rich fuel mixture out of the exhaust, here's my email please help stampamike@yahoo.com

Posted by Anonymous on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Cars & Trucks Master
  • 2,422 Answers

Is the vehicle a chevy Understand I can't say for sure with out actully looking the thing .
But it kind of sounds like a fuel pressure regulator the rich smell of gas is a sign that its working wright
From what you have said it is a fuel problem but its unlikely a pump problem . Was the old fuel filter clogged or restricted and what differance if any did it make after you installed the new filter

Posted on Apr 08, 2015

Testimonial: "It's a 2001 saturn sc2, the fuel filter was just old thought it may help to replace"

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

97 oldsmobile achieva wont fire changed coil pack spark plugs cam sensor still wont start


Make sure battery has a full charge and battery connections all good.
If it cranks good but won't start, have a helper crank it while you visually check for spark at the spark plugs. If spark everywhere, use a gage and check proper fuel pressure and fuel injector pulse.
If you having a problem with more than one system, I want to check for rpm signal, that usually comes from the crank sensor. Not sure why you replaced cam sensor? I always want to check sensor wiring circuits before replacing anything. Don't replace anything unless your testing points in that direction.

Nov 04, 2016 | Oldsmobile Cars & Trucks

1 Answer

2003 windstar stalls when driving, idles high in neutral, now 4 codes


ok so much done owell next is the mass air flow to be checked then the fuel regulator to check pressure and the fuel pump for pressure and then check the cat,s for back pressure wood be my next thing and Last is the how many Km,s does it Have ?sounds like filter needs lookin at in the tranny if she,s got High Km,s if not then check the intake for leaks it,s Plastic so don,t hurt gone this far Let me Know What Happens,s Thank,s

Apr 08, 2013 | 2003 Ford Windstar

1 Answer

Replaced bad fuel pump, installed new relay and fuel filter, engine turns over but is not firing on..... positive the fuel pump is pumping gas and checked to see if gas was going thru fuel filter. Tried...


Hi, Ok you have confirmed that it's not a fuel problem. You need to check for spark. Pull the coil wire off of the coil(secondary lead-looks like a spark plug wire) Have some one crank it over and listen for a popping sound. IF yes, spark is at the coil, that means all ignition sensors are working. Next check for spark at ends of wires after cap. IF no replace cap and rotor. IF yes remove a couple spark plugs and check for fouling(wet, fuel etc...) IF yes replace or clean plugs and retest for starting. IF no spark is present at coil you need to scan computer and watch for rpm signal. IF no rpm signal, replace crankshaft sensor with OEM delco part. BIGGEST problem with these engines is Cap and Rotor burn out.

May 23, 2011 | 2002 Chevrolet Blazer

1 Answer

My 1996 4 cylinder, manual trans, dodge avenger buckles/jerks while driving after 20 - 30 minutes. Engine light is on - multiple misfires. Performed cylinder pressure test, each cylinder is 160 psi....


on the side of the engine near the oil filter is the crankshaft position sensor. some time those get heat sensitive .noamaly the sensor is not to pricey. so its more cost effective to just replace it.


sgm1115_93.png

May 13, 2011 | 1996 Dodge Avenger

1 Answer

I have a 1991 ford explorer 4.0L Eddie Bauer edition. The idle revs to 2000 rpm's and then will drop to no less then 1200 rpm's. If I give it the gas it dies whether I'm in gear or not but when I...


There are several problems and they are all related. Check plugs if they a white with gray ash buildup. Gap .054

1. Fuel pressure regulator, if it is ruptured fuel will be vacuumed straight into the the intake causing idle surge also in causes temperature fluctuation and poor performance. It will also cause lean running condition.
2. The Mass Airflow Sensor also has a huge impact on mixture, defective symptom was a knocking and clattering under load especially uphill. Cleaning will only give temporary fix.
3. Spark Plugs- Do not use Platinum plugs they run hotter than standard plugs!
4. Any intermittent starting problems are likely fuel pump related, when you turn the key in the ignition you should hear the pump running!!
5. Preventive maintenance is the key change your fuel filter at recommended intervals.

I have a 94 Explorer, it run very poorly after changing these items it runs great, restored power, idles great and great mileage again and finally no more temperature fluctuation.

Nov 05, 2010 | 1991 Ford Explorer

1 Answer

Why wont my chevy tahoe pick up speed ? we did everything , new spark plugs , new gas filter ,new fuel pump , new air filter , new gas filter , new spark plug wires , still it wont pick up speed . Why ?


did you check the timing? the firing order.
does the engine rpm rev up high? if it does then check the transmsission for low on fluid or slipping.
check your catalytic converter for clogged up.

Apr 27, 2010 | 1997 Chevrolet Tahoe

3 Answers

'90 3.1 lumina euro idles ok but tries to stall when accelerated.


If the cat is red then it is probably plugged if the motor can't exhale it wont run at high rpm

Apr 11, 2009 | 1990 Chevrolet Lumina

1 Answer

87 Toyota Celica total power loss


Replace the Fuel Pump. I had the same problem and i did everything you did to find out that it was the fuel pump. I removed the tank and repaced the fuel pump and bingo! No more problems the car runs like new

Apr 03, 2009 | 1987 Toyota Celica

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

62 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...