Question about Cars & Trucks

Open Question

My rzr is throwing trouble code 636 witch is the crank positon sensor. starts and runs good until you reach 4000rpm's then cuts out and dies with an engine light.

Posted by on

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1243 Answers

SOURCE: van runs good until u

what engine and year,make, and model?

Posted on Jul 17, 2011

  • 1082 Answers

SOURCE: car starts and runs perfectly

Possibly the catalytic is plugged. How to know? Has this been getting worse over short time period week or two? Check out at exhaust shop..
Good luck.

Posted on Aug 18, 2011

lt1350
  • 32 Answers

SOURCE: why are so many trouble diagnostic codes being thrown

sounds like you speed sensor and your throttle poistion sensor

Posted on Sep 02, 2014

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why are so many trouble diagnostic codes being thrown


sounds like you speed sensor and your throttle poistion sensor

Sep 02, 2014 | Cars & Trucks

1 Answer

2000 lesabre sometimes stalls at hiway speed. Temp sensor?


Have a Repair Shop Diagnose that code

Don't throw parts at it

Nov 25, 2012 | 2000 Buick LeSabre

1 Answer

Ok so I changed out the throttle position sensor and its made NO difference~my truck is still Idling rough and dieing need some help here please~~


I guess I will start with asking why you changed the crank sensor and the TPS ?
Usually when the engine is stalling at stop signs the problem is a dirty throttle body or a problem with the idle air control valve.
If the check engine light is on it should have a code unless the PCM is failing. I would try another scanner next to make sure the computer does not have any trouble codes.

Aug 08, 2012 | Cars & Trucks

1 Answer

Car cranks but will not start. stars for 2-3 seconds. full pump is good. would it be the crank sensor? no codes


It sounds like you need a new fuel filter. It runs until the fuel runs out and the fuel filter is preventing the fuel pump from reaching the correct fuel pressure. If the fuel filter doesn't fix the problem, you might have a bad crankshaft or camshaft position sensor, but this would usually cause the vehicle to die once it has warmed up a bit (when the timing starts to advance).

Oct 12, 2011 | 2003 Ford Escape

1 Answer

Car starts and runs perfectly until engine reaches operating temp then loses power starts poping spitting firing all over the place until it dies. then it wont start again for 2-3 hours until engine cools...


Possibly the catalytic is plugged. How to know? Has this been getting worse over short time period week or two? Check out at exhaust shop..
Good luck.

Aug 18, 2011 | 1997 Chrysler Sebring

1 Answer

I recently changed my transmission and since that has happened, I am having trouble starting my vehicle. I had some codes come up that stated that the crankposition sensor and MAF or VAF is having trouble....


The only thing I can sugest is to check that all your ground wires are connected and tight.Just about all of your PCM grounds ground at the transmission.

Apr 24, 2011 | 2000 Oldsmobile Intrigue

2 Answers

Mazda stalls


I have a 1997 626 2.0L 5speed when im driven it like rev limits cuts out around 3500-4000rpm, and when i rev it up and past 4000rpm it stalls, anyone have a idea whats wrong??? thanks i just replaced the crank sensor and egr and still. good power put cuts out

Jul 03, 2009 | 1997 Mazda 626

2 Answers

Car cut off, won't restart, later cranks up fine , no fault code


had same problem with 2000 dodge ram. would run great then start to buck then die.let sit would start then same thing. it took some time for the crank shaft position sensor code to pop up. changed sensor (very easy) good ever since.

Feb 12, 2009 | 1994 Buick LeSabre

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...