Question about 2005 Toyota Avalon

1 Answer

I had to replace my main 120amp fuse. Is there any other fuses that would blow if you crossed battery cables.

After replacing altinator I was charging the battery and crossed the cables. I have replaced main fuse. Car wants to start but stalls when I let go of the key. I noticed my eng light does not come on when the key is in the on position. When I try to start it the light flahes

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Toyota Master
  • 531 Answers

Worse case scenario: you could have fried the ecu / ecm

anything electrical is effected; had a neighbor's car whole front end wiring to his headlight system got fried/melted together
do you have access to an obd2 scanner and plug it in to check?

in hindsight, this is one of the reasons why calling AAA for a jumpbox is better than having someone hook up jumper cables incorrectly ~ most also will connect the cables directly to the dead car's battery terminals when you're really supposed to connect it to "engine ground"

once you gave it a look over all the electrical wiring and fuses, time bo bite the bullet and take it to the shop ~ sadly

Posted on Apr 01, 2015

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kia optima hybrid 2012 not electrial function at all, the car is no working no ligths,not ignition complete dead what I need to do?


Did you replace the battery recently?
seem like your main fuse many may be 100 or 120amp fuse is blown and not powering little fuses.

Feb 18, 2017 | Kia Optima Cars & Trucks

1 Answer

I replaced my altinator and radiator today now my 120 main fuse keeps blowing. Why is that?


probably connected a wire from the fuse to earth and that is the reason the fuse keeps blowing ( dead short)

Jul 19, 2015 | Cars & Trucks

1 Answer

2002 Toyota camry i press the accelerator down and get nothing


Have someone clear codes and reset all adaptives and then see if its fixed. If not then youll need an ECU(computer). Hooking the cables up wrong will spike the computer and fry one or more quad drivers in the ECU.

Jan 01, 2014 | 2002 Toyota Camry

1 Answer

Replaced altinator now wont start


check a loose wire or fuse under dash or next to battery

Mar 27, 2012 | Chrysler Sebring Cars & Trucks

1 Answer

Put new battery in now car does nothing....no power going to car at all. not able to jump...no lights...no start...nothing. located relay box and cross-over wire burned out and one red square fuse. how...


Hi there,

Sounds like your Main 30A Fuse Link (i.e. hot at all times) or an in-line fuse may have blown, during cable connection (or due to incorrect jump starting).

First, follow the RED + battery cable from the battery and check if there is an in-line fuse along the cable - replace if blown.

The Main 30A (depending on model) Fuse is situated up in the engine bay fuse box.

These fuses carry a lot of current and hence, are usually secured into the fuse box by either large screws or 8-10mm bolts. Look for the mounting screws/bolts on the side of the blown fuse (you may have to undo another component to gain access to your main fuse).

Make sure the battery is disconnected BEFORE you attempt to replace any fuses.

Good luck..



"Please take a moment to rate this solution with a 'testimonial' and/or 'thumbs up', as this will keep my status active and allow me to continue offering technical support. Thank you."










Aug 04, 2011 | 1992 Subaru Legacy

1 Answer

My 97 Saturn SL! has a new starter, altinator and battery. When you turn the key to start it, there is nothing including any kind of sound or noise. The radio, lights, and blowe come on telling me it is...


IF STARTER FUSE AND RELAY OKAY.REPLACE THE NEGATIVE BATTERY CABLE COULD HAVE BAD GROUND AT CABLE.IF CABLE GOOD. I AM LOOKING AT FAULTY IGNITION SWITCH OR FAULTY TRANSMISSION SAFETY NEUTRAL SWITCH.

Nov 28, 2010 | 1997 Saturn SL

1 Answer

What will cause the 120amp fuse to blow in ls400


hi, this must be a dead short. if you connect a lamp and lamp holder with the battery and the other side of the fuse if the lamp is lit the short is still present. LEAVE THIS LAMP CONNECTED this testing can take a long time. you need to disconnect, seat motors, or any HEAVY CIRCUITS.ALTERNATOR TO CAR MAIN CABLE IGNITION SIDE. WHEN THE FAULT IS FOUND THE LAMP WILL DIM OR GO OUT. i am sorry that i cannot do any more. hope you sove this. gerry

Sep 10, 2010 | 1992 Lexus Ls 400

2 Answers

97 dodge dakoata main fuse keeps blowing 140 amp fuse


Regulator in alternator obviously faulty, have it bench tested & fixed or replace alternator, and cure your problem.

May 19, 2009 | 1997 Dodge Dakota

1 Answer

Electrical fault somewhere


Hi,
I think the problem is not the alternator but the conection in the 120Amp fuse to the main engine fuse box.
The actual contacts to the spade fuse are enclosed and the contact area cannot be cleaned (scraped) easily. The fuse does not pull out like the rest but is bolted in with two bolts (one 8mm and one 10mm) No one knows this at first, release the bolts on either side and work the spade fuse up and down many times to score the contact area.
When I first tested it it was showing some 20 ohms with a high impedance meter but after it was cleaned it showed close enough to zero.
The high resistance connection on the 120Amp fuse may have caused a volt drop (with all systems on ie engine, air, wipers, and headlights) sufficient to drop out the engine relay and it conk it out. It starts again readily but the low voltage may cause the stop light warning light to come on.
Volvo had the car for two weeks and couln't fault it after I did the clean and replaced the engine relay - but they didn't charge me - so good on them. They quoted me $1400 to fit a new alternator saying they had seen the problem before and they replaced the alternator and the cable which may have inadvertantly fixed the bad connection on the 120Amp fuse.
I worked for Volvo Truck for a couple of years as a contract Production Engineer but when sales went down I was moved on - guess I was too much of a smart arse. Renault owns them now - predictable I should have thought.

Apr 24, 2009 | Volvo V40 Cars & Trucks

Not finding what you are looking for?
2005 Toyota Avalon Logo

91 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7688 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...