Question about 2009 Mitsubishi Lancer 1.5

1 Answer

Random no start no power then it will start and run fine Checked Battery and grounds

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

U prob have a dirty connection. If u get it to start take it down to an auto parts store they will test everything for free

Posted on May 03, 2015

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 96 camaro rs my car woulnt start so I replaced the battery. Today when I started driving it the battery level was going down as I push the gas and it just suddenly stopped and turned the ABS Inop...


Pull the battery cable off one of the posts when the car is running. If it turns off, then that means your alternator is bad. If it keeps running without a batttery connection, then your alternator is fine and maybe something else is shorting out and drawing a lot of power. Sometimes speaker wires to an amplifier touch ground and just consume all your battery juice and then the alternator power too. So look fro a faulty ground if the alternator is working

Feb 23, 2015 | Cars & Trucks

2 Answers

2003 Toyota echo flashing battery light after installation of new battery.


The battery light indicates, when lit, that the charging system (alternator), is not supplying enough power to run the vehicle and thus is draining the battery of power. Under normal conditions this should never happen. Have your charging system checked.

Dec 31, 2014 | 2003 Toyota ECHO

1 Answer

My aviator won't start and its not the battery what can be it was working fine


I had a similar problem. My battery was new, charging at 14.5 volts when running, 12.4 volts static. Checked all battery connections and grounds, all good. Checked started and found it loading the battery with over 250 amps, normally about 75 amps. BINGO! time for a new started. Test your circuits with a voltmeter and ensure low resistance. Make sure your battery is charging.

Nov 21, 2014 | 2005 Lincoln Aviator

1 Answer

2006 gmc envoy loses power and stalls out


Take your Envoy to a competent mechanic and have it checked for OBD codes, etc. Otherwise, you are just replacing parts at random without identifying and solving the real problem(s).

Jan 13, 2014 | 2006 GMC Envoy

1 Answer

2001 Chevy Cavalier runs fine most of the time but will randomly not start. Sometimes will start a few hours later or the next day and run fine for days or months? The starter was replaced. When dead no...


the 'no lights' part makes me think it could be a bad ground -- follow the ground cable from the battery where it should connect with the chassis then continue on the the engine itself -- make sure it's very firmly connected at each point (battery end as well)

Sep 29, 2010 | 2001 Chevrolet Cavalier

1 Answer

1994 toyota estima intermittant start problem. makes click


This could be a grounding problem. Check all battery connections. Also check motor to body ground strap for corrosion. Check battery to motor ground and battery to body ground. Even if the ground looks allright it can be corroder underneath, so you have to take the ground bolt off to clean it.

Jul 29, 2010 | 1994 Toyota Previa

1 Answer

Fuel Pump wiring


If I understand right, I would say the normal ground for the pump is bad.
"I am guessing the pump uses a ground source to start." well, just the normal ground like for any motor, you have the power wire (gray) to the pump, then the ground wire for pump, does it branch off near the tank and find a ground? Or does it go into the tank connector and then routed back somewhere through the wiring harness? Anyway, it has to go to ground somewhere. You have the wiring right it sounds,. just make a good ground source, or find the original ground and repair it.

Mar 14, 2017 | 1999 GMC Sierra

1 Answer

My rodeo wont start and i have no power throughout


Providing the new battery is charged up, and your cables are tight on the battery end and at the starter and the ground wire is good and well grounded... there should be a fusible link in your positive cable. It has probably blown. It's a thick spot on your cable. Use a test light to see if there is power at both ends of the cable. At the battery post, and the starter.

Apr 29, 2009 | 1995 Isuzu Rodeo

Not finding what you are looking for?
2009 Mitsubishi Lancer 1.5 Logo

Related Topics:

19 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8211 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...