Question about 2001 Mercedes-Benz C-Class

1 Answer

I have a 2001 Mercedes c240. The radio produces no sound at all.. but seems to be functioning normally otherwise. I was told it may be an amplifier fuse... but don't know where that is located either.. please help. Thanks

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 787 Answers

If its got one it should be at the back of the radio(sometimes inside.
wish you well.

Posted on Mar 29, 2015

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
keemo68
  • 1263 Answers

SOURCE: Fuse for the radio on a 2001 Ford Taurus

do you have a owners manual? this will show the location and the purpose of each fuse and relay. the radio fuse should be red in color and be located in the fuse panel on the drivers side it is a 15 amp and is red in color... hope this helps you...please rate this thanks

Posted on Sep 02, 2008

  • 1 Answer

SOURCE: My 1994 Mercedes Benz SL500 radio display turns on, but no sound?

I had same problem with my 1994 SL600. Also when this happens you will lose your interior door lights when you open the doors. My problem was solved by taking out the, A-white 40 amp 12V Relay and cleaning off the 6-prongs and reinstalling. It is located in the box underhood ahead of the main fuse box. Just need a phillips screwdriver. It is the fartherest relay in back left. I had to pull the one out in front of it to be able to remove the white one. You can hear it click when you push in dooropen switch. When working right you do not hear it. Hope this helps.

Posted on Sep 18, 2009

jasperoni
  • 203 Answers

SOURCE: How To Change Oxygen Sensors in 2002 Mercedes C240 Sedan?

I do not know the part numbers but you have 4 sensors. 2 pre and 2 post catalytic converter. The pre sensors are the most sensitive and are generally the ones to fail. the rear sensors usually have a heater circuit problem. If your just replacing them for routine service interval I would just do the fronts. They connect to the engine wire harness in the front of the transmission pan. You may need an o2 sensor socket to remove the fronts. They are just a 22mm. in size.

Posted on Oct 18, 2009

Testimonial: "Thank you for the reply...I appreciate your time! Will replace front O2 sensors and see if check engine light goes out...thanks again...Jamie."

  • 1 Answer

SOURCE: Fuse location on Mercedes Sprinter 312D 1999

Mercedes Benz S550 problem with taking park and wont turn on

Posted on Jul 25, 2010

TDISLine
  • 1874 Answers

SOURCE: i have a mercedes benz

The fuse box is placed in the engine compartment:

tdisline_591.jpg
tdisline_592.jpg
Fuse no.# 21 - F21 (25A) is for radio & audio amplifier system

Posted on May 30, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 2001 Mercedes c240 and there is no sound for the radio. Radio is coming on and searching channels properly. .. just no sound? ?


pull the stereo unit out check the rear wires and the rear fuse some times there are 2 fuses 1 for unit its self and another for the amp if its still not working try another cheap radio if that works its the stereo if not there is something wrong with speakers probable worth just replacing head unit will work out cheaper

Mar 29, 2015 | 2001 Mercedes-Benz C-Class

1 Answer

Where is fuse for amplifier for speakers in 2003 t&c


speaker relay ,under dash ,bottom row 2nd from the left

Mar 09, 2015 | 2003 Chrysler Town & Country

2 Answers

No sound output in 2000 BMW 328i 4dr Sedan but radio functions properly?


Hi Toxey.

Does your trunk amplifier got power.
basically amp need remote power input it is coming from your radio.
please check when you turn on the radio remote power must turn on.
if no it is radio problem or wire is damaged itself.
please check the outputs,speakers with multimeter or single 1.5v cell.
if power is ok.and the remote on signal is ok your device still not working , it is the problem with power amplifier unit.

please check and let us know the status.
regards.
nuwan

Jan 20, 2014 | 2002 Chrysler Town & Country

1 Answer

L have a 2001 C240 Merc and after starting (and warming up )moisture comes out of exhaust pipe( approx a couple of teaspoons). The other day after driving for some time, when stopping at the lights it...


One gallon of gas produces about 1 gallon of water vapor,its gotta go somewhere......thats why its best to run a car hot.have you seen a cars exhaust in winter,its steaming.......and the exhaust pipe is made of steel.....its cold..therefore CONDENSATION.

Nov 10, 2010 | 2001 Mercedes-Benz C-Class

1 Answer

C240 mercedes key wont turn seems locked... I went to my car used fob doors unlocked when I tried starting i inserted the key in the ignition and the fob will not turn seems locked..now all of a sudden the...


I have a 2001 C240 with the same issue. I removed the positive battery cable from the battery and kept it off for 30 seconds then replaced it. Everything was reset and the key worked.

Jan 12, 2010 | 2001 Mercedes-Benz C-Class

1 Answer

Radio, cd and Nav all have power but no sound out of speakers at all. Model is Mercedes Benz year 2001 S430. Where should I check


these models have a amplifier. if this has burned out you would get no sound. this is in the trunk, left side, behind the carpet.

Dec 17, 2009 | 2001 Mercedes-Benz S-Class

1 Answer

I just had the mass air flow sensor replaced in my 2001 merceded-benz c240 thinking it would solve the hesitation and loss of power. There is no power when I press on the gas peddle with about a 3-4 second...


IT SOUNDS LIKE THE TPS (THROTTLE POSITION SWITCH/SENSOR) IS BAD, BUT TO BE SURE OF THE PROBLEM ,YOU WILL NEED TO HAVE IT HOOKED TO A DIOGNOSTIC SCANNER & IT WILL PINPOINT EXACTLY WHAT THE PROBLEM IS.

Dec 05, 2009 | 2001 Mercedes-Benz C-Class

1 Answer

The stereo in my 2001 mercedes slk 320 produce no


hello,good day,try to check your number 14, for your left and rigth speaker amplifier control module,also try to check the fuse in your amplifier,ty

May 12, 2009 | 2001 Mercedes-Benz SLK-Class

1 Answer

The radio comes on but there is no sound


hello,good day,seems you need to bring your unit to your dealer,maybe erasing fault ,your speaker amplifier or radio configuration only,only the dealer have the tester (star diagnose),ty

May 09, 2009 | 2001 Mercedes-Benz C-Class

Not finding what you are looking for?
2001 Mercedes-Benz C-Class Logo

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

yadayada
yadayada

Level 3 Expert

77202 Answers

Joseph Prosser

Level 3 Expert

771 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...