Question about Cars & Trucks

1 Answer

Speedo keeps sticking then works again and so on

Need to know if it's the speedo or maybe in the g/box and may be a way to see what is causing the problem

Posted by Anonymous on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Loyalty:

    Visited the website for 30 consecutive days.

  • Cars & Trucks Master
  • 532 Answers

Best just to replace the inner cable.
You can try unplugging it under the dash and shooting wd40 a little at a time down the cable to lube it first

Hope this helps Mike.

Posted on Mar 29, 2015

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My speedometer stopped working so my truck is stuck in 1st gear


Hi Ber, It would help a great deal to know what vehicle and the year of manufacture we're talking about. Modern vehicles use the speed sensor to actuate the gear change on auto boxes. take the vehicle for a diagnostic scan. Have the speedo repaired and you will probably have the vehicle back to being faithful again. Regards John

Sep 09, 2012 | Cars & Trucks

1 Answer

Dodge avenger speedo sticks and doesnt seem to shift correctly after speedo sticks


Sticks? Where? Zero miles per hour, or a value above that? The problem is likely the speedo "head", the part immediately behind the speedometer that makes it work. And if the speedo is not working right, the trans will not either. It might be worthwhile to have it "scanned" to see if the computer can identify the cause of the fault.

Apr 18, 2011 | Dodge Avenger Cars & Trucks

1 Answer

Speedometer goes to zero every now and then


Does this happen intermittently, im guessing so with the wording "Now And Then" also when your coming to a junction/roundabout and the Speedo has gone to Zero, do you feel a decrease in power around 10% and dipping the clutch and braking causes the Red Warning light to flash top right hand side in the dash and the car wants to stall and or Cuts out?

I have this same Problem and Believe it could be the Speed sensor on the gearbox ( Around £30 on ebay that i have found) 50+ from ford Dealer.

My Quick fix to get the speedo back from zero this is what i have found works to make it come back It does not Totally fix the problem, it just makes it come back if the speedo has dropped again whilst Moving.

This normally stops it happening again until the next time the car is turned off or stood for a while I have noticed it happens More often when the fuel gauge is Below 1/4 and its been raining for some reason? so im thinking it might have a loose connector on the sensor and its getting wet? but have to get under to have a check.

try this to see if it works, it does for me and i have a V Reg Focus LX 1.6

------------------------------------------------------------------------------------------------------------

What to do when you notice the Speedo has gone Off .

1) turn the lights on and off then,

2) change DOWN a gear to 3rd, then UP to 4th then to 3rd again

3) and tap the Gear stick on the palm part with the palm of your hand quite hard and wiggle the Gear Stick left and right with dipped clutch in Neutral .

4) turn the main dipped headlights on and off again ( i found also if i have the Heater running it makes this happen so turn it on and off a few times)

5) if it is safe to do so, pull over and turn the car OFF leaving the key in the ignition and then back ON Within 10 Seconds, repeat 1) , 2) 5) again and repeat untill the Speedo Returns (normally within 2-3 mins of this procedure)

if anyone else knows how to fix it please Post any info :)

uni.ianjones@gmail.com

Feb 20, 2011 | 2000 Ford Focus

5 Answers

My speedo on my 1993 dodge cummins quit working, i use to be albe to get up to around 80km/hr and it would work again. also my overdrive doesn't work when i speedo isn't working. any ideas.


I am no expert on this but have the same problem. Here is where I am at. I bought the truck used, needed a new PCM which after installing one from a gas job and verifying that wiring was good, bought a reman from Chrysler. Speedo still did not work even though it did with the gas PCM but was fluctuating allover. Chrysler replaced PCM and speedo started to work intermittantly. Took truck into dealer and $600. later told mechanic thought it was faulty PCM. He called Chrysler and asked them to pull one from the shelf and test. They said needed a new crankshaft speed sensor.Mechanic took truck on the road, shifted into nuetral then turned ignition back on, speedo works. Replaced crankshaft speed sensor and situation didn't change. Total spent $1000. and no speedo and no overdrive. Speedo started working intermittantly, seemed like depending on transmission temperature. Friend that works on dodge said is instrument cluster. tried another cluster still the same. Replaced ignition switch, thinking that may be the problem. Still the same. Bought a new Neutral starting switch, which I have not replaced as of yet. If I place truck in neutral and start the truck speedometer is activated right away but does not stay. So right now am down to two scenarios. The neutral starting switch or,...... the temp sensor in the oil line. Feeling is it is the neutral starting switch. By the way had already replaced speed sensor in tranny and rear end. Going to replace neutral starting switch, cost is $25. for the part and see what happens. Please keep us posted, as others are having the same problem.

Nov 12, 2009 | 1993 Dodge Ram

1 Answer

Speedometer not working. I was driving when I noticed smoked coming from the wheel. A spring cable came out. Any one can help? thanks


I beleive you possibly have a earth problem on the engine and because of which the car tends to earth through the speedo cable causing it to get very hot and often melt the casing resulting in no speedo best to check all the earth straps on engine to body work for corrosion etc. if need be try using a jump lead off any steel bolt or fixing from the engine and put the other end on the body work and see if this works for the earth solution and regards to the speedo simply check th outer state of the speedo cable casing to see if its melted? you can allso remaove cable from gearbox end and spin using a hand drill or small low speed cordless drill to see if speedo then works?regards to the spring coming out? this is difficult to determine but maybe due to the over heating? so go through the above steps as the most important issue is the smoke/overheating which may have caused further faults.

Sep 16, 2009 | Fiat X1/9 Cars & Trucks

1 Answer

Powerwindows, windshield wipers, interior lights, and speedo do not work.


Hi have you checked the fuse box to see if any fuses have blown as that is the most likely cause of the problem.

Let me know if you have done this or if you need further assistance ok

Aug 17, 2009 | 1998 Ford Windstar

1 Answer

Won't shift out of first gear


good diagnosis that is correct if the vehicle speed sensor is not working the speedo doesnt work and the trans doesnt know when to shift

Jul 17, 2009 | 1998 Ford Windstar

1 Answer

98Civic speedo malfunctioned a bit, now fine, but engine light on


you can drive the car

should have the code read at a shop

possible cause is speed sensor problem???

Jul 01, 2009 | 1998 Honda Civic

1 Answer

L1995Lexus LS400 speedometer does not work-


I have a similar problem with the speedo needle which sticks at 0 occasionally. To get it working I tap firmly on the front of the instrument panel and it pops right up. I don't know the cause but it isn't a major issue. Try it.

May 10, 2009 | Toyota Tercel Cars & Trucks

1 Answer

1995 VW GTI VR6 tach and speedo


this could be a ground wire issue ...look carefully for loose or corroded wire to frame under dash black usually near harness under instrument cluster

Nov 07, 2008 | 1995 Volkswagen GTI

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

16 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...