Question about Chevrolet Tahoe

1 Answer

My Chevy Tahoe has no power and cant get up past 40 mph without starting to lose power, could it be Mass air flow sensor?

After filling up my tank, I got on interstate for about 5 mins and my check engine light started blinking and my truck started losing power, I can drive it around town at lower speed and it does fine, but once I try to get over 35-40 mph, it starts to stall, but has not actually died.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 2 Answers

Possibly, but it sounds more likely a catalytic converter may need replacing or fuel filter maybe clogged

Posted on Dec 15, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 2002 Tahoe I've replaced o2 censor fuel pump& filter spark plugs and corals it will start up but won't get any power it switches gears fine but once up to about 30mph it losses power on and off...


you have checked or replaced most things, but you probably need to replace the plug wires as well. also, check your catalitic converter or the exaust to see if it is plugged in any way. This will cause a lose of power. Have you check any engine codes in the system? If not do so. That may tell you what to look for AS well.

Mar 12, 2015 | 2002 Chevrolet Tahoe

1 Answer

Car wont accelerate past 40 mph


Folty fule pump or mass air flow sensor harniees problem

Feb 17, 2015 | 2002 Hyundai Santa Fe

2 Answers

Toyota yaris will not accelerate past 40 mph


sounds like transmission is sliping

Feb 01, 2013 | 2009 Toyota Yaris

1 Answer

My 2002 tahoe rpms jump up when I first start in the cold. Motor has slight lope in it until warmed up. why is this happening


Try cleaning your maf (mass air flow sensor) with maf cleaning spray and also checking or replacing your air filter if needed. These vehicles also have a cold start fuel injection system which is supposed to regulate the engine speed/idling until the vehicle has reached operating temp. You may need to get a professional fuel injector treatment which is much better than the bottle in the gas tank remedies which seldom do more than waste your money. I personally use a bottle of iso heet fuel additive when I fill up every 4 or 5 tanks this helps to remove any moisture which may be present in your fuel. I also recommend purchasing fuel without ethanol, it degrades the octane levels in your fuel and can cause reduced performance and build up on your intake valves.

Dec 09, 2010 | 2002 Chevrolet Tahoe

1 Answer

How do I install a mass air flow sensoe for my


just undo the hose claps on the air cleaner snorkle pull the connection for the mass air flow sensor and go backwards to install

Paul
www.carburetorexchange.com

Sep 02, 2009 | 2003 Chevrolet Tahoe

1 Answer

Po 101 and 300


To give you a little peace of mind, your engine is fine. I had the same problems with mine, and I totally forgot what they did to it and it was simple. I keep want to think it airmass sensor or throttle sensor its was one of those, they had the parts and seems like it took them 10minutes to replace and I was n and out. code 101 is airmass sensor and 300 is misfire the cause factor is from 101, you cant go faster than 40 to 50 mph even if you have the pedal to the floor..One of the mechanic state having Onstar system play a factor in it. Being electronics parts it may be still cover eventhough is 2003.

Aug 07, 2009 | 2003 Chevrolet Tahoe

1 Answer

Runs rough when cruising at 35-40 mph


try pulling off the air breather hose and look inside at the mass air flow sensor,it looks like a wire with a diode hooked to it incase you didnt know,see if there is any fuzz on it,sometimes the air filter will lose small pieces and the mass air flow sensor catches it.If that doesnt work then you may have a fuel problem,weak pressure,causing the mass air flow sensor to read too much air so it tricks the computer to adjust the issue.

May 20, 2009 | 1998 Ford Expedition

1 Answer

Having problems with my 96 chevy tahoe mass air flow


The MAF (Mass Air Flow) sensor is a very common problem with these along with the pickups. This isn't what you would call an inexpensive part. Definitely do some shopping before you buy one.

Nov 10, 2008 | 1996 Chevrolet Tahoe

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

242 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7768 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...