Question about 1995 Chevrolet Camaro

1 Answer

Replaced a spark plug wire that was arcing to fix an unrelated problem and the car drove fine until you put it under heavy acceleration. It would backfire and lose all power until u let off the gas. A mechanic told me to change my tps so i did and now my camaro won't start. I've taken it off 6 times and reclocked, cleaned the iac and checked vacuum lines. I reset te computer and it ran for 5 minutes and shut off and wouldn't start back up. 1995 camaro 3.4l 5speed. Help please!

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Chevrolet Master
  • 786 Answers

Check the oil, the low oil sensor will disable the ignition if more than a quart low. Next change the air filter, a dirty air filter can put the MAF ( mass airflow) sensor out range. Next change the fuel filter. A cough or back fire is an indication of fuel starvation. Always do the cheapest fixes first. Perform an OBDII scan for stored fault history before buying parts you don't need.

Posted on Jun 04, 2017

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Won't start


Year make and model. Is the security light staying on/flashing? Pull a spark plug wire and see if it has spark. That could be a coil/s or crank sensor.

Jun 26, 2015 | Cars & Trucks

1 Answer

Replaced rotor and distributor cap started right away, drove 3 miles stop 2 hr won't start cranks fine what next


Re-Check the wires. One may have come loose. For external coils, check there first. Next, make sure that the rotor is properly seated inside the cap on the Distributor.
Did you also replace any of the spark plugs?
It could also be completely unrelated. Haha. Check for fuel pump operations, and that you are getting fuel. Its either air/fuel/spark.
But definitely check the wires and rotor. Hopefully you put the securing screw back in.

Best of luck, mate.

Mar 18, 2015 | Cars & Trucks

1 Answer

1996 crown victoria misfiring loss of power under light to heavy acceleration, rough idle


The plug wires on this model year and prone to burn through, replace them all, do one at a time and always put them back in the factory wire looms they run through, that is very important, replace any you may break. Use high qyuailty oplug wuires foractory parts are preferred..

Jun 07, 2013 | 1996 Ford Crown Victoria

1 Answer

Engine running rough on take off


Under load on take off from a stop or under heavy acceleration when already in motion could be one or more spark plug wires breaking down/misfiring.
You may be able to duplicate by opening hood, have someone set park brake and hold foot hard on regular brake pedal, block wheels also and press on gas pedal to simulate the loaded condition. Stand off to side, not in front of van and see if the engine misses and you may hear a snapping as the spark arc to ground. More common on the 3.3 engine.

Jan 23, 2013 | 1997 Dodge Grand Caravan

1 Answer

1997 Oldsmobile Achieva - check engine light is on and car is running sluggishly...brand new motor installed 6 weeks ago.


What speed are you going when it chugs?
It could be as simple as a bad spark plug or a spark plug wire/boot grounding out.
When spark plug boots get old, the rubber cracks and lets voltage arc out the side and to the engine instead of through the plug.
This will be most noticeable when trying to maintain a speed of over 40 mph, or under mild acceleration.
The reason for being noticeable at this speed/acceleration level is that the transmission torque converter will be locked, transferring the vibration from any engine miss straight through to the wheels.

Jan 07, 2012 | 1997 Oldsmobile Achieva

1 Answer

Rough engine idle under heavy acceleration. After a heavy rain, I started the car and the idle was terribly rough. Changed out the spark plugs and wires. Its much better but the condition still exists...


heh, you might want to change the title here as I am pretty sure you cant idle under heavy acceleration.
However I think you were on the right track with the plugs and wires. You didnt mention the cap though and that is usually the biggest culprit in damp weather. Put a new cap and rotor on it and see if that doesnt do the trick.

Mar 25, 2010 | 1987 Oldsmobile Ciera

3 Answers

Rewired ford taurus spark plugs and when turns on it jumps what could i have done wrong?


If you replaced the distributor cap then there is a high possibility that you put the wires in the wrong firing order on cap.

If all you did was replaced the plugs, then I would pull each one out and recheck the Gap sizes with a feeler gauge. Also check to see if the spark/coil plug wires are touching metal or each other, which can cause the spark to arc out of the wire and never get to the spark plug. If I suspect an arc and do not see a physical problem, I wait until nighttime and look under the hood while engine is running...they stick out like a sore thumb. Also make sure that you did not put the wrong plugwire to the wrong spark plug.

When you change your plugs, you should also replace wires, cap and rotor.

Oct 17, 2009 | 2001 Ford Taurus

2 Answers

Under heavy acceleration the car stumbles, runs rough


I am having the same problem with my mustang, have replaced tps, egr valve and sensor, clean maf, new plugs and wires, new fuel filter, cleaned throtle body and still having same problems....Please help!!!!!

May 29, 2009 | 2002 Ford Mustang

1 Answer

Upon acceleration the car jerks then smooths out under heavy acceleration


Check engine light on? Most problem is spark plug wire breaking down. Replace spark plugs and wires.

Apr 29, 2009 | 2000 Mercury Grand Marquis

Not finding what you are looking for?
1995 Chevrolet Camaro Logo

Related Topics:

40 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8202 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...