Question about 1998 GMC Suburban

1 Answer

High beams do not work

Checked fuses.. They were good

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

I had this issue as well. My headlights did work but the high beams didn't. I replaced the high low beam switch under the dash bolted to the steering column. Go to rockauto.com and it'll be under your vehicle under electrical switches. The switch heats up and gets stuck in high or low. Common problem. Good luck!

Posted on Dec 13, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2009 ford focus high beams quit working . the fuses are good I have replaced the high beam multi function turn signal assembly


Your not going to want to hear this , there is a high beam relay inside the smart junction box , it's nonserviceable . Soldered to the circuit board . Do you know what a Smart junction box is ? Is ford BCM body control module . Have you checked fuse's inside the vehicle ? F23 15amp high beam .

Mar 19, 2017 | Ford Cars & Trucks

1 Answer

2010 impala high beams do not come on, light on dash comes on, replaced bulbs still don't work, checked all fuses, look good


High Beam Headlamp Operation
Battery voltage is applied at all times to the coil and switch sides of the HIGH BEAM PCB Relay located in the underhood fuse block. When the headlamp dimmer switch is placed in the high beam position, the headlamp dimmer switch signal circuit to the BCM is pulled low signaling the headlamp high beam request. In response to this signal, the BCM applies ground through the high beam relay control circuit energizing the high beam relay. With the high beam relay energized, battery voltage is applied through the switch side of the relay, the left and right high beam fuses, and the high beam supply voltage circuits illuminating the high beam headlamps. At the same time the BCM sends a GMLAN serial data message to the instrument panel cluster (IPC) requesting the IPC to illuminate the high beam indicator. Ground for the left headlamp is provided at G101 and the right headlamp at G100.

Nov 23, 2016 | 2010 Chevrolet Impala

1 Answer

No highbeams low works fine. changed switch but still the same fuses are good. help


98 Explorer No High Beams Problem - Ford Explorer and Ranger ...

https://www.explorerforum.com/forums/showthread.php?t=374129

Nov 15, 2012 - 16 posts - ‎8 authors
98 Explorer XLT 4X4 - No high beams. I've read thru many threads here and other places about this. Pulled and checked every fuse - all good ... Fog Lights Off When High Beams Activated - Normal?
19 posts
Nov 30, 2015
Headlights not working (not MFS, Fuses, or bulbs)
12 posts
Feb 24, 2015
97 explorer no low beams high beams
3 posts
Nov 4, 2013
no headlights in 96
15 posts
May 7, 2009
More results from www.explorerforum.com

Jan 03, 2016 | 1998 Ford Explorer

1 Answer

Had loose battery terminal, fixed it but now the high beams don't work


there is a relay for high beams try that it should be under the hood if you have fuse box under hood good luck

Dec 11, 2013 | Cars & Trucks

1 Answer

Low beams work high beams dont


The bulbs have 2 filaments, one for low beam and one for high beam. It's possible both high beam filaments are blown and you just need to replace the bulbs. You can check by measuring the voltage at the high beam terminal. You should see at least 12 volts when you turn on the high beams. If you do, it's the bulbs. If you don't it's likely the switch or the relay (assuming you've verified the fuses are good)

Jan 11, 2013 | 1996 Honda Accord

1 Answer

No high beams but low beams work


Have you tested the dimmer switch yet ?

Jul 14, 2012 | Ford Taurus Cars & Trucks

1 Answer

98 caviler low beam


98 caviler high beam left side dosent work canged bulb checked fuse and all good

Feb 06, 2010 | 1998 Chevrolet Cavalier

3 Answers

Low beam not working but high beam is-Pontiac Vibe 2005


I have heard it could be the Daylight Running Light module located under the dash above the brake pedal. The module controls both the daytime running lights and the low beam lights. The high beams are independent of this module.

I have the same problem. I am trying to buy a new module.

Jan 15, 2010 | 2006 Pontiac Vibe

1 Answer

My high beams stopped working,low beams still work


I have checked the Toyota web sites and the general conscientious is the high beam switch is defective.

Dec 14, 2008 | 2006 Toyota Camry

1 Answer

High beams not working...


More likely to be the high beam relay if it is affecting both headlights.

Oct 13, 2008 | 1994 Mercedes-Benz C-Class

Not finding what you are looking for?
Cars & Trucks Logo

128 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76673 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...