Question about Cars & Trucks

1 Answer

My 96 chevy 1500 4x4 has a 4l60e and I change the a and b silinoids changed the servo and the tps it reads code p1870 still.I can take off and it won't shift till I let off the gas then goes straight to 3rd and that's it no od it makes a werid nose in first I looked at the pan there is no shavings and the fluid looks fine what else could be wrong

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 20 Answers

What it sounds like is that you're losing pressure to activate the clutchesand or your bands are gone how many miles you're most likely looking to rebuild or replace to solve your problem

Posted on Dec 13, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
raycrazek
  • 106 Answers

SOURCE: 96 plymouth voyager no shift

you say the fluid looks good... that's great.
now next time your out drive for about ten good minuetes long enough for the transmission to get nice and warm and then pull over to nice level ground and with the vehicle in park check the fluid again. it's kind of hard to read because it always has a lot of bubbles on it and stuff. but it may be low on fluid.. good-luck ray

Posted on Jan 16, 2009

  • 24 Answers

SOURCE: ford 2001 explorer sport transmission slipping 2nd to 3rd gear

I agree with the shift solenoid being the problem.

Posted on Feb 21, 2009

emissionwiz
  • 76164 Answers

SOURCE: transmission won't shift into 3rd

the trans has a serious failure, that is why the metal, it can be overhauled for less than a replacement

Posted on Mar 30, 2009

Molson02536
  • 3854 Answers

SOURCE: 4L60E Shifts fine in 1st, 2nd, & 3rd but will not shift into OD

The EMC detected and problem so it's in limp mode, As long as it's in limp mode the 4th and OD will not activate. Take care not to burn up the transmission by running it hard while your in the limp mode.
Your going to have to get the truck scanned to clear any codes and why there are DTC codes. Auto Zone scan for free and most auto shops charge $10.00 to $20.00 to scan sine they want the business.
If you want to clear the codes your self you can put the ignition to the run position and pull the ECM (Batt) fuse out for 20 sec and place it back in then start the truck. It may stall but let it, just start it again and this would have cleared all the DTC code history.
The transmission should be running fine unless there is a problem and the service engine light will be on again and you'll be in limp mode still with an updated DTC in the ECM.
Good luck and hope this helps.

Posted on May 26, 2009

  • 208 Answers

SOURCE: 1993 chevrolet blazer fullsize 4l60e trans problem

first of all shavings are a bad sign likely internal damage has occured

Posted on Jun 22, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1997 Buick Lesabre Custom 3200. Error codes P1870 & P0740. No prior indication. Drive one block, sounds like axel connections in transmission are binding and rarely slipping.


Code P1870...What does it mean??? - GM Forum - Buick, Cadillac ...

www.gmforum.com > ... > 1992-199
Jun 9, 2005 - Location: Bloomington-Normal, IL 1997 SE ... Default Code P1870...What does it mean??? I got a CE light the other day, and this is the code that was read word for word: P1870 ... No TCC solenoid electrical DTC P0740 ... Code P1870 & Speedometer error, Hi_tork, 1992-1999, 4, 10-16-2011 04:08 PM.

Sep 14, 2015 | Buick Cars & Trucks

1 Answer

1997 buick lesabre- scan codes p300,p420,p1870,p1641. new plugs,wires,oil,filter,throttle blade cleaned,maf sensor,tps changed. now no acceleration with rough idle. could it be iac valve?


How about a blocked exhaust converter

They only last 12 to 14 years, under perfect
fuel trim conditions, with no misfires & you have
those or did

You changed the fuel filter & checked pressure at the motor?

IAC-Idle air control--so no--idle control is not your problem

Oct 07, 2014 | Cars & Trucks

1 Answer

I changed silinoids and it's still slipping. Its a Tahoe and when in park shows it's ok and when in drive shows off. U can manually shift the gears


If it is an automatic then no. If it is slipping then check the fluid level. Have a pressure test done on the transmission to check pressures. Run fault codes to determine if solenoid / servo problems . Change the oil. Pull the pan and clean out the filter and adjust the clutch packs and bands

Aug 01, 2014 | Cars & Trucks

1 Answer

I have a 1999 blazer I pulled the code p1870 if I change the control solenoid could that fix the problem?


Here is the definition of the code.
I doubt replacing an electrical component would do it.

P1870 CHEVROLET Description Transmission is in 4th gear with Torque Converter Clutch (TCC) engaged and the Engine Control Moduel (ECM) has detected excessive slippage when comparing the input shaft speed to the output shaft speed
Read more: http://engine-codes.com/p1870_chevrolet.html#ixzz26gqhKHvr

Sep 15, 2012 | Cars & Trucks

1 Answer

96 nissan quest code p0120 p1705 the O/D flushes after startup. TPS was replaced but code still exists. Rough idle, loss of power and fuel economy.


this is an obd2 trouble code table, it can help you understand the meaning of code.
and for p0120
the Causes:
Sticking throttle return spring
MAP or TPS connector corrosion
Misrouted harness causing chafing
Bad TPS
Bad PCM
Possible Solutions:
If you have access to a scan tool, with KOEO (Key on engine off) observe the TPS voltage. With throttle closed, voltage should be about .45 volts. It should gradually sweep upwards to approximately 4.5 to 5 volts as you depress the throttle. Sometimes only a scope can capture an intermittent glitch in the TPS signal voltage. If you notice a glitch in the TPS sweep voltage, replace the TPS.
NOTE: Some TPS sensors require fine adjustment. If you aren't comfortable with using a DVOM (Digital Volt Ohm meter) to adjust the new TPS, then it's best to take the vehicle to a shop. If the voltage is not .45 volts (+or- .3 volts or so) with the throttle closed or if the reading is "stuck" then unplug the TPS connector. With KOEO check for 5 volts reference voltage present at the connector and a good ground. You can check the signal circuit for continuity by jumping a fused wire between the ground circuit of the TPS connector and the signal circuit. If the TPS reading on the scan tool now reads zero, then replace the TPS. However if that doesn't change the reading to zero, then check for an open or a short on the signal wire and if none is found, suspect a bad PCM. If manipulating the TPS wiring harness causes any change in idle, then suspect bad TPS.

Jul 11, 2011 | Nissan Quest Cars & Trucks

1 Answer

My 2005 chevy impala recieved a code of P1070 and I am unsure of what that means. I could really use some help. I believe I need to change the spark plugs could this cause the problem I have?


Unfortunately not the best news: A P1870 code means the transmission reporting to the computer that something is slipping.

You could try flushing / changing the transmission fluid & resetting the computer, but transmission service could be in your near future.

Hope this helps.

Feb 23, 2011 | 2005 Chevrolet Impala

1 Answer

Check engine light code read P1870 on a 1998 s10 chevy blazer


Hi, this could be a common problem with Chevy S-10's. It has something to do with Valve Body. If you are aware of changing it, have it replaced right away for this might damage some parts on your precious truck. I have provided you a link where certain individuals were abel to reseolved this type of problem. Please click here.

Jun 07, 2010 | 1998 Chevrolet S-10 Pickup

1 Answer

Idle issues with 96 Chevy cavalier 2.2L OHV. everytime i try to adjust RPM's i get idle too high code. after doing research found that stop screw on throttle is factory set and should not be messed with,...


WHEN YOU MOVE SCREW YOU CHANGE TPS VOLTAGE READINGS YOU WILL NEED TO MONITOR TPS VOLTAGE AND ADJUST BACK TO SPECS DONT KNOW EXACT BUT SHOULD BE AROUND .50 AT IDLE

Mar 17, 2010 | 1996 Chevrolet Cavalier

1 Answer

1996 chevy lumina 3.4. service engine light on


You will need to replace the valve body in the transmission.

Mar 01, 2009 | 1996 Chevrolet Lumina Mini

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

15 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...