Question about Cars & Trucks

1 Answer

1993 TF Rodeo temp gauge not working, doesn't move from below C

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Cars & Trucks Master
  • 14,585 Answers

Replace the engine coolant temperature sensor.

Posted on Dec 13, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
csmock132
  • 4669 Answers

SOURCE: 2002 gmc van overheatig

It has a leak. Fill up the radiator and the coolant tank. Then restart it and check for leaks.

Posted on Mar 13, 2009

  • 395 Answers

SOURCE: My temp gauge is not working.

try replacing the coolant sensor

Posted on May 09, 2010

  • 11800 Answers

SOURCE: i want to replace temp

It's on the thermostat housing where the upper radiator hose meets the intake manifold. It looks like that
http://www.partstrain.com/store/details/Isuzu/Rodeo/Standard/Engine_Temperature_Sensor/1993/LS/4_Cyl_2-dot-6L/SITX18T.html?vdesc=true

Posted on Apr 23, 2011

bhowell786
  • 88 Answers

SOURCE: Was running fine, then i

It sounds like your fuel pump is bad. The fuel sending unit, which tells your gas guage how much gas you have is integrated into the pump so when you replace the pump it will fix both problems.

Good Luck!
~Brandon

Posted on May 27, 2011

  • 188 Answers

SOURCE: Speedo needle doesn't move, petrol gauge moves

hi can be conection at the back of cluster or a loose earth or the cluster is faulty,hope u get it sorted

Posted on Jul 05, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

93 tf rodeo temperature gauge not working, doesn't move from below C


check for broken wire to temp sender unit or wire missing off the sender unit. If the wire is there and attached then with a partner/friend turn the ignition to run and ground out the wire at the sender unit. If the circuit is ok then the gauge will go straight to hot and this will indicate a faulty sender unit.

Dec 12, 2014 | Cars & Trucks

1 Answer

My temp gauge in my 85 s10 doesn't work. it sits normal when the truck is off but when i turn the truck on it goes down to nothing and doesn't move? what might the problem be


sensor unit or wiring 2 the sensor try removing the wire see what gauge reads it should drop back 2 nothing if not problem in wiring or gauge it self

Sep 08, 2011 | 1991 Chevrolet S-10

1 Answer

My temperature gage on my 1993 corolla does not work I changed both sensors and thermostar and it still did not work


unplug the sensor that goes to the gauge and take a wire and put it in one end of the sensor wire and touch the other end to the battery ground or any other engine ground and get someone to see if the temp gauge starts to move if it goes all the way to hot then the sensor is bad and if it does not move the gauge is bad or the the wire from sensor to gauge is bad. good luck let me know if i was any help at all...............

Jun 14, 2011 | 1993 Toyota Corolla

1 Answer

99 holden rodeo,no fuel or temp gauge?


check fuses. also do the guages move at all when you shut the key off ?

Feb 09, 2011 | 1999 Isuzu Rodeo

1 Answer

My temp gauge is not working.


try replacing the coolant sensor

May 09, 2010 | 1996 Mazda MPV

1 Answer

My 93 jeep wrangler 4 cylinder temp gauge doesnt work right. when driving the gauge reads 0 when i step on the gas the gauge moves to the right temp. i have installed a new therm. new water pump new...


depending on how fast, this happens, could be an air lock in cooling syste, or a bad head gasket, or head. does the gauge ever go too high? can you hear gurgling in the rad, and does it ever push out coolant?

Dec 19, 2009 | 1993 Jeep Wrangler

2 Answers

Air conditioner, fuel gauge, and temp gauge all stopped working at the same time


Three possibilities;
All related to blown fuses,

1- Fuse blown in the engine compartment LH.
2- Fuse blown in the cabin forward LH below the dashboard (below your legs left hand).
3- Fuse blown in the harness (wire bundles) below the dashboard very easy to reach with your hands “just look underneath steering wheel ".

U said " The air conditioner blows, but the air is not cold.
" Yes only the fan working which might receiving power independent all from those other mentioned things.
If all fuses OK. Then look for broken wires.

Regards;
MAR

Jun 03, 2009 | 2003 Saturn L-Series

1 Answer

Temp. gauge not working after having a heater core replaced.


if the engine cooling system was not filled and air bleed out the system may have an air pocket and this keeps the gauge from reading correctly.

Apr 10, 2009 | 1993 Mercury Cougar

1 Answer

1998 Holden Rodeo TR series 5-speed manual 2WD


run the fault codes
look for ambient temp sensor or baro sensor problems

Jun 30, 2017 | 1992 Isuzu Rodeo

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

30 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...