Question about 2009 Chevrolet Silverado 2500HD

1 Answer

How to fix dash lights gages stop working and start working0 ... .0

Nothing

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Renaissance:

    An user who is expert in 3 categories / brands.

  • Chevrolet Master
  • 808 Answers

Remove cluster and take to speedo shop they can check and repair it .

Posted on Dec 12, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My brake light on dash comes on, all the odometer readings stop working and the gas gage goes down and the gas light comes on and the air stops working. What is wrong? it does this only sometimes then


You have an unusual electrical problem. There could be a loose ground wire from the dash gauges or a power wire intermittently opening. It may be cut or resting on a sharp metal part under the dash. It will take someone who looks past the obvious to locate the exact place where the problem lies.

Oct 07, 2014 | 2005 Nissan Maxima

1 Answer

I unplugged my cigarette lighter to fix the dash and now my dash gages don't work. Things like my gas gage, temp gage, ect. Where do I start to fix this?


your main plugins have become disconnected ,,there are individual plugs like for your instrument panel ,,,headlamps as well as all plugins ,,you apparently will have to remove your dash back some or crawl under it to ensure all components are plugged into the proper areas ...Note everything must be plugged in ,,leave nothing out

Oct 27, 2013 | 1994 Ford Econoline

1 Answer

Mazda 6 2005 u0101,u0155,u0121,u0073,u0100 codes coming up


I got the same problem. u ever figure it out? ive cleared codes and there the same. light on cluster lit up . plus some time after pulln away from stop car goes five mph. turn off start up drives fine. im about to burn this thing.

Apr 21, 2013 | 2005 Mazda 6

1 Answer

Fuel gage is not working along with odometer checked for fuses did not find took apart dash found nothing there what should i check next. Tempature gage and oil pressure gage still work fuel gage is right...


when you pulled the top of the dash off did you check the cable connection to the insturment cluster. i had a similar problem where my gauges died individually including the spedo and tach. slapping the dash usually would cause the gauges to start working again, but that quit also and i had to tear the cluster out and check the conneciton. that fixed the problem.

Oct 26, 2009 | 1992 Saturn SL2

2 Answers

I can start my car and all my gages work fine. speedometer,RPM,s ,Fuel, and temp. I can turn on my lights or heater and the gages start jumping all over. The indicator lights and shift indicator lights...


This problem drove me crazy for 2 weeks. Then the car just stopped running. It would turn over but it would not fire. I replaced the crank and camshaft sensors. That did nothing. I replaced the ignition switch and the car started right up. So if your dash indicator lights start doing a light show for you and your gages jump around or just stop working. Try replacing the ignition switch.

Oct 18, 2009 | 1996 Dodge Intrepid

1 Answer

It all started with my signal lights. they would not turn on or blink when engaged. and then the next time they would work. i checked all the fuses and bulbs all are good.. then just the other day my temp...


check the ground from the battery to the battery box make sure the bolt to the box is tight and not broken, If you ever had a battery leak then battery acid could have eaten the wire harness. just look it all over. good luck

Oct 08, 2009 | 2000 Pontiac Sunfire

1 Answer

Gages and dash lights


Have you checked the fuses? Look in the owner's manual for the locations... you might have just blown one.

Aug 15, 2009 | 2000 Oldsmobile Intrigue

1 Answer

My speedo has not been working today all the other gages went out and after about 4 hours started working again


It sounds like the connection to your dash gage may have gone lose do to everyday vibration. If everything was running fine without any check engine or service engine soon, then it's your dash gage. Before your start your truck and the key'sare in the run possition, your gages should move up then down checking it's self. Keep a eye on that. Good luck. easy fix dubble check connection. 

Apr 06, 2009 | 2003 Chevrolet Suburban 1500

Not finding what you are looking for?
2009 Chevrolet Silverado 2500HD Logo

18 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

77169 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...