Question about Cars & Trucks

1 Answer

2000 chevy milabu.starts great, but it runs 15 minutes or so and will shut down then it starts when it has cooled.i replaced the fuel filter ,fuel pump relay.and engine still does the same

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 49 Answers

You need to look in to the Crankshaft Position Sensor. This is a common symptom of a degrading CKP sensor, and it is also an easy cheap fix.

Posted on Dec 09, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine runs 15 or so will shut off and starts when cool. Replaced fuelfilter and fuel pump relay. still does the same thing.


If you don't have any check engine warning light on your dashboard relating to EGR system means it has to be the FUEL PUMP according to you fuel pump relay and fuel filter was replaced but the most common cause by that is fuel pump...to verify have you try to install Fuel Pressure Tester to a fuel line it might not be the specified psi while observing the tester a several minutes tester shows it dropping down the pressure till it shut off by itself.

Dec 09, 2014 | Cars & Trucks

1 Answer

1993 Eagle Vision.. Car runs great... for 15 min. Then falls on its face..try to start..barley runs...rapidly pump gas pedal car will run barley. shakes and chokes and sputers... shut the car down for...


Could be fuel pump is going out. Its getting hot not working properly and when it cools down it works right again for a short period. Ive seen this happen several times.

Oct 05, 2013 | Eagle Vision Cars & Trucks

1 Answer

2000 chevy blazer, starts but shuts right off


It Was the electric fuel pump on my blazer when that happened and also replaced fuel filter.

Mar 05, 2013 | 2000 Chevrolet Blazer

1 Answer

Km 90 r runs then shuts off


have you tried checking the fuel line

Jun 30, 2012 | Cars & Trucks

1 Answer

Engine rough after 15 to 45 min, cool off and uhookbat and repeat


check the egr valve, it may need to be replaced.

Feb 26, 2010 | 1996 Ford Bronco

2 Answers

Car shuts down after 20 minutes of driving


a likely problem is a fuel pump going down...as it gets warm, it heats up the wiring inside and they expand causing a loss of connection inside the pump...As it cools, it comes back together and works again...when it dies out turn the key off and listen closely for the pump to hum when you turn the key on...If it doesn't wait for it to cool and then when you try again listen and if you hear it and it starts, that's your problem...fuel pumps will go bad quickly if you don't keep your tank at least a quarter to half full as the gas is what keeps it cool so it don't get too hot and melt the shellac on the wiring which will eventually short out...

Feb 02, 2010 | 2006 Chevrolet Cobalt

1 Answer

1970 Chevy 350 in C30 truck dies when warm


You need to find oput what you loose when the truck shuts off, all you need is Air, Fuel , and spark to run one of the three are droppuig out when it stalls and will not run. Chech the carb for gas it sounds like you have a weak fuel pump.

Sep 24, 2009 | 1983 Chevrolet K1500

1 Answer

'99 chevy Silverado Z71,5.3 engine.....will not rev when hot.....


try replacing your EGR Valve, or your Oxygen Sensor

Feb 10, 2009 | 2001 Chevrolet S-10

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...