Question about 2009 GMC Sierra 2500HD

1 Answer

I have a2009 GMC 2500 HD with 195,000 miles. It seems like the transmission is slipping or it revs real high before it shifts into gear.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 26 Answers

Check both your fluid levels and the programming for the tranny, if it's electronic. 195K means you should probably look at a fluid swap and possibly any tranny filter

Posted on Dec 08, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Transmission slipping in 2nd gear


1 Ck A/T fluid level & quality
2 Scan/ck for code(s)
3 With scan tool connected,road test vehicle/Ck parameters....
....time for a pro !!

Apr 06, 2014 | GMC Sierra Cars & Trucks

1 Answer

My truck shifts real hard and now shakes when I stop


If you have been driving the vehicle even 10 miles or more
with a transmission that acts up,slips,bangs,etc,& have not
changed the fluid every 3 years since it was new,then yes, it
most likely has to be rebuilt,could have been prevented

Jun 23, 2013 | 2003 Lincoln Navigator

1 Answer

I have a 2003 GMC Envoy XL with 150,000+ miles and an automatic transmission. Starting this week, the engin began to rev very high as it transitioned from 1st to 2nd gear. it's very sluggish. Once I get it...


Sure sounds like a slipping transmission to me. When is the last time you changed the transmission fluid? Before you go dumping $2,600 for a new transmission, I'd do a transmission fluid change first. If you do change the fluid, use Dextron 6, it's GM's new transmission fluid, much better than the fluid you have now. Not to scare you, but my transmission went out at about 100k miles, so you're doing good if it hasn't been rebuilt yet.

Jan 21, 2011 | 2003 GMC Envoy Xl

1 Answer

My 2001 GMC Jimmy 4x4 Automatic with 84K miles. It winds when I put it in reverse and I think I only have 1st and 2nd gear. Additionally it revs high, like over 3000 rpm, delays and then eventually...


It winds up in 1st and then shifts right from 1st into 3rd. Then never shifts into 4th. Plus rev is gone. You broke the sun shell. The transmission will need to rebuilt or replaced.

Oct 30, 2010 | 2001 GMC Jimmy

1 Answer

THE REVERSE GEAR SEEMS TO BE SLIPPING


The transmission needs to be inspected internally,so yes a teardown is needed

Mar 07, 2010 | 1991 GMC Suburban

1 Answer

My 1994 Subaru Legacy Touring (Turbo) Wagon is not shifting properly when taking off. It does not shift until 3500 rpm at 20 mph. The initial shift should be around 2000 rpm. All other gears seem...


Hi,
The 1st>>2nd shift on the Subaru 4EAT automatic transmission can be more abrupt, but 3500 is too high.
Is there any delay when shifting from Park to Drive?
Does the Power light flash on startup? If it does, you can pull the codes by following these instructions.

This trans has 'bands' that can be adjusted. I'm not 100% sure they affect the 1st>2nd gear shift, but maybe they need adjusted.

Take a look @ ultimatesubaru.org/forum and http://bbs.legacycentral.org. 2 sites dedicated to Subarus.

Good luck,
Td


Feb 18, 2010 | 1994 Subaru Legacy Outdoor

3 Answers

My 2000 Toyota 4runner V6 125k miles automatic transmission started slipping on cold starts especially in the morning. After starting up, putting in drive and pressing the gas pedal first gear doesn't...


Low transmission fluid is usually the only reason power engages late or slippage occurs. But changing the transmission fluid again would not hurt. The stuff really shouldn't deteriorate like engine oil. Be sure to not run the vehicle many miles until the problem is completely resolved < 100 miles. One easy check would be to make sure the transmission lines are well connected and maintain pressure as well as fluid level. The good thing is that Toyota has a reputation of very good transmissions.

Oct 18, 2009 | 1990 Toyota 4Runner

2 Answers

2000 GMC Jimmy SLT 4wd, 65k miles, baby'd, driven


bad transmission, it will need rebuilding or replacement. sorry....hopefully this helps

Aug 16, 2009 | GMC Jimmy Cars & Trucks

5 Answers

2003 gmc sierra duramax 2500


Problem with Diesel Fuel System. Gmc 2002 duramax 2500 HD 4x4 will start 

Apr 19, 2009 | 2003 GMC Sierra

Not finding what you are looking for?
2009 GMC Sierra 2500HD Logo

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...