Question about 2000 Toyota ECHO

1 Answer

Fan for radeator is not working

Fan is ok i think problem is sensor or swish

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 253 Answers

Check the fuse first, then see if you can turn fan by hand to see if it's froze...probably need a new fan

Posted on Dec 07, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Over heat n due to non circulation of coolant into radeator


You may have a leaking engine head gasket or a clogged radiator. Do not drive this until the problem is repaired or you will do serious damage to the engine.

Nov 08, 2012 | Cars & Trucks

1 Answer

Over heating


hi Patricia the first then is to check if engine fan is workingwhen engine is at normal temp that's when the fan should come on
if the fan is not working check fuses temp sensors for the fan or fan clutch if not electric fan
if the fan is working then the engine head gasket is leaking and theta,s cause of your over heating

Sep 09, 2012 | 1994 Honda Passport

1 Answer

My 1989 corvette is overheatng


If thermostate has been replace check cooling fan to be sure its working if fan checks ok replace radeator

Jun 26, 2011 | 1989 Chevrolet Corvette

1 Answer

Lincon LS 2006 5600 kl coolent fan runs in winter when the temp gage is normal the radeator is not hot.The fan is very noisy, the engin has ben bled of air. The car has ben looked at by Lincon dealer said...


the fan has a low and high speed or some have 2 fans. It comes on low speed when the temp starts to climb or when you turn the a/c, defrost, or mix mode (it turns on when the a/c compressor kicks on. If the temp of coolant gets to about 230 F, then the high speed kicks in.

What is your doing? Very nosiy sounds like high speed. Could be a defective ECT - engine coolant temp sensor.

Dec 07, 2010 | 2006 Lincoln LS

1 Answer

No heat in cab.


You did not BLEED the radiator and it's over heating.

Take off radiator cap when engine is COLD

Start engine

Let it idle until it's HOT

As it heats up you will notice air bubbles coming out of the radiator filler neck.

Let car run until you don't see any more bubbles

Fill radiator coolant to keep it topped up to the hot mark.

Put radiator cap back on once you hear the fans kick on.

Done

You should now have tons of heat

Providing your water pump is working

Mar 31, 2010 | 2000 Chrysler 300M

2 Answers

Cooling fan not working


sensor may be bad. . any other symptoms that you think caused the cooling fan to fail?

May 27, 2009 | 1996 Nissan Maxima

2 Answers

Water not circulating,we put on radeator cap water pump ,intake gasket,flush heater core,engine radeator,reservoir


check to make sure the bottom radiator hose is not collapsing. sticking together. once it sucks together its like the thermostat being closed. the faster the engine turns the it sucks together. also make sure its not the clutch on the fan gone bad. if it has one. to ckeck ,look under hood at fan ,have someone to rev engine. make sure the fan turns as fast as the engine turns . if it doesn't it's a bad fan clutch. goe put a new one on.

Apr 21, 2009 | 1993 Chevrolet Lumina

1 Answer

Radeator fans not comming on when temp is hot


Check for possible broken wire to/from sensor.

Mar 05, 2009 | 1996 Plymouth Grand Voyager

Not finding what you are looking for?
2000 Toyota ECHO Logo

Related Topics:

48 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8557 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...