Question about Toyota Cars & Trucks

1 Answer

A shifting problem it loses power after shifting into drive and wont stay in over drive i have installed new throttle position censor but cant seen to get it set right if I move it up it changes the i

Played with the throttle position senor cant find a happy medium there. want to change the o2 sensor but cant get the nuts off as somebody has striped the corners off them and there in such a tight stop cant get anything on them

Posted by on

  • Brian W
    Brian W Dec 07, 2014

    1990 toyota 4runner 3.0L

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Toyota Master
  • 20,706 Answers

No car stated, no engine, and no year.wow. that is hard.
guessing, i see.
no year car stated
no engine option, which engine.?
what country.>? USA, Flordia.
or
Alert, Nunavut

why not get it serviced?
why not use a scan tool (1996+) and see if there are stored or live
DTC errors. (tops list)
A/T issues.?
a technician can tell you if the engine lacks power or the trans is failing.
The transmission will never use OD if the engine lacks power.
or the transmission or engine are stuck on limphome mode.

The TPS most be calibrated, ever seen the FSM book
the factory service manual> if set wrong idle speeds will wrong.

that which is stripped is bad, replace object stripped, the TB.?
the "Throttle body" or re-tap it or heli-coil it.

Test 1: done i 3 seconds flat
see FSM , see Trans, chapter.
see the stall tests. does that pass, parked, hot engine.?
that be first. if not , we work that first.
stall rpm too low, bad engine.
stall rpm too high , bad tranny.

i never once said to replace a part, that be last. (after diagnosis)
tell more get more.

Posted on Dec 06, 2014

Testimonial: "sorry its a 1990 Toyota 4runner 3.0L"

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 314 Answers

SOURCE: Loping and high idle

You are really onto it! Either the TPS or the cable from the peddle. Do check the cable first. Frankster016

Posted on Oct 26, 2008

  • 1 Answer

SOURCE: 95 GMC Jimmy 4.3l W vin rough idle

My problem was solved when I repaired my 4 wd activation dash switch. The switch was contacting on 2WD & 4HI at the same time. The front differential activation is vacuum activated possibly creating a tug of war that didn't actually engage it but drained off vacuum from the engine? A theory at best but stumbbled across it because I knew the switch wasn't working properly I repaired it and low and behold rough idle disappeared and all is good for 3 weeks running.

Posted on Dec 10, 2008

  • 3 Answers

SOURCE: 2005 Toyota Transmission downshifts rough

Sounds like you need the updated engine computer for harsh shifting. Look up under the glove box at the computer. Number should be 89661-02K21 if not, you need the update. It is an 8/80 warranty item.

Posted on Dec 31, 2008

  • 132 Answers

SOURCE: 99 gmc no power when passing or climbing

It could be the cat. it sounds like this could be your problem

Posted on Feb 07, 2009

  • 158 Answers

SOURCE: transmission wont shift

check the kickdown/throttle valve cable. It may be bound up and stuck in the maximum position giving you extremely late shifts.

There ISN"T any modulators or vac lines on any Chrysler automatics

Posted on Apr 03, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

94 ford ranger splash 4.0 will start but dies,i don't know if it is fuel related or what. iv'e changed about everything I know.


Try the ignition module or the ignition switch itself. I have seen them before where they will only get spark in the crank mode. Also check and make sure that your wires are on the correct side of the starter solenoid and not only getting power when you are cranking.

Oct 10, 2015 | Ford Cars & Trucks

1 Answer

Throttle positing senser on a 99ranger I changed it now the idle is way to high


The positioning of the new TPS IS OFFSET....It is possible to install it wrong by accident..I have seen this happen before..The pressure from the sensor plastic actuator has been installed and slightly twisted against the throttle lever inside which causes throttle to raise slightly....Wear safety glasses and disconnect battery..Remove sensor slowly and carefully while removing and watch the throttle lever inside to see if it moves in any direction...Carefully install it again making sure it doesn't twist the throttle lever inside where sensor mounts...The lever on the sensor should stay in its position...Carefully install sensor making sure it doesn't twist...Connect wiring and battery and start for a safety check.....It is possible to have a wrong sensor or faulty new sensor...Double check that it is the correct sensor...

Mar 01, 2015 | Cars & Trucks

1 Answer

1993 chevy suburbun 5.7 liter, edelbrock high output fuel injection has fuel and spark still wont start have changed distributor, coil,cap and rotor, plugs and wires are fairly new, timing is dead on,...


When you changed the distributor did it go in the right way sometimes people put it in 180 degrees around as it will drop right in then also take a look at the rotors position when you are at the proper firing position for 1 and check it otherwise it seems like a walk down as in going backwards on all your steps to see if its right

Jul 22, 2014 | 1993 Chevrolet Suburban

1 Answer

2010 dodge ram1500 automatic transmission stay in 4 gear


It is more than likely the Shift Positioning Censor. Run up to any auto parts store and have the codes read. Can only be purchased at the dealer and is actually easily installed. It is suggested that you replace the cylinder packs also, but in a 2005, I wouldn't. IF you need assistance on how to replace censor, let me know.

Feb 22, 2014 | Cars & Trucks

1 Answer

I have a 2002 f150 and the code P1121 comes up on the code reader. Will this have any effect on the Transmission? When I started driving the truck, I shifted it in Drive as per normal but this time it...


yes the problem is the throttle position sensor. you need a new one. it isn't shifting because the transmission isn't getting a signal from the tps. so it thinks your foot is all the way to the floor so it wont change into 3rd until it redlines. change the sensor before you damage the transmission. It is easy to change. its on the throttle body on the side of the throttle plate. it reads the angle of the plate. two screws and one wire connection

Mar 17, 2013 | Ford E-150 Cars & Trucks

2 Answers

2003 Altima 2.5L. Intermittently loses acceleration while driving down the road. I have seen this problem posted elsewhere, but have not seen any real suggestions. Description: There is a slight change...


Your crankshaft and camshaft position sensor are bad. GEt the new one with aluminum shield (not bad plastic design). Autozone has it for $30 per piece. go to nissanclub.com to findout how to install it.

Jun 24, 2010 | 2003 Nissan Altima

1 Answer

I have a 2000 GMC sierra 2500 truck. The guy I bought it from had a new transmition put in it. After driving a while I noticed that the tranny wouldn't shift into low gears 1st & 2nd on comand. and...


-----check possible tps [throttle position sensor ]circuit for damage or faulty sensor----if good check the fuses and trans harness for shorts damage or disconnection,check o2 sensors wiring possible ground to exhaust ,or internal leak 2nd gear apply circuit[servo assembly or 1-2 accumulator] or poor pump pressure

Feb 13, 2010 | 2000 GMC Sierra

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

44 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

77202 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8755 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...