Question about 2003 Dodge Stratus

2 Answers

My car keeps randomly going into limp mode

I've replaced the coil three times,the grounding strap and clip behind the head, the cam sensor twice,boots, plugs,map sensor, IAC, pcv valve and air filter. Keeps going into limp mode every so often, runs great for about 20 min then won't go over 30mph without flooring it. Has happened three times so far with about a month in between episodes, last two times the day after filling up the gas tank,... previous codes being misfire on cylinder five even tho its only four cylinders, evap code, and random misfire. This time however I'm not throwing any codes at all????

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 71 Answers

If not the 02 sensor, check the fuel filter and fuel pump, another (slight) possibility would be a partially clogged catalytic converter.

Posted on Dec 04, 2014

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 373 Answers

O2 sensors will do this and many times will not leave a trouble code.

Posted on Dec 04, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Replaced the head and Im not getting spark, what could it be?


Check all your grounds very carefully. Newer cars are quite sensitive about grounding and one missing ground can throw the whole works off.

Sep 07, 2015 | 2007 Chrysler PT Cruiser Base

2 Answers

Peugeot 307 code p1386 sayingP1386 Variable Cam timing Overadvanced (Bank #2)


I seem to think your cat is going for the running problem . the way that I myself ck this is to take the O2 sensor out before the cat and see if your car runs better this is just to ck thr running problem do not leave it out , it will be a little loud but at least you will find your problem , if your cat is clooging up means it is melted inside and will not let the exaust gas out through it and so it backs up like a clogged line , try it and get back

Nov 13, 2014 | 2005 Peugeot 307 1.4

1 Answer

My 1992 eb2 ford fairmont 5 litre goes to limp mode what are possible causes


Limp in mode has to deal with engine sensors and electrical power and grounds from the computer IF the basic engine is good such as compression, fuel pressure, charging system.

May 16, 2014 | 1983 Ford Fairmont

2 Answers

When I drive my 05 aveo uphill my engine light flashes and I lose power???


have the OBD codes read at a garage this will tell you what the problem is could be simple like a sensor or more serious like head gasket good luck

Apr 29, 2014 | 2005 Chevrolet Aveo

1 Answer

I have a 2002 Dodge Grand Caravan Sport it is in limp mode. I have replaced the TCM, Speed sensors (3 times), and checked the ground strap. Once they replaced the last speed sensor seemed worse actually....


you don`t say if you ever had codes pulled from the tcm or if you installed a new tcm and not a used one.if a used one you may have a bad one.also you may have to have the tcm programed to your vehicle.if in limp in mode there possibly a problem internal to the transmission.you need to have it checked out a tranny shop that you trust or is recomended by several people.

Nov 04, 2013 | Dodge Caravan Cars & Trucks

2 Answers

1994 CONCORD NO POWER TO FUEL PUMP, NOT FIRING AND DOES TURNOVER, REPLACED CRANK SENSOR AND CAM SENSOR, TRIED DIFFERENT RELAY FOR FUEL PUMP-STILL WON'T START?


NO POWER TO FUEL PUMP......CHECK ALL IN LINE WIRING
NOT FIRING... START WITH COIL PACK, DIST CAP ETC...PLUGS/WIRES??????
"HOT WIRE" (DIRECT W/ FUSED JUMPER) TO FUEL .PUMP....NO - GO,,,BAD PUMP

Oct 09, 2011 | 1994 Chrysler Concorde

1 Answer

I've got a 2003 jetta 2.0 made in april of 2002 throwing a po343, I replaced the cam sensor, timing belt, it ran great for about 10 miles then the ignition pack went out(miss-fire cyl 1). I replaced...


If your car is off a single tooth on the Timing Belt, you will have continued problems... you need to verify the timing is on. If the timing is off, reset it and then proceed if the problem returns

I did have a problem with a defective Cam Shaft Sensor and replacing it with another Defective Sensor....

May 26, 2011 | Volkswagen Jetta Cars & Trucks

2 Answers

P0300 (random misfire) code


nissan xterra codigo p0300 random misfire cual es el problema que devo de hacer para areglarlo

Feb 09, 2010 | 2001 Nissan Xterra

1 Answer

98 Catera goes into "Limp Mode" after warm up.


have you check you ignition coil packs.

Dec 25, 2008 | 1998 Cadillac Catera

Not finding what you are looking for?
2003 Dodge Stratus Logo

119 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...