Question about 1998 Mercury Villager

1 Answer

98 mercury villager...rough idle runs fine on acceleration....wanted to try cleaning or replacing maf sensor..how do i do that

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Night Owl:

    An expert who has answered 10 or more questions between 12 midnight and 6am on the same day.

  • Expert
  • 113 Answers

Just Google your question on line for Maf question and advance timing or adjust idle.

Posted on Dec 03, 2014

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 15 Answers

SOURCE: 98 chev 3.1L runs rough and dies at idle

Check the DIS module or injectors. Check to make sure you have a spark on each cylinder. One cylinder could be misfiring

Posted on Mar 18, 2010

  • 59 Answers

SOURCE: 2002 impala 3.8L 180,000kms. Having

it is possibly the throttle position sensor(tps) malfunctioning. basically the computer or "brain" of the car thinks the throttle is in a different position than it really is and automatically makes adjustments to fuel, air ect.... based on these false readings from the sensor thus causing the engine to react a little different when you expect to have power.

Posted on May 14, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1998 Mercury Villiager stalls out when put into gear also at red lights unless it has been running for over 15 minutes?


I suspect your fast idle control is not working. Could be solenoid. Mounted on throttle body.


clean the throttle body passages and clean the MAF sensor with carb cleaner. disconnect battery for 2 hours to clear memory in computer, drive for 10 miles to relearn, may run rough for 10 miles.

also go here for Villager help

http://groups.yahoo.com/group/villagerquest/

Dec 27, 2009 | 1998 Mercury Villager

2 Answers

Under heavy acceleration the car stumbles, runs rough


I am having the same problem with my mustang, have replaced tps, egr valve and sensor, clean maf, new plugs and wires, new fuel filter, cleaned throtle body and still having same problems....Please help!!!!!

May 29, 2009 | 2002 Ford Mustang

1 Answer

99 MERCURY VILLAGER


claen the MAF sensor in air intake tube with carb cleaner and a toothbrush. Gently brush & spray the 2 wires. Then disconnect the battery for 2 hours and then drive for 10 miles while colputer relearns engine controls and the clean MAF sensor. May run rough for 10 miles.

go here too
http://autos.groups.yahoo.com/group/villagerquest/

May 28, 2009 | 1997 Mercury Villager

Not finding what you are looking for?
1998 Mercury Villager Logo

101 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

fordexpert

Level 3 Expert

5520 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...