Question about 2007 Opel Corsa Utility

1 Answer

My back indicator is not working on the right any suggestions of fixing it

I have checked the globes and swap the whole unit from the left and is still working so i suspect it is the wire giong to the unit where the globes fit into

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 32 Answers

A think the switch in the stering stil mooving that wy the lite is open or chech the ignition switch , mabe you have to much key on you set it to heavy for the ignition end when you close your ignition the light still open

Posted on Dec 03, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Left side indicator not working front & rear


hi

it could be a bad globe, check both front and back

25729317-kk45hi5thrg2ekkphxdk3mx1-5-0.jpg

the indicator stalk might be malfunctioning



make sure the wires are all connected

cheers

Jun 04, 2015 | 2007 Opel Corsa Utility

1 Answer

The whole right side indicator signals do not work, front, on mirror, and rear, and do not work in hazzard mode either... is it the relay or it it a globe?


If one side works the flasher unit is ok it could be bulbs, a bad connection or a fault with the indicator switch

Apr 06, 2014 | 2003 Ford Escape

1 Answer

Right hand turm signal does not work ~


Sounds like the flasher relay in the fusebox under the hood

Apr 05, 2014 | Ford Escape Cars & Trucks

2 Answers

Beetle left turn indicator runs rapidly


the indicator usually ony flashes fast when one of the indicators on the same side is blown, check the other indicators, should only be a blown globe, defroster should be a fuse =)

Jul 26, 2012 | 2002 Volkswagen Beetle Turbo S

1 Answer

I have a 2001 Pontiac Firebird. When i start my car, my left turn signal light comes on but the right front turn signal light remains off. If i turn my lights on, the right turn signal light then comes...


Perhaps a dicky connection somewhere. Perhaps corrosion, even moisture in the connection plugs. Inspect all connections to your indicator lights. Also check for worn or damaged wires. Also Have a look inside the lenses of the lights to see if the the globes are corroded or have water ingress etc and causing shorts to other wiring within the lighting circuits.

You may also consider turn indicator lever to on to indicate truniong right, make sure the engine off. Have someone watch right indicator and literally grab the plugs/leads to the indicator globe and give them a shake to see if the fault goes away. If it doe stop intermitantly then it will help point you in the correct area.

Jun 10, 2011 | Pontiac Firebird Cars & Trucks

1 Answer

The signal flashers are goin extremely fast on my 2004 alero


usaully when flasher goes extremely fast this means you have a blown light bulb on one or more of your indicaters , if it is only when you indicate left then the globe is on left of vehicle , and on the right same rules apply , both sides then more then one globe is blown ...

turn on and step out your car and check globes .
hope this helps..

Oct 09, 2010 | 2004 Oldsmobile Alero

1 Answer

Passenger headlight is out./electrical box damaged


you are eing sold a bill of goods. go to our site and ask this question and read our files, we can help you.
First check your headlamp relay in the power distribution box under the hood uin front of the battery. Switch the left relay with the right relay and see if the problem switches to the other headlamp. report back on our site

http://autos.groups.yahoo.com/group/villagerquest/

Jun 22, 2009 | 2004 Nissan Maxima

Not finding what you are looking for?
2007 Opel Corsa Utility Logo

92 people viewed this question

Ask a Question

Usually answered in minutes!

Top Opel Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Brad Brown

Level 3 Expert

15478 Answers

george parkes

Level 3 Expert

975 Answers

Are you an Opel Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...