Question about Cars & Trucks

Open Question

2004 Iveco daily cuts out when warm but restarts ok

Replaced the low pressure fuel pump. Replaced the camshaft sensor. Repaired wires to the camshaft sensor.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 22 Answers

SOURCE: hesitates & starts hard after it is warmed up 1992 5.7 gmc truck

You might try checking the timming if it is out depending on the milage you might need to replace the timing chain and guides good luck

Posted on Dec 11, 2008

Ad
  • 14 Answers

SOURCE: 1992 gmc chevy 350 wont idle when warm

This could be a number of things but i think that your problem sounds like a vacuum leak or an EGR problem. Try listening for leaks and try un-plugging the EGR solenoid valve one time.

Posted on Apr 17, 2009

  • 2 Answers

SOURCE: SL2 Won't start; previous codes=PO

I HAVE A 98 SATURN, WON'T EVEN TRY TO START EVERY ONCE IN A WHILE. TURNS OUT TO BE THE CRANKSHAFT POSITION SENSOR

Posted on Jul 22, 2009

  • 74 Answers

SOURCE: No/Low Fuel Pressure after replacing in-tank fuel pump & filter

Need to have the fuel pressure checked at fuel rail to know for sure if there is a fuel pressure problem for sure. There may be a in line filter as well, you can also do a check of the pressure regulator by pulling the vacuum line off of it then try starting the car with it off and see if it runs, if it does the regulator is bad, but IF it doesnt run doesnt necessarly mean it is good, a lot of fuel filters have a bypass wich allows the gas to bypass the filter when it is full bad thing is the debris can then plug the injectors causing problems, or there could be a loss of signal to tell the injectors to give fuel to the cylinders from an electrical or a sensor failure. So it is best to test the pressure to know for sure if it is in the fuel line or the injectors if it is truly being starved of gas. hope this helps

Posted on Apr 13, 2010

  • 1 Answer

SOURCE: My 03 jeep grand cherokee crd cuts out randomely

hi mate, got the same problem, comes up with a ECU 15 code so they say, its a speed sensor problem !!!!! but i phoned jeep they say our model dont have speed sensors and want £660 for a valve body !!!! way too dear if you ask me, jeep are ripping folk off, at best take for a diagnostic at jeep, get the codes and source the the problem yourself, but its a speed sensor fault, i'm having a garage look to see if i have the sensors, input and output on my box, if not its the valve body

Posted on Oct 29, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

What is wrong? cheapest fix


as these numbers are dodge fault codes ill assume that's what you have , both of these codes refer to a low to no oil pressure condition , this has several causes an can be as simple as low oil level to a bad sensor (behind alternator) to at worst a bad oil pump

since this is a oil pressure loss fault its stored as a major fault an will require a reset of ecm before it will allow a engine restart (after resolving problem) it does this to prevent engine failure for no lubrication

Dec 01, 2015 | Cars & Trucks

1 Answer

Freelander 04 does not start... but will crank.... pressure is at 53 ... i changes the camshaft sensor and crankshaft sens


When you turn the ignition on can you hear the fuel pump run for a second or so? If not could be faulty fuel pump.

Apr 03, 2014 | 2004 Land Rover FreeLander

1 Answer

Temp sensor


I'm not a 100% but it sounds like your camshaft position sensor went bad then caused the other codes to come up because the camshaft position sensor tells the computer how much gas it needs. So it started a chain reaction with the fuel level sensor, fuel temperature sensor, and knock sensor codes. The Fuel temp. sensor helps the engine to know how much fuel to inject as well depending on the temp. of the fuel. The fuel pressure sensor senses the amount of fuel in the fuel rail by reading the internal pressure of the rail, so that's what leads me to believe that it's your camshaft position sensor. Particularly if that was the first code that came up. Hope this helps you.

Aug 27, 2013 | Nissan Xterra Cars & Trucks

1 Answer

2002 taurus 3.0L OHV stalls when hot have replaced IAC,camshaft position sensor,fuel pump and there are no codes on engine stall occurs most often when slowing and turning


If you have to wait to restart its usually a faulty coil or ignition module.
Someone would need to troubleshoot the ignition system when the engine fails to start to proceed. Could be a faulty relay too.

Sep 13, 2012 | 2002 Ford Taurus

1 Answer

1997 chevy cavalire 2.2 , 5speed stalls and dies at stop sgns and red lights, but will usually start right back up if I turn the off before trying it again.


fit a fuel pressure gauge and check the pressure, if low check fuel filter and fuel regulator if they are ok replace the pump

Apr 03, 2017 | Cars & Trucks

1 Answer

1998 park avenue cuts off sometimes i let it for a few minutes cut right back on i think its the fuel pump


CHECK FUEL PRESSURE SOON AS ENGINE STALL OUT.IF FUEL PRESSURE SHOULD BE 41 - 47 PSI. IF NOT OR PRESSURE ZERO OR LOWER FUEL PUMP FAULTY.FIRST REPLACE FUEL PUMP RELAY AND CHANGE FUEL FILTER SEE IF ENGINE STILL STALL OUT.IF FUEL PRESSURE OKAY HAVE CAR CODE SCAN FOR FAULTY CRANKSHAFT SENSOR OR FAULTY CAMSHAFT SENSOR.

Mar 30, 2011 | 1998 Buick Park Avenue

1 Answer

1989 ford aerostar will not start when engine is warm.


AM temp 55 car started but stalled out after starting. Attempted to restart and did not hear fuel pump. Tried again and then fuel pump kicked in. Checking fuel pump inertial switch and fuel pump electrical supply.

Apr 19, 2009 | 1989 Ford Aerostar Cargo

3 Answers

Gdi 1800 cedia wagon-odometer 80,000km exact, starting, no power


Hi it sounds like your high pressure pump needs replacing. the pump can be repaired but you will have to find someone who knows about it, i fix a lot of them before. there is a spring that pushes out the piston in the pump so it can compress the fuel that spring losses its ability to extract the piston back out. i have pictures of one if anyone wants to see

Jan 03, 2009 | 2002 Mitsubishi Lancer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...