Question about 2010 BMW 528i

1 Answer

NO POWER AT 30B

CHECKED FUSES CHECKED POWER AT BST TERMINAL CHARGED BATTERY

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 37 Answers
Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1997 Toyota t100 will not start,will not even make a sound I have replaced starter, battery is fully charged, have checked all fuses


Be sure to check that all connections are clean and free of build / contamination. Terminal to post, leads to terminal and if this is beyond that, check the "-" lead contact / connect at the opposite end - should be the frame or engine block. The majority of the time it will be at the battery, post to connect. You can find a very handy post / terminal wire brush tool at the local parts store for a few bucks. I dont normally suggest this but, Coka-Cola does actually work if you disconnect the terminals from the battery and pour over each of the "contacting points". Hope this helps!

Aug 11, 2013 | 1997 Toyota T100

1 Answer

As reported before, there is no power in interior,vehicle will not start.,battery is fully charged. there is 12 volts at battery , and at starter relays bottom terminai,no voltage at top terminal....


check for corrosion on the large positive wire that leads to the starter. allthough you have 12 volts, but corrosion cant handle amperage. or it may be possible that you just need a new starter, you can remove the starter, and apply a seperate power source like a jump pack or seperate battery to verify that the starter is ok

Jun 13, 2011 | 1997 Ford Explorer AWD

1 Answer

My daughters 2006 chevy cobal wont crank the battery is fully charged . i tested the batteryit has 12.75 volts at the battery and at the jump start terminal under the hood i also connected a fully charged...


Sounds like the starter itself has gone bad. If you can access it easily you can try to jump across the solenoid. Use a jumper wire from the hot lead to the exciter lead. If your not comfortable doing that DONT. Im pretty certain your starter is bad.

Feb 20, 2011 | Chevrolet Cobalt Cars & Trucks

1 Answer

Battery is new, has been charged and checked several times, it has a intermentant draw. i pull #2 maxi fuse and draw goes away. ive pulled all small fuses with no result


Check your ground (the negative cable on the battery). See if you have continuity between engine and battery negative terminal (-).

Dec 11, 2010 | 2004 Saab 9-3

2 Answers

My car will not start. There is no clicking noise. the battery has been charged. I even tried jumping it there's nothing. A friend of mine checked the fuses and he says they're all ok. The engine is a...


Hi
Will the car turn over? If it does I don't know. If it doesn't check the connections from battery to the starter. If starter not clicking then it either isn't getting power, the solenoid is bad or the entire starter is shot. Also check the battery ground cable for corrosion.

Jul 10, 2010 | 2002 Buick Century

1 Answer

2000 Ford explorer, just wont turn on, there is no power, but the battery is charged


battery terminals?? cable disconnected on the positive terminal,one of the big fuses near the battery has a dirty connection??

Apr 06, 2010 | 2000 Ford Explorer

3 Answers

My 93 altima started yesterday just fine.Willnot even turn over today,there is power ,not even clicking. Checked fuses ,battery,moved relays around not sure how to check them


there is whats called a fuseable link on the + side of the battery taht may have burnt out over time!
bst get a auto electrician or a mechanic to come over & test it for you
Good luck Cheers Rob.

Jul 20, 2009 | 1993 Nissan Altima

1 Answer

Car won't start,


Does you car start ok with boost? If so then Your battery maybe fine but it may be the battery terminal issue. Check that you side terminals have not eroded. If there is powder stuff on the terminal then that terminal has eroded and is not getting good connection to the battery. Replace you battery.

Jun 23, 2009 | 2000 Oldsmobile Intrigue

1 Answer

All electrical went out


Use a wire brush to clean the battery terminals and the inside of the battery cables where they connect to the battery terminals. If that doesn't fix it, I suspect the problem is the negative connection from your battery to the car body/engine block. Follow the thick cable from the negative terminal of the battery to where it connects to engine block. Make sure you have a good clean metal to metal contact. Use an ohm meter to check to make sure this cable and connection is good. If the connection to the engine block is bad the hood light might still be able to work if it has a separate connection to the negative battery terminal.

May 21, 2009 | 1989 Chevrolet Beretta

Not finding what you are looking for?
2010 BMW 528i Logo

Related Topics:

31 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Anthony Jones
Anthony Jones

Level 2 Expert

128 Answers

Doberman

Level 2 Expert

254 Answers

dhnguyen

Level 2 Expert

281 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...