Question about 1995 Subaru Legacy

2 Answers

Car runs smooth, until I have to stop at red light or stop sign, then it runs rough. When I put it it neutral, it runs smooth. Could that be the EGR valve sticking? Any help would be appreciated, than

Car runs smooth, until I have to stop at red light or stop sign, then it runs rough. When I put it it neutral, it runs smooth. Could that be the EGR valve sticking? Any help would be appreciated, thank you.

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Subaru Expert
  • 180 Answers

I would check the vacuum lines first. I've seen many that no longer fully seal at the age of your car. The easy way to find the leak is to put vaseline on the ends of each one until the idle smooths out.

Posted on Nov 27, 2014

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

Depends on what you mean by rough. Could be a cylinder misfire.They sometimes are not noticed as engine speed increases during driving or under light load as when idling in neutral but at idle under load as when stopped at a light in drive became noticable.
Could also be running rich. The causes of either are too numurous to list.Consult a good mechanic who can actually see and hear the problem to put you on the right track.

Posted on Nov 26, 2014

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 59 Answers

SOURCE: 1992 Subaru Loyale - Rough idol when in gear

mine did the same thing but was only a VACUUM line near the throttle body (like the carb) on top on the engine near the front of the car one of those line was popped loose u can just reinsert it but i recommend a hose clamp or even tightly use wire ties (nylon type) on all those vac hoses.

Posted on Nov 21, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

3.9 engine is idling rough but smooth when accelerating or driving. If I put in neutral it's still rough. Have 250000 thinking maybe injectors? Or where do I start?


Take an have diagnostics run . Could be a vacuum leak , mass air flow sensor problem , If fuel injector's where the problem it wouldn't smooth out while accelerating > Have fuel trims check , O2sensors . EGR valve stuck open a little . If the check engine light was on an had a random misfire code P0300 could be fuel injector. or a specific cylinder misfire.

Oct 02, 2016 | Cars & Trucks

1 Answer

Code says system running too lean Bank1 and at stoplights I have to put car in neutral or it will stall


Lean Bank1 can be attributed to a faulty oxygen sensor or by unmetered air entering the system. A comon problem with the protege is cracks in the plastic air intake hose after the MAF which sucks air in that is not registed by the car and thus make it run lean and idle poorly
.
Another comon problem causing rough idle is the EGR valve being stuck because of carbon deposits, this will usually throw an EGR related check engine light but not always.

Feb 11, 2013 | 2000 Mazda Protege

1 Answer

P0401 & P0171 Mazda Protege '02


It sounds like you may have an EGR valve sticking open. That can also cause the p0171 code, which means fuel system lean, and the p0401 which is insufficient EGR flow, kinda sounds like the valve may just be stuck open and not moving at all. replace the EGR valve.

Mar 05, 2012 | 2002 Mazda Protege

1 Answer

1993 LeSabre- just started running rough mostly when put in reverse or drive. Not so much in park or neutral but a little, maybe cause of higher idle speed in park. Also runs a bit rough at slow speeds....


Sounds like the Torque Converter Lock-up Solenoid is failing. It will cause the car to run rough at slow speeds, and sometimes stall while idling in gear (at a stop sign for example)
To test this, locate the 2 or 3 wire connector on the left side of the transmission (looking at it from the left side of the car, it can be hard to find some times) Disconnect it. If the car runs and drives ok with it unplugged, the Lock Up Solenoid has gone bad. The solenoid itself is inside the valve body, inside the transmission (above the transmission pan)

Aug 24, 2011 | 1993 Buick LeSabre

1 Answer

When sitting there or after driving and coming 2 a red light or stop sign it acts like its going 2 stall or die i took it 2 autozone put it on the check engine reader and they said it was the EGR value


EGR valve controls the amount of gas to oxygen ratio. this is a must to keep the car running smooth. to much or to little of either will make it run rough or sputter. you need to take it to a mechanic and have it replaced. it is an inexpensive part and labor shouldnt be to much either.

Dec 16, 2010 | 1999 Mercury Cougar

1 Answer

Go out in AM, car is cold, starts and runs fine. Drive short distance, stop and restart, runs fine, idles fine. Drive about 8 miles at 50-55 mph, pull up at a red light, when speed gets down to ~25-30...


The EGR valve is unserviceable which causes a bad or insufficient fuel control for em-missions......Hope this helps you out........EGR valves are not very expensive.

Oct 12, 2010 | 1985 AMC American Motors Eagle

2 Answers

Loss of power


Could be bad spark plugs or wires

Jul 18, 2009 | 1994 Toyota Camry

1 Answer

Car cuts off at red light or stop sign. {1995 Toyota Camry)


most likely a bad egr valve and vsv valve. stuck open position.

May 17, 2009 | 1995 Toyota Camry

1 Answer

1988 mercury topz


Have you tried cleaning the Throttle Positioning sensor?
Thanks,
Lee

Dec 01, 2008 | 1988 Mercury Topaz 2 Door

Not finding what you are looking for?
1995 Subaru Legacy Logo

273 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7689 Answers

Are you a Subaru Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...