Question about Cars & Trucks

2 Answers

98 chevy blazer no passenger high beam or running lights all bulbs and fuses are good ????????

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Cars & Trucks Master
  • 1,013 Answers

Check earth and wiring to that bulb if you have one or can borrow one try a multi meter on the conectors or join a bulb to a couple of pices of wire and poke the ends of the wire into the harness ends if no meter avalible to see if there is any power to harness bulb should light up also make sure the bulb that is in the lens is seated properly as this could be causing a faulty earth

Posted on Nov 25, 2014

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 27 Answers

Sounds like a bad ground. Check the socket with a meter to verify 12 volts at the socket. Use the continuity setting to check ground. Or wiggle things about.

Posted on Nov 25, 2014

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 290 Answers

SOURCE: no low beams bulbs are ok fuses look good

There may be a relay that operates the low beam lights, check the owners manual to see if there is a relay, you should be able to hear it go "click" if there is one.

Posted on Dec 26, 2009

Molson02536
  • 3854 Answers

SOURCE: 2004 chevy trailblazer low beams not working fuses good bulbs new

Check the relay or your head light switch has gone bad. 

Posted on Apr 06, 2009

gladys_neal
  • 334 Answers

SOURCE: fog lights and high beams work, but not the low beams

most likely the hi lo switch

Posted on Dec 31, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

One low beam head lights will not work, high beam works though


check for a damaged wire for the low beam. Also wouldn't hurt to check the ground wire as the high beam will try and ground through the low beam but not visa verse

Dec 29, 2013 | 1997 Chevrolet Blazer

2 Answers

Dashboard & Highbeams Don't Work


DRIVERS SIDE BULB IS PROBABLY BAD, SWITCH THE LEFT TO THE RIGHT AND SEE IF YOU HAVE THE SAME PROBLEM. IF YOU DO... IT A WIRING PROBLEM. GOOD LUCK

Nov 03, 2012 | Chevrolet Blazer Cars & Trucks

1 Answer

2007 chevy trail blazer low beam lights wont work.


maybe a fuse the fuse box is under the drivers side passenger seat . sometimes ive seem them get something spilled on them and i had to wiggle the fuses to clear the corrosion

Mar 16, 2010 | 2007 Chevrolet TrailBlazer SS

1 Answer

Passenger headlights only do not operate.


check the bulbs first and also the fuses theres a fuse for each side and for low and high beams, start there, good luck.

Feb 19, 2010 | 2002 Mitsubishi Eclipse Spyder

1 Answer

98 caviler low beam


98 caviler high beam left side dosent work canged bulb checked fuse and all good

Feb 06, 2010 | 1998 Chevrolet Cavalier

1 Answer

Automatic headlamps work during the day, but at night only highbeams, even using manual switch.


Your blazer has a total of six bulbs (eight if you have fog lights) . Two are low beam, two are high beam and two are daytime running lights. It sounds to me like your high/low beam selector switch is faulty. This switch, as you might know also controlls many other functions, so if you are not having problems with other things like cruise, wipers or blinkers, I'd make sure first that your fuses are all good and the bulbs are good also before tearing into anything.

Dec 13, 2009 | 2002 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

23 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...