Question about 1999 Pontiac Sunfire

1 Answer

I have a 99 Pontiac sunfire with a 2.2L. it runs fine but when I try to get up to speed it starts running rough and I can't keep it at 45 mph it starts to idle bad at 2500 rpms the Car had new plugs and wires. I just replaced the Crank positioning sensor thinking that was the problem but it still is doing the same thing any ideas what it could be?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Pontiac Master
  • 615 Answers

It could be a plugged cataletic converter most muffler can test the converter and tell you if they are blocked if this was helpful please leave good feed back

Posted on Nov 25, 2014

  • Tyler Nov 26, 2014

    It was the converter I pulled out the o2 Sensor befor the cat and it ran great took out the cat and it runs better than ever

×

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: 1994 Cougar XR7 Engine idling rough and running rough at low and

Not saying this for sure, but I had the same problem, and i have a 1994 xr7 V6 3.8 L , and all u need to do is set the idle down manually because your computer could have seen that the injector was stuck open, and tried to turn up idle to keep up with the amount of fuel being pumped, worth a shot :P

Posted on Feb 21, 2009

ourhowse
  • 2007 Answers

SOURCE: car idles rough and stalls

Have you ever changed the fuel filter? If it's not that, and it's not a vacuum leak, it is probably your idle air control valve.

Posted on May 08, 2009

jturcotte
  • 8195 Answers

SOURCE: 1995 ford probe gt 2.5l V6, was running at 45 mph,

OK, and now it looks like coachjoehutc is thinking the same as me. When I look up your car, it takes me to the Mazda Millenia engine--does that sound right? It only shows 2 cam sprockets, but maybe there's a gear in the head to turn the other cam? Anyway, I'm pasting a picture of the marks. There's a little tang coming off the head that marks the timing. Now unfortunately it appears the timing covers are the one-piece type that stretch all the way down (I was hoping there would be a section on the top you could remove to see the gears). I hate for you to have to take the whole front off and find out I'm wrong, so maybe you can just remove the upper cover screws and, if the cover is plastic, it may let you bend it out far enough to see those marks on the gears (????). If so, then rotate the engine to TDC for #1 (there is an ignition timing tab to use for that around the one o'clock position). Look for the marks on the gears--if I'm right, they will only be off the tangs by a tooth (any more and the engine wouldn't run). If you don't see the dots on the gears, you're on the exhaust stroke and need to turn the engine another 360. Is this all making sense? Let me know if you have questions.
If you want to see the instructions to take off the whole covers, I can send them, or maybe you can access them at http://www.autozone.com/autozone/repairinfo/repairguide/repairGuideContent.jsp?pageId=0900c152802610a5



6d96be8.jpg

Posted on Sep 08, 2010

  • 8 Answers

SOURCE: Car was running well then just refused to

its possible there are multiple coil packs usually one for each bank or one for every two cylinders. Or check for a ignition control module

Posted on Oct 08, 2010

SOURCE: car start runs rough, after replace crank sensor car run rough, now don't run.

go through wireing near sensor and plug attached to sensor and clean it all first,my mate had same prob cleanded it all and now works,not saying will be solution but it worked for his.

Posted on Nov 15, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rough engine idle


you don`t say if you have checked anything so start with the plugs for condition and age as well as plug gap.then the ignition wires they may need changing.the engine compression can affect idle and give the impression its alright at higher speeds.fuel injectors if they are dirty can cause rough idle and run okay at higher speeds.just somethings to check

Jan 11, 2012 | 2004 Pontiac Sunfire

2 Answers

Rough idle surging. have replaced plugs,fuel filter,injector o rings top and bottom and have run one bottle of injector cleaner. suspect IACV, fuel pump or maybe fuel regulator. please advise. thanks...


the best thing to do is to have a scan preformed on the engine, sounds like a mass air flow, but these parts are to costly to guess at. if the car will run ok at highway speeds of 60 mph or faster your fuel pump is ok.

Apr 19, 2011 | 2005 Pontiac Sunfire

1 Answer

I replaced the timing chain in a 2005 potiac sunfire with a 2.2 and now it run rough but runs fin going down the road but idling it run rough and sometimes will die


if the car ran fine befor you changed the timing chain you may have the cam timing off by one tooth retarted. Being the PCM controls the timing advance . The engine smooths out at higher speeds .Start back tracking and looking at the simple stuff . but you may have to pull the timing housing again to check the timing marks on the cam and the crank

Mar 06, 2011 | 2002 Pontiac Sunfire

1 Answer

I have a 99 ponti sunfire 187k miles 5 speed


Sounds like either an evap system leak, maybe intake gasket. While it is running spray water around the intake, if it starts to cut out..you have a leak. If that doesnt do it, I would check the mass air flow sensor, and throttle postion sensor. Hope this helps.

Jul 12, 2010 | 1999 Pontiac Sunfire

1 Answer

2000 Sunfire 2.4 GT bucks when maintaining speed


Sounds like the EGR valve is giving you some trouble. If it is happening during steady cruises, That is where I would start. Do you have a check engine light on?

Mar 11, 2009 | 2001 Pontiac Sunfire

1 Answer

2000 Pontiac Sunfire that Shakes Violently around 45-50 MPH


Check the ball joints and cv axles this could cause the car to shake violently and most tire stores will check them for you for free.

Dec 20, 2008 | 2000 Pontiac Sunfire

1 Answer

97 pontiac sunfire idles rough and wont go past 20


PLUG EVERYTHING BACK IN.....
REPLACE THE IAT (INTAKE AIR TEMP SENSOR) AND THE COOLANT SENSOR THEY BOTH WORK AS PART OF THE FUEL CONTROLL SYSTEM
LET ME KNOW HOW IT GOES
RATE MY SOLUTION

Dec 11, 2008 | 1997 Pontiac Sunfire

1 Answer

Blazer runs rough when running at 45 to 55 mph


the problem was low transmission fluid. added half a quart and the problem went away.

Sep 28, 2008 | 2000 Chevrolet Blazer

2 Answers

Transmission problem


car out of cruise control flutters or runs rough from 45 mph to 55 mph and once over 55 mph runs smooth. I notice from 45 to 55 the rpm guage moves with flutter or rough running engine. when i put in cruise control it smooths out.

Sep 12, 2008 | 2000 Chevrolet Blazer

Not finding what you are looking for?
1999 Pontiac Sunfire Logo

63 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8195 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...