Question about Cars & Trucks

1 Answer

I have a 1996 Chevy Beretta that started making strange noises, kinda a pulley or possibly the blower motor going bad. I drove 2 miles turned it off, and wouldn't start less than 5 min later. Like battery was dead. Assumed it was alternator. Somehow while inside calling about a new one it somehow charged itself enough to almost get me home. We replaced alternator and charged battery started. Let it run maybe ten min and it died soon as battery lost its charge. Someone said we might have bought a bad alternator. Replaced it 2nd time and switched battery but still doesn't stay charged. I'm lost!! There are 3 relays/fuses under the hood, Could one of those cause the same problem? And how do you check them?

Posted by on

Ad

1 Answer

I suggest you stop guessing & replacing parts,
without the knowledge & ability to find a problem
thru proper testing & have a professional find the issue

Posted on Nov 23, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
alicantecoli
  • 22219 Answers

SOURCE: I have an 87 Alfa Spyder Veloce that just quit

try checking the feed wire to the altenator ,did you fit a recon unit or one from thje scrapyard??

Posted on Sep 09, 2009

alicantecoli
  • 22219 Answers

SOURCE: Drove 10 miles to work, battery dead, jump

alternator problem ,start engine the remove a battery terminal if engine stops renew the alternator

Posted on Nov 30, 2010

bayyagg
  • 1672 Answers

SOURCE: 1996 tercel, charge the battery it will start then

Hi,

Check if the alternator output is 13 volts to 14 volts or when the engine runs try to disconnect the negative (- ) terminal from the battery, if it still runs your alternator is okay. Just to check if that new alternator works.
If the procedure that I have told you is working, the battery must be brought to the nearest battery center, they have a load tester that will definintely assess the battery's condition if it really good or needs to be replace.

Hope that charge up the problem!

Thanks for using Fixya!

Posted on Dec 11, 2010

  • 2006 Answers

SOURCE: History: 2 days ago the

Replacing the fuse the first time was the right move, becuase it could have been a fluke that it blew. Replacing it again and again was not! You should have found out EVERYTHING that the #2 fuse controlled and verified that the components weren't pulling excessive amperage (shorted condition). By replacing the fuse over and over, you might have made the problem worse by subjecting good components to something that was shorted.

BTW next time pick the oldest guy at autozone to help you, if the counter help knew their stuff they would have told you the same thing I just did!

Posted on Sep 04, 2011

  • 436 Answers

SOURCE: Daughter called me ..car wont

it sounds like you have blown fuse to the Alternator.. I don't know what car you are talking about but they charging systems vary.. But if alternator isn't getting all the power it needs it won't charge. this should be checked.

good luck

Posted on Oct 21, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Location of blower motor


Make and model of the vehicle would be a big help to point you in the right direction. If the motor is making noise then the bushing are bad in the motor and it is going to have to be replace.

Oct 02, 2017 | 2002 Saturn L-Series

1 Answer

2003 Hyndai Elantra oil light has started flickering, Why?


If it flickers at idle, it "might" be engine wear, especially if you are approaching 200,000 miles. It might also be a faulty oil pressure gauge sending unit which is a little more likely.

Jan 24, 2012 | Hyundai Motor 2003 Elantra

1 Answer

When I turn on the ac or heater I notice that my engine starts making a funny noise. When I step on the accelator it sounds like a pulley is making a strange noise


you may have an a/c compressor clutch and or clutch bearing going bad. may be time for a new a/c compressor or compressor clutch assembly. the a/c comes on when you have the defrost or recirculation on in heater mode.

May 30, 2011 | 1996 Buick Century

1 Answer

My chevy beretta has no heat and i want to find a diagram of the fuse panel but i cant find one can anyone help me?


Is there air blowing out the vents? If not then you most likely have a bad blower motor relay. The relays are in you fuse box in the engine bay. Switch the horn and blower motor relay and see if the blower motor works then. If so they you have a bad relay. They can be picked up at any auto parts store.

If you have air blowing but its not hot then you have a cooling system issue. Check to make sure your coolant is full in the radiator and the overflow. Also make sure the car isn't overheating. Could be a bad thermostat, water pump, radiator or low on coolant. If low on coolant check for leaks.

Good Luck,
Subikid90

Mar 04, 2010 | 1995 Chevrolet Beretta

2 Answers

1996 Chevy Lumina Sedan Whining noise from engine


The pattern you describe is consistent with an alternator going bad. Maybe the fields are already rubbing together. Test it this way: Start the car and leave on idle, when the whine is worse, then start using up electricity, by increasing the demand. Turn on AC, then lights, then full blower and then high beams. If there is a change in the whine, then either alternator or voltage regulator is the culprit. When a compressor pulley bearing is bad, noise shifts just by turning AC on and off.

Jan 02, 2010 | 1995 Chevrolet Lumina

1 Answer

Serpentine Belt and pulley were replaced. Drove


High moisture with cheap belts would be a start. 2nd possibility is you have a bearing in an accesory drying out. Check water pump pully first with the screwdriver methode. Do not place on a moving part!!!

Nov 28, 2009 | 1998 Ford Windstar

1 Answer

I have a 96 dodge 1500 4x4 with the 5.9. when you turn on the heaterAC there is a loud humming noise that comes out of it kinda like the bearings in the blower motor are bad but its brand new. Any...


MUST OF THE TIME THERE ARE LEAVES OR OTHER THINGS STUCK INSIDE BLOWER MOTOR WHEEL AND CAUSE THE HUMMING NOISE, BUT IF YOU HAVE ELECTRIC MODE,BLEND DOOR MOTORS POSSIBLE MOTOR ACTUATOR IS GETTING BAD

Nov 18, 2009 | 1996 Dodge Ram

2 Answers

Car won't start, wait 15 min. will start but kinda backfires.


possible ignition coil pack breaking down...unit cools off them fires plugs again...fuel pressure is a concern also ..possible failing fuel pump

Jun 25, 2009 | 1995 Chevrolet Caprice Classic

2 Answers

Blower Motor trouble


It could be the fan switch is bad.

May 07, 2009 | 1996 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

52 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76673 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...